Overclock.net › Forums › Consumer Electronics › Video Cameras › Sony Vegas always out of sync
New Posts  All Forums:Forum Nav:

Sony Vegas always out of sync

post #1 of 5
Thread Starter 
I've been having trouble with Vegas lately in that when I drop in a recording of a video game, record a commentary over it, and then preview it, the recorded vocals gradually become more and more out of sync from the video, to the point where after about 10 minutes the recorded take is 5-6 seconds earlier than it should be.

If I simply click somewhere to start the project at that location, it "resets" the sync issue and everything is synced perfectly, and then the process of it gradually becoming out of sync starts over again from that location. This makes absolutely no sense to me, because when I look at the waveforms I can see that they are aligned correctly and are not out of sync at all.

The issue carries over into the rendered video and I've had to delete all of the rendered videos because they're so ridiculously out of sync that they're unwatchable, and the recorded commentary has nothing to do with what's on-screen at the time due to the sync issues.

I have this issue with multiple resolutions, framerates, etc. I've tried different project settings such as ensuring that the project settings are in line with the media settings and so on. The issue is obviously something in the project itself, not the rendering, because it occurs when previewing as well. Just to clarify, it's the recorded waveform that becomes out of sync, not the actual audio connected to the video (which is fine). I also set up some text markers throughout the timeline that correspond to different events in the video, and they always show up correctly whereas the audio is what's off, so I can say without a doubt that it is the recorded audio that's causing the problem.

I searched around and found a lot of people asking this question but no one answered it definitively. I've already wasted hours trying every possible combination of settings and nothing has worked. Is Vegas just a horribly-designed application or does anyone know of a way to fix this?
lol
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770k Gigabyte Z77X-UD4H EVGA GTX 1060 6GB G.SKILL 2x8GB 
Hard DriveOSMonitorKeyboard
Intel 120GB SSD Windows 7 [64-bit] Dell 30" Logitech 
CaseMouseMouse Pad
Thor Logitech none 
  hide details  
Reply
lol
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770k Gigabyte Z77X-UD4H EVGA GTX 1060 6GB G.SKILL 2x8GB 
Hard DriveOSMonitorKeyboard
Intel 120GB SSD Windows 7 [64-bit] Dell 30" Logitech 
CaseMouseMouse Pad
Thor Logitech none 
  hide details  
Reply
post #2 of 5
Vegas is not that bad... dont give up on it lol

im surprised that setting markers does not work as that was the first thing i thought of when i started reading your problem. maybe cut the video tracks so and use linking to make the audio snap in place. thats how i used to sync audio back in the day when i was first learning to edit and it never failed.

sorry your having so much problem i have not heard of it still not working after checking everything to make sure it all matches up
Montage mkIII
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700K ASUS ROG Maximus VIII Hero EVGA 980Ti Classified Corsair 16GB DDR4-3000 
Hard DriveHard DriveHard DriveCooling
Samsung 240GB EVO 850 Samsung 128GB EVO 830 Samsung 1TB EVO 850 CM 212EVO  
OSMonitorKeyboardPower
Win10 Dell U2713HM Logitech 810 EVGA Supernova 750W P2 
CaseMouseMouse PadAudio
Corsair 450D Razer Deathadder Steelpad QcK Audioengine D1 
Audio
Audio-technica ATH-A900X 
  hide details  
Reply
Montage mkIII
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700K ASUS ROG Maximus VIII Hero EVGA 980Ti Classified Corsair 16GB DDR4-3000 
Hard DriveHard DriveHard DriveCooling
Samsung 240GB EVO 850 Samsung 128GB EVO 830 Samsung 1TB EVO 850 CM 212EVO  
OSMonitorKeyboardPower
Win10 Dell U2713HM Logitech 810 EVGA Supernova 750W P2 
CaseMouseMouse PadAudio
Corsair 450D Razer Deathadder Steelpad QcK Audioengine D1 
Audio
Audio-technica ATH-A900X 
  hide details  
Reply
post #3 of 5
Thread Starter 
Oops ... I had a pitch shift on one of the tracks and somehow I accidentally unclicked the "preserve duration" box lol. So I couldn't tell the difference just by looking at it but it sped it up just enough to shave off a few seconds after enough time had passed.
lol
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770k Gigabyte Z77X-UD4H EVGA GTX 1060 6GB G.SKILL 2x8GB 
Hard DriveOSMonitorKeyboard
Intel 120GB SSD Windows 7 [64-bit] Dell 30" Logitech 
CaseMouseMouse Pad
Thor Logitech none 
  hide details  
Reply
lol
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7-3770k Gigabyte Z77X-UD4H EVGA GTX 1060 6GB G.SKILL 2x8GB 
Hard DriveOSMonitorKeyboard
Intel 120GB SSD Windows 7 [64-bit] Dell 30" Logitech 
CaseMouseMouse Pad
Thor Logitech none 
  hide details  
Reply
post #4 of 5
oh wow nice one lol
Montage mkIII
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700K ASUS ROG Maximus VIII Hero EVGA 980Ti Classified Corsair 16GB DDR4-3000 
Hard DriveHard DriveHard DriveCooling
Samsung 240GB EVO 850 Samsung 128GB EVO 830 Samsung 1TB EVO 850 CM 212EVO  
OSMonitorKeyboardPower
Win10 Dell U2713HM Logitech 810 EVGA Supernova 750W P2 
CaseMouseMouse PadAudio
Corsair 450D Razer Deathadder Steelpad QcK Audioengine D1 
Audio
Audio-technica ATH-A900X 
  hide details  
Reply
Montage mkIII
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7-6700K ASUS ROG Maximus VIII Hero EVGA 980Ti Classified Corsair 16GB DDR4-3000 
Hard DriveHard DriveHard DriveCooling
Samsung 240GB EVO 850 Samsung 128GB EVO 830 Samsung 1TB EVO 850 CM 212EVO  
OSMonitorKeyboardPower
Win10 Dell U2713HM Logitech 810 EVGA Supernova 750W P2 
CaseMouseMouse PadAudio
Corsair 450D Razer Deathadder Steelpad QcK Audioengine D1 
Audio
Audio-technica ATH-A900X 
  hide details  
Reply
post #5 of 5
Vegas is crap. Use avid, fcp, or Autodesk smoke. Anything else is a waste of time.
lv426
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k 4.5gHz HT enabled p8p67 Deluxe Rev 3 MSI GTX 570 FROZR III in SLI 16gb of Gskill Ripjaws 1600 
Hard DriveOSMonitorPower
x2 1TB 7200rpm dual boot Win7 64 Ult. & OSXx64 Hackintosh LG 42inch HD TV Kingwin Mach 1 - 1000w 
Case
Fractal Design Define XL Full Tower 
  hide details  
Reply
lv426
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k 4.5gHz HT enabled p8p67 Deluxe Rev 3 MSI GTX 570 FROZR III in SLI 16gb of Gskill Ripjaws 1600 
Hard DriveOSMonitorPower
x2 1TB 7200rpm dual boot Win7 64 Ult. & OSXx64 Hackintosh LG 42inch HD TV Kingwin Mach 1 - 1000w 
Case
Fractal Design Define XL Full Tower 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Video Cameras
Overclock.net › Forums › Consumer Electronics › Video Cameras › Sony Vegas always out of sync