post #1 of 1
Thread Starter 

Had this set for about a year and a half, and i've had a problem with the subwoofer i've been trying to ignore. It sounds good on most music i listen to, but when i crank up the sound to jam out, the sub starts peaking (or something) where it will vibrate but not produce bass notes.

Listening to music at a somewhat higher volume right now to give some examples of songs that sound fine and start peaking.

For reference, youtube volume is at 100%, windows volume is at 40%, the bass knob is at 12oclock, and the volume knob is at 11 oclock.

Fine:



Not fine:


Yes, its all electro/dubstep/house and the only type that makes my sub sound like garbage. I know its not a fantastic set, but should i contact klipsch about it or is it normal?
Edited by Higgins - 7/19/11 at 12:03pm
    
CPUMotherboardGraphicsRAM
Intel 2500k Gigabyte Z68X-UD3H-B3 XFX HD5870 16GB G.Skill RipjawsX 
Hard DriveOptical DriveCoolingOS
60GB OCZ Vertex 3 + 2x TB Seagate LG DVD+RW Stock Intel Windows 7 64bit / OSX Mountain Lion 
MonitorKeyboardPowerCase
Dell ST2210 + 17" IBM Das Ultimate S Antec TruePower 650W Antec P183 
MouseMouse PadAudioAudio
Logitech MX Revolution X-Trac Ripper Objective 2 + ODAC Combo Sennheiser HD650 + Klipsch 2.1 Promedia 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel 2500k Gigabyte Z68X-UD3H-B3 XFX HD5870 16GB G.Skill RipjawsX 
Hard DriveOptical DriveCoolingOS
60GB OCZ Vertex 3 + 2x TB Seagate LG DVD+RW Stock Intel Windows 7 64bit / OSX Mountain Lion 
MonitorKeyboardPowerCase
Dell ST2210 + 17" IBM Das Ultimate S Antec TruePower 650W Antec P183 
MouseMouse PadAudioAudio
Logitech MX Revolution X-Trac Ripper Objective 2 + ODAC Combo Sennheiser HD650 + Klipsch 2.1 Promedia 
  hide details  
Reply