post #11 of 11
Thread Starter 
Turns out I should have been running WoW in OpenGL mode (since I'm in linux). I get a smooth 30-60 FPS now with ultra settings. smile.gif Thanks everyone!