Overclock.net › Forums › Components › Sound Cards and Computer Audio › what is with this driver crap I hear about
New Posts  All Forums:Forum Nav:

what is with this driver crap I hear about - Page 5  

post #41 of 58
I didn't have any issues with any of the other X-Fis (Fata1ty or otherwise).

After putting my Titanium HD in my sig rig (Win 7; 64 bit) the drivers simply wouldn't install properly. The card would show up in the device manager, the driver installation software (from both the CD and Creative's site) would find the hardware, but after the installation it would still be unknown in my system, Creative's software would find but couldn't identify the card, and I'd get no audio from it.

After a couple hours of re-seating the card, uninstalling and sweeping drivers, etc. I found the PAX drivers online while trying to find a solution. I figured to give those a shot and sure enough, they worked just fine on the first install. My computer recognized the card, Creative's software saw it as a Titanium HD, and I got sound.

I love the card itself and never had an issue with Creative's drivers with the 3-4 prior cards I had installed in machines for myself or others, but for whatever reason the Titanium HD fought me. I haven't checked for updated drivers from Creative in a while so I don't know if it was just my PC being difficult or something on Creative's side, but at least I have the card working now.
Edited by frizo - 7/20/11 at 11:55am
TITAN
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6700K @ 4.6GHz ASUS Maximus VIII Whetstone 1080 Ti Hybrid 16GB G Skill Trident Z - 3200 
Hard DriveHard DriveHard DriveCooling
500GB Samsung 950 Pro - Boot 1TB Samsung 850 Evo 2x 500GB Samsung 850 Evo Corsair H115i 
OSMonitorPowerCase
Windows 10 Pro ASUS PG279Q Seasonic Prime Titanium 850 Corsair Carbide 540 
Audio
Schiit Gungnir (MB) -> Yamaha HS8 
  hide details  
TITAN
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-6700K @ 4.6GHz ASUS Maximus VIII Whetstone 1080 Ti Hybrid 16GB G Skill Trident Z - 3200 
Hard DriveHard DriveHard DriveCooling
500GB Samsung 950 Pro - Boot 1TB Samsung 850 Evo 2x 500GB Samsung 850 Evo Corsair H115i 
OSMonitorPowerCase
Windows 10 Pro ASUS PG279Q Seasonic Prime Titanium 850 Corsair Carbide 540 
Audio
Schiit Gungnir (MB) -> Yamaha HS8 
  hide details  
post #42 of 58
had a sound blaster live and i never had any problems... acually i think it was the only driver i didnt have problem with
Streamer/Gamer
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-5820K Asus X99-A Sapphire R9-290 Crucial Ballistics Sport 16gb 2400mhz 
Hard DriveHard DriveCoolingOS
OCZ Agility 3 60gb Seagate 1TB Corsair H100  Windows 10 64-bit 
MonitorKeyboardPowerCase
3x 22" 1080 monitors Logitech G510 Corsair HX620 Nzxt Switch 810 
MouseMouse PadAudio
Logitech G402 Steel series QCK cloth Logitech G930 headset 
  hide details  
Streamer/Gamer
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-5820K Asus X99-A Sapphire R9-290 Crucial Ballistics Sport 16gb 2400mhz 
Hard DriveHard DriveCoolingOS
OCZ Agility 3 60gb Seagate 1TB Corsair H100  Windows 10 64-bit 
MonitorKeyboardPowerCase
3x 22" 1080 monitors Logitech G510 Corsair HX620 Nzxt Switch 810 
MouseMouse PadAudio
Logitech G402 Steel series QCK cloth Logitech G930 headset 
  hide details  
post #43 of 58
no driver problems yet with my new Titanium HD in win7 32-bit. 10 years ago, also had a sound card (sound blaster). Dont recall any problems except maybe dealing with irq settings.

drivers are what some people blame when there is a mysterious, inexplicable problem and they do not know what else to blame.

Before you blame drivers, please do consider:

1. poorly compatible (or faulty) motherboard
2. Incorect bios settings (pci-e,pci,isa, ..., on-board sound on/off)
3. Incorrect OS settings (or corrupted/unpatched OS)
4. incorrect drivers or outdated drivers
5. inadequate power
6. other faulty hardware/firmware/software
7. ???
8. combination of the above
9. occasionally there is an actual driver problem.
     
CPUMotherboardGraphicsRAM
Athlon II X4 750k Asus F2A85-V MSI GTX 750 Ti Team 2x2GB 
Hard DriveCoolingOSMonitor
Kingston SSD V300 120GB Zalman CNPS5X performa + Arctic MX-4 Windows 7 64-bit Asus VW222 22" LCD 1680x1050 
PowerCase
FSP 460W Foxconn TSAA-426 
CPUMotherboardGraphicsRAM
Pentium G3258 @ 4.4 GHz ~1.38Vcore ~1.9Vccin Ri... MSI H81M-P33 Asus GTX 750 Ti OC + Thermalright HR-11 backsid... Transcend 2x2GB @ 1400MHz (5-7-5-18) ~1.62V 
Hard DriveCoolingOSMonitor
Intel SSD 330 240GB ZM CNPS5X (not performa) + 120mm fan (push) Windows 7 64bit Acer GD245HQ - 1920x1080 120Hz - Nvidia 3D Vision 
PowerCaseAudio
FSP 500W Enermax Phoenix Neo + 220mm Globefan (side) Creative Titanium HD + Beyer DT 880 - 250 ohm 
  hide details  
     
CPUMotherboardGraphicsRAM
Athlon II X4 750k Asus F2A85-V MSI GTX 750 Ti Team 2x2GB 
Hard DriveCoolingOSMonitor
Kingston SSD V300 120GB Zalman CNPS5X performa + Arctic MX-4 Windows 7 64-bit Asus VW222 22" LCD 1680x1050 
PowerCase
FSP 460W Foxconn TSAA-426 
CPUMotherboardGraphicsRAM
Pentium G3258 @ 4.4 GHz ~1.38Vcore ~1.9Vccin Ri... MSI H81M-P33 Asus GTX 750 Ti OC + Thermalright HR-11 backsid... Transcend 2x2GB @ 1400MHz (5-7-5-18) ~1.62V 
Hard DriveCoolingOSMonitor
Intel SSD 330 240GB ZM CNPS5X (not performa) + 120mm fan (push) Windows 7 64bit Acer GD245HQ - 1920x1080 120Hz - Nvidia 3D Vision 
PowerCaseAudio
FSP 500W Enermax Phoenix Neo + 220mm Globefan (side) Creative Titanium HD + Beyer DT 880 - 250 ohm 
  hide details  
post #44 of 58
Quote:
Originally Posted by Partol;14285875 
no driver problems yet with my new Titanium HD in win7 32-bit. 10 years ago, also had a sound card (sound blaster). Dont recall any problems except maybe dealing with irq settings.

drivers are what some people blame when there is a mysterious, inexplicable problem and they do not know what else to blame.

Before you blame drivers, please do consider:

1. poorly compatible (or faulty) motherboard
2. Incorect bios settings (pci-e,pci,isa, ..., on-board sound on/off)
3. Incorrect OS settings (or corrupted/unpatched OS)
4. incorrect drivers or outdated drivers
5. inadequate power
6. other faulty hardware/firmware/software
7. ???
8. combination of the above
9. occasionally there is an actual driver problem.


When your computer works perfectly and you install a sound card, you can probably guess that the sound card is at fault. Especially since many people switched from the X-fis to the Xonars and all their problems mysteriously went away. Your experience is pretty common, because the Titanium HD is the only creative card known to work (almost) flawlessly on W7 64bit, and 10 years ago was XP. The driver problems are for older cards on W7/Vista 64.
post #45 of 58
Thread Starter 
Quote:
Originally Posted by Partol;14285875 
no driver problems yet with my new Titanium HD in win7 32-bit. 10 years ago, also had a sound card (sound blaster). Dont recall any problems except maybe dealing with irq settings.

drivers are what some people blame when there is a mysterious, inexplicable problem and they do not know what else to blame.

Before you blame drivers, please do consider:

1. poorly compatible (or faulty) motherboard
2. Incorect bios settings (pci-e,pci,isa, ..., on-board sound on/off)
3. Incorrect OS settings (or corrupted/unpatched OS)
4. incorrect drivers or outdated drivers
5. inadequate power
6. other faulty hardware/firmware/software
7. ???
8. combination of the above
9. occasionally there is an actual driver problem.
this
OoGhiJ MIQtxxXA
(13 items)
 
  
CPUMotherboardGraphicsRAM
q9550 E0 @3.825ghz Abit IX48-GT3 Tigerforce SPARKLE GTX470 850c/1800m 220 650c sli later 4GB DDR3 Mushkin blackline 7-8-7-24-1T 1200mhz 
Hard DriveOptical DriveOSMonitor
WD1tb +WD500gb +WD200gb not like I need one edge linux LG 22" w2240 +optiquest q71 
KeyboardPowerCaseMouse
Adesso MKB-135B Mechanical DELTA GPS-750B A 750w sleeved moded Kandalf LCS Razer Mamba 
Mouse Pad
don't got one or need one 
  hide details  
OoGhiJ MIQtxxXA
(13 items)
 
  
CPUMotherboardGraphicsRAM
q9550 E0 @3.825ghz Abit IX48-GT3 Tigerforce SPARKLE GTX470 850c/1800m 220 650c sli later 4GB DDR3 Mushkin blackline 7-8-7-24-1T 1200mhz 
Hard DriveOptical DriveOSMonitor
WD1tb +WD500gb +WD200gb not like I need one edge linux LG 22" w2240 +optiquest q71 
KeyboardPowerCaseMouse
Adesso MKB-135B Mechanical DELTA GPS-750B A 750w sleeved moded Kandalf LCS Razer Mamba 
Mouse Pad
don't got one or need one 
  hide details  
post #46 of 58
Quote:
Originally Posted by Narzon;14286355 
Your experience is pretty common, because the Titanium HD is the only creative card known to work (almost) flawlessly on W7 64bit, and 10 years ago was XP. The driver problems are for older cards on W7/Vista 64.

I think its unreasonable to expect good windows 7 or vista drivers for hardware that was designed before those OS's existed. The common problem I see on forums is ....

new card with old motherboard .... or
old card with new motherboard ..... or
old card and/or old motherboard with new OS

To ensure hardware/software compatibility, it's better that all hardware/software are from the same "generation".

Honestly, if I was CEO at a big card manufactuer, I would spend little time and resources on customers who only spend $50-100 every 10 years on a budget sound card. I would give much more attention to richer customers who upgrade their hardware/software every few years.

Yes, I agree, it would not surprise me to see some driver problems when running a 5-10 year old sound card in vista or 7. I see the Titanium HD is listed as not supported in xp. Maybe Creative does not care much about old OS or old hardware. Good news is that new sound cards are not so expensive when compared to new graphics cards,cpu's,motherboards.
Edited by Partol - 7/20/11 at 5:31pm
     
CPUMotherboardGraphicsRAM
Athlon II X4 750k Asus F2A85-V MSI GTX 750 Ti Team 2x2GB 
Hard DriveCoolingOSMonitor
Kingston SSD V300 120GB Zalman CNPS5X performa + Arctic MX-4 Windows 7 64-bit Asus VW222 22" LCD 1680x1050 
PowerCase
FSP 460W Foxconn TSAA-426 
CPUMotherboardGraphicsRAM
Pentium G3258 @ 4.4 GHz ~1.38Vcore ~1.9Vccin Ri... MSI H81M-P33 Asus GTX 750 Ti OC + Thermalright HR-11 backsid... Transcend 2x2GB @ 1400MHz (5-7-5-18) ~1.62V 
Hard DriveCoolingOSMonitor
Intel SSD 330 240GB ZM CNPS5X (not performa) + 120mm fan (push) Windows 7 64bit Acer GD245HQ - 1920x1080 120Hz - Nvidia 3D Vision 
PowerCaseAudio
FSP 500W Enermax Phoenix Neo + 220mm Globefan (side) Creative Titanium HD + Beyer DT 880 - 250 ohm 
  hide details  
     
CPUMotherboardGraphicsRAM
Athlon II X4 750k Asus F2A85-V MSI GTX 750 Ti Team 2x2GB 
Hard DriveCoolingOSMonitor
Kingston SSD V300 120GB Zalman CNPS5X performa + Arctic MX-4 Windows 7 64-bit Asus VW222 22" LCD 1680x1050 
PowerCase
FSP 460W Foxconn TSAA-426 
CPUMotherboardGraphicsRAM
Pentium G3258 @ 4.4 GHz ~1.38Vcore ~1.9Vccin Ri... MSI H81M-P33 Asus GTX 750 Ti OC + Thermalright HR-11 backsid... Transcend 2x2GB @ 1400MHz (5-7-5-18) ~1.62V 
Hard DriveCoolingOSMonitor
Intel SSD 330 240GB ZM CNPS5X (not performa) + 120mm fan (push) Windows 7 64bit Acer GD245HQ - 1920x1080 120Hz - Nvidia 3D Vision 
PowerCaseAudio
FSP 500W Enermax Phoenix Neo + 220mm Globefan (side) Creative Titanium HD + Beyer DT 880 - 250 ohm 
  hide details  
post #47 of 58
You ppl DO know that part of the problem had to do with the fact that MS completely messed with the sound stack settings and stopped native hardware support for sound when Vista dropped.
Right?
Creative suddenly found themselves with an entire product line that had drivers that didn't work for their target OS. In addition to hardware that wasn't optimized.
I think they did a pretty good job of trying to climb that mountain.
I just don't care for the bloatware involved in the Creative drivers. If I want an audio creation program I'll get a REAL audio creation program.
Blue Fury
(19 items)
 
  
CPUMotherboardGraphicsRAM
AMD A8 6600k asus Sapphire 290X Tri-OCX 4GB 2x4 (8)GB G-Skill Ripjaws 1600 
Hard DriveHard DriveHard DriveHard Drive
OCZVertex3 60GB Seagate 1TB WD 500GB Samsung 
Hard DriveOptical DriveCoolingOS
Samsung Evo 850 ASUS DVDRW24x Corsair H100 W10 
MonitorKeyboardPowerCase
55" 4k Hisense Razer Blackwidow Ultimate 2013 Corsair CX750 AzzA Hurrican 
MouseMouse PadAudio
Razer Deathadder 3500 Diablo3 RoS LE onboard 
  hide details  
Blue Fury
(19 items)
 
  
CPUMotherboardGraphicsRAM
AMD A8 6600k asus Sapphire 290X Tri-OCX 4GB 2x4 (8)GB G-Skill Ripjaws 1600 
Hard DriveHard DriveHard DriveHard Drive
OCZVertex3 60GB Seagate 1TB WD 500GB Samsung 
Hard DriveOptical DriveCoolingOS
Samsung Evo 850 ASUS DVDRW24x Corsair H100 W10 
MonitorKeyboardPowerCase
55" 4k Hisense Razer Blackwidow Ultimate 2013 Corsair CX750 AzzA Hurrican 
MouseMouse PadAudio
Razer Deathadder 3500 Diablo3 RoS LE onboard 
  hide details  
post #48 of 58
Thread Starter 
I completely forgot that

you know that's probably the main reason why there are problems
or at lest one of them
Edited by 3dfxvoodoo - 7/20/11 at 5:51pm
OoGhiJ MIQtxxXA
(13 items)
 
  
CPUMotherboardGraphicsRAM
q9550 E0 @3.825ghz Abit IX48-GT3 Tigerforce SPARKLE GTX470 850c/1800m 220 650c sli later 4GB DDR3 Mushkin blackline 7-8-7-24-1T 1200mhz 
Hard DriveOptical DriveOSMonitor
WD1tb +WD500gb +WD200gb not like I need one edge linux LG 22" w2240 +optiquest q71 
KeyboardPowerCaseMouse
Adesso MKB-135B Mechanical DELTA GPS-750B A 750w sleeved moded Kandalf LCS Razer Mamba 
Mouse Pad
don't got one or need one 
  hide details  
OoGhiJ MIQtxxXA
(13 items)
 
  
CPUMotherboardGraphicsRAM
q9550 E0 @3.825ghz Abit IX48-GT3 Tigerforce SPARKLE GTX470 850c/1800m 220 650c sli later 4GB DDR3 Mushkin blackline 7-8-7-24-1T 1200mhz 
Hard DriveOptical DriveOSMonitor
WD1tb +WD500gb +WD200gb not like I need one edge linux LG 22" w2240 +optiquest q71 
KeyboardPowerCaseMouse
Adesso MKB-135B Mechanical DELTA GPS-750B A 750w sleeved moded Kandalf LCS Razer Mamba 
Mouse Pad
don't got one or need one 
  hide details  
post #49 of 58
I never have really had any issues with any of the Creative cards. Back when I had some of the lower end cards the mode switcher would screw up sometimes or even fail to open but the Titanium HD is totally problem free once I figured out why my mic wasn't working.
SFF Goodness
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770k ASRock z87m OC formula MSI GTX 780 GAMING 8GB G Skill Ripjaw DDR3 2400MHz 
Hard DriveHard DriveCoolingOS
SanDisk Extreme II 480 GB Seagate 2TB Noctua NH-D14 Windows 8.1 Pro 
MonitorKeyboardPowerCase
Dell U2312HM x3 Das Model S Professional Silverstone Strider Gold Evolution 750w Silverstone SG10 
MouseAudioAudioAudio
Logitech G500 Xfi Titanium HD Audioengine 5+ Velodyne Impact 12 
  hide details  
SFF Goodness
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 4770k ASRock z87m OC formula MSI GTX 780 GAMING 8GB G Skill Ripjaw DDR3 2400MHz 
Hard DriveHard DriveCoolingOS
SanDisk Extreme II 480 GB Seagate 2TB Noctua NH-D14 Windows 8.1 Pro 
MonitorKeyboardPowerCase
Dell U2312HM x3 Das Model S Professional Silverstone Strider Gold Evolution 750w Silverstone SG10 
MouseAudioAudioAudio
Logitech G500 Xfi Titanium HD Audioengine 5+ Velodyne Impact 12 
  hide details  
post #50 of 58
BREAKING NEWS

This just in:

If anyone doesn't have a problem with a piece a hardware and its drivers how they use them means anyone else who uses other various options with any number of different hardware configurations, driver versions, and OSs and has problems is a "noob."

Tune in tonight at 6 for more info. *derp*
Bueller
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K 4.7Ghz @ 1.36v Asus Sabertooth Z77 Gigabyte Windforce 780 Ti 3GB 16GB Corsair Vengeance 1866 9-10-9-27 
Hard DriveOptical DriveCoolingOS
256GB Samsung 840 Pro + RAID1 2TB 7200 Hitachis LG 6X Blu-ray Burner Corsair H100i Windows 7 x64 
MonitorKeyboardPowerCase
Asus VG236HE XArmor U9BL-S Enermax Galaxy Evo 1250W Corsair 600T 
MouseMouse PadAudio
Logitech G500 SteelSeries 5L O2DAC -> Corsair SP2500 (or O2 amp and Beyerdyn... 
  hide details  
Bueller
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 3770K 4.7Ghz @ 1.36v Asus Sabertooth Z77 Gigabyte Windforce 780 Ti 3GB 16GB Corsair Vengeance 1866 9-10-9-27 
Hard DriveOptical DriveCoolingOS
256GB Samsung 840 Pro + RAID1 2TB 7200 Hitachis LG 6X Blu-ray Burner Corsair H100i Windows 7 x64 
MonitorKeyboardPowerCase
Asus VG236HE XArmor U9BL-S Enermax Galaxy Evo 1250W Corsair 600T 
MouseMouse PadAudio
Logitech G500 SteelSeries 5L O2DAC -> Corsair SP2500 (or O2 amp and Beyerdyn... 
  hide details  
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
This thread is locked  
Overclock.net › Forums › Components › Sound Cards and Computer Audio › what is with this driver crap I hear about