Overclock.net › Forums › Graphics Cards › AMD/ATI › Low Fps in SC2 from 5870?
New Posts  All Forums:Forum Nav:

Low Fps in SC2 from 5870?

post #1 of 20
Thread Starter 
Hello everyone,

i recent built a Sb i5 2500k with 8gb ram and corsair 750tx psu. I am also using my gpu diamond 5870 from sig rig.

In my c2q system, i was getting decent fps, around 60, when i was playing sc2
So when i moved the gpu to my sandy bridge, i thought my fps would jump a lot

BUT sadly, my fps has dropped to around 20-40.. what seems to the problem??

Any benchmark to see if the card is workinng correctly? Maybe when i was transferring card from 1 location to another, a bump might damaged the card ?


Both rigs run the same 5870 about 36 fps but for my testing on my 775 rig, the circled red gpu reading is very weird... Any comments on that?


Edited by lazi punk - 7/20/11 at 11:53pm
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel SB I5-2500k  MSI g43 p8p67 ATI Radeon Diamond 5870 8GB g-skill  
CoolingOSMonitorPower
Hyper 212+ Windows 7 Ultimate x64 22' samsung HD 22 Antec true gaming 520watts 
Mouse
Rose will destroyer 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel SB I5-2500k  MSI g43 p8p67 ATI Radeon Diamond 5870 8GB g-skill  
CoolingOSMonitorPower
Hyper 212+ Windows 7 Ultimate x64 22' samsung HD 22 Antec true gaming 520watts 
Mouse
Rose will destroyer 
  hide details  
Reply
post #2 of 20
What are your settings? AA forced in CCC? Settings used for previous system? Drivers? Did you try anything?
     
CPUMotherboardGraphicsRAM
Intel Core i3 4150 Gigabyte  Gigabyte Geforce GTX 1050 Ti 8GB DDR3 
OSMonitorPowerCase
Windows 10 x64 Samsung BX2450 300 Watt Bitfenix 
Audio
Small Amp + Pair of Realistic Minimus 26 
CPUMotherboardGraphicsRAM
Intel Core i5 4570 H81 EVGA Geforce GTX 750 Ti 8GB 1600Mhz DDR3 
Hard DriveOSMonitor
Western Digital 1TB 7200 RPM  Windows 10 Pro x64 HP w2007 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i3 4150 Gigabyte  Gigabyte Geforce GTX 1050 Ti 8GB DDR3 
OSMonitorPowerCase
Windows 10 x64 Samsung BX2450 300 Watt Bitfenix 
Audio
Small Amp + Pair of Realistic Minimus 26 
CPUMotherboardGraphicsRAM
Intel Core i5 4570 H81 EVGA Geforce GTX 750 Ti 8GB 1600Mhz DDR3 
Hard DriveOSMonitor
Western Digital 1TB 7200 RPM  Windows 10 Pro x64 HP w2007 
  hide details  
Reply
post #3 of 20
Try using MSI AfterBurner to monitor the GPU usage, and check to see whether the core/mem clocks are going to 3D mode.. When that happened to me, I saw that my 5850 was stuck in idle/2D clocks for some strange reason. I suspect yours might be doing the same.
 
dm1z
(13 items)
 
 
CPUMotherboardGraphicsRAM
2500K P8P67 Evo MSI RX 480 Sniper|1600 
Hard DriveCoolingOSMonitor
Intel 330 Hyper 212+ Win8-x64 P2310H + P2311H 
PowerCase
CMPSU-650TX NZXT S340 
CPUGraphicsRAMHard Drive
Dual-Core E-350 Radeon HD 6310M 3GB DDR3 HDD 
Optical DriveOSMonitorMouse
HP External BluRay/DVD Windows 7 Home Premium 11.6" LED (1366 x 768) Touch 
CPUMotherboardGraphicsRAM
Phenom II 840T 880GM-LE GTS 450 Corsair XMS2 2x2GB 
Hard DriveOptical DriveCoolingOS
Caviar Green 1TB LG Scythe KATANA 3 Windows 7 Professional 32-bit 
PowerCase
CX430 V2 Dell 
  hide details  
Reply
 
dm1z
(13 items)
 
 
CPUMotherboardGraphicsRAM
2500K P8P67 Evo MSI RX 480 Sniper|1600 
Hard DriveCoolingOSMonitor
Intel 330 Hyper 212+ Win8-x64 P2310H + P2311H 
PowerCase
CMPSU-650TX NZXT S340 
CPUGraphicsRAMHard Drive
Dual-Core E-350 Radeon HD 6310M 3GB DDR3 HDD 
Optical DriveOSMonitorMouse
HP External BluRay/DVD Windows 7 Home Premium 11.6" LED (1366 x 768) Touch 
CPUMotherboardGraphicsRAM
Phenom II 840T 880GM-LE GTS 450 Corsair XMS2 2x2GB 
Hard DriveOptical DriveCoolingOS
Caviar Green 1TB LG Scythe KATANA 3 Windows 7 Professional 32-bit 
PowerCase
CX430 V2 Dell 
  hide details  
Reply
post #4 of 20
Thread Starter 
its a new system and no previous drivers were instaslled. I just wanted to play sc so i didnt download any drivers from ati. It was automatically installed via windows. If i have to guess, its one of the old drivers.

Is there any programs out there i can test the card to see if it's working correctly? I only know fraps
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel SB I5-2500k  MSI g43 p8p67 ATI Radeon Diamond 5870 8GB g-skill  
CoolingOSMonitorPower
Hyper 212+ Windows 7 Ultimate x64 22' samsung HD 22 Antec true gaming 520watts 
Mouse
Rose will destroyer 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel SB I5-2500k  MSI g43 p8p67 ATI Radeon Diamond 5870 8GB g-skill  
CoolingOSMonitorPower
Hyper 212+ Windows 7 Ultimate x64 22' samsung HD 22 Antec true gaming 520watts 
Mouse
Rose will destroyer 
  hide details  
Reply
post #5 of 20
Download the new drivers. Chances are you're still on integrated if you haven't touched any drivers at all.

Also get MSI Afterburner like onoz has already suggested.
The Beast
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k @ 4.8GHz (1.40v) ASUS P8P67-M PRO Sapphire HD 6950 2GB 8GB Ripjaws-X 1600Mhz 
Hard DriveOSMonitorKeyboard
Samsung SpinPoint 500GB @ 7200RPM Windows 7 Ultimate x64 Dell 24" UltraSharp U2412M IPS Steelseries 7G 
PowerCaseMouseMouse Pad
Corsair HX 850W Xion (white) Steelseries Xai Steelseries 9HD 
Audio
Sennheiser HD 650 w/ Fiio E7+E9 
  hide details  
Reply
The Beast
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k @ 4.8GHz (1.40v) ASUS P8P67-M PRO Sapphire HD 6950 2GB 8GB Ripjaws-X 1600Mhz 
Hard DriveOSMonitorKeyboard
Samsung SpinPoint 500GB @ 7200RPM Windows 7 Ultimate x64 Dell 24" UltraSharp U2412M IPS Steelseries 7G 
PowerCaseMouseMouse Pad
Corsair HX 850W Xion (white) Steelseries Xai Steelseries 9HD 
Audio
Sennheiser HD 650 w/ Fiio E7+E9 
  hide details  
Reply
post #6 of 20
Quote:
Originally Posted by Goaky View Post
Download the new drivers. Chances are you're still on integrated if you haven't touched any drivers at all.

Also get MSI Afterburner like onoz has already suggested.
Umm, what integrated? He's using i5 2500K?

Edit: Does i5 2500K have a IGP?
post #7 of 20
lol.... You ALWAYS have to install video drivers, no matter how giddy you are to play with your new toy. The drivers are it, when you installl them you will see immense increases in every area of video output from your video card. Your probably using integrated generic drivers which pretty much just force basic video output via DVI/HDMI.

Please dont ever skip the driver phase lol. Lesson learned eh?
post #8 of 20
Thread Starter 
Quote:
Originally Posted by Goaky View Post
Download the new drivers. Chances are you're still on integrated if you haven't touched any drivers at all.

Also get MSI Afterburner like onoz has already suggested.
i dont think so, after windows installed driver, i was able to play sc and hdmi would produce sound ouput. Device manager says hd5800 series as well..

Quote:
Originally Posted by Tuxi View Post
Umm, what integrated? He's using i5 2500K?

Edit: Does i5 2500K have a IGP?
SB has integrated gpu but p67 board doesnt have that function.

Quote:
Originally Posted by Add3r View Post
lol.... You ALWAYS have to install video drivers, no matter how giddy you are to play with your new toy. The drivers are it, when you install them you will see immense increases in every area of video output from your video card. Your probably using integrated generic drivers which pretty much just force basic video output via DVI/HDMI.

Please dont ever skip the driver phase lol. Lesson learned eh?
i will try that and see if anything changes


BUT before this SB setup, i was running on windows installed drivers as well on my 775 system and everythign was fine?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel SB I5-2500k  MSI g43 p8p67 ATI Radeon Diamond 5870 8GB g-skill  
CoolingOSMonitorPower
Hyper 212+ Windows 7 Ultimate x64 22' samsung HD 22 Antec true gaming 520watts 
Mouse
Rose will destroyer 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel SB I5-2500k  MSI g43 p8p67 ATI Radeon Diamond 5870 8GB g-skill  
CoolingOSMonitorPower
Hyper 212+ Windows 7 Ultimate x64 22' samsung HD 22 Antec true gaming 520watts 
Mouse
Rose will destroyer 
  hide details  
Reply
post #9 of 20
Trust us. you need to install the drivers manually for every component to get the best performance. The windows drivers aren't always up to date. Make sure your chipset and bios are also up to date.
Blue Giant
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 3820 Asus P9X79 MSI GTX 570 in SLI RipjawsX 16GB DDR3 1600 8-8-8-24 
Hard DriveOptical DriveCoolingOS
2TB WD Black Blu-Ray Reader Custom Water Cooling Windows 7 Professional 
PowerCaseAudio
KINGWIN Mach 1 1000w AZZA Solano 1000 Xonar DG 
  hide details  
Reply
Blue Giant
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7 3820 Asus P9X79 MSI GTX 570 in SLI RipjawsX 16GB DDR3 1600 8-8-8-24 
Hard DriveOptical DriveCoolingOS
2TB WD Black Blu-Ray Reader Custom Water Cooling Windows 7 Professional 
PowerCaseAudio
KINGWIN Mach 1 1000w AZZA Solano 1000 Xonar DG 
  hide details  
Reply
post #10 of 20
In device Manager, Right click and select "DELETE driver" if it's there for the graphics card. This way it won't reinstall MS' own ATI drivers. Only the standard vga driver which is normal.
Intel Evilnow
(18 items)
 
   
CPUMotherboardGraphicsRAM
i5 2500k 4ghz @ Offset -0.015 Asus P8P67 Evo (bios 3207) Sapphire 280x Tri-x 3GB OC (Stock 1020/1500 Non... G.Skill RipjawsX 2x4gb 1866mhz 9-10-9-28-2n @ 1.5v 
Hard DriveHard DriveHard DriveHard Drive
SHSS37A120G WD5000AAKX-001CA0 WD20EARX WD20EZRZ 
Hard DriveOptical DriveCoolingOS
WD5001AALS-00L3B2 (Now External) ASUS DRW-1814BLT Noctua NH-u12p SE2 Windows 10 Pro 
MonitorKeyboardPowerCase
Asus VH242H Wobbly Stand :) Microsoft Ergo 4000 Enermax Infiniti 650 (28a,28a,30a) Cooler Master haf 912 Advanced 
MouseOther
A4tech x7 F3 Sunbeam RHK-EX-BA Rheobus-Extreme Fan Controlle... 
CPUMotherboardGraphicsRAM
Phenom II x6 1090t BE 3.6/4.0 Turbo@def.volt MSI K9A2 Platinum v1 Sapphire HD6850 1GB 850/1100@def.volt Kingston 2x2gb Hyperx 1066 5-5-5-15 
Hard DriveHard DriveOptical DriveOS
Western Digital WD5001AALS Seagate Barracuda ST3250410AS Asus DRW-1814BLT Windows 7 Ultimate x64 SP1 
MonitorKeyboardPowerCase
Asus VH242H 23.6" Wobbly Stand :D Microsoft Ergo 4000 Enermax Infiniti 650w (28a,28a,30a) Thermaltake Kandalf SuperTower 
Mouse
A4 tech Swop-3 
  hide details  
Reply
Intel Evilnow
(18 items)
 
   
CPUMotherboardGraphicsRAM
i5 2500k 4ghz @ Offset -0.015 Asus P8P67 Evo (bios 3207) Sapphire 280x Tri-x 3GB OC (Stock 1020/1500 Non... G.Skill RipjawsX 2x4gb 1866mhz 9-10-9-28-2n @ 1.5v 
Hard DriveHard DriveHard DriveHard Drive
SHSS37A120G WD5000AAKX-001CA0 WD20EARX WD20EZRZ 
Hard DriveOptical DriveCoolingOS
WD5001AALS-00L3B2 (Now External) ASUS DRW-1814BLT Noctua NH-u12p SE2 Windows 10 Pro 
MonitorKeyboardPowerCase
Asus VH242H Wobbly Stand :) Microsoft Ergo 4000 Enermax Infiniti 650 (28a,28a,30a) Cooler Master haf 912 Advanced 
MouseOther
A4tech x7 F3 Sunbeam RHK-EX-BA Rheobus-Extreme Fan Controlle... 
CPUMotherboardGraphicsRAM
Phenom II x6 1090t BE 3.6/4.0 Turbo@def.volt MSI K9A2 Platinum v1 Sapphire HD6850 1GB 850/1100@def.volt Kingston 2x2gb Hyperx 1066 5-5-5-15 
Hard DriveHard DriveOptical DriveOS
Western Digital WD5001AALS Seagate Barracuda ST3250410AS Asus DRW-1814BLT Windows 7 Ultimate x64 SP1 
MonitorKeyboardPowerCase
Asus VH242H 23.6" Wobbly Stand :D Microsoft Ergo 4000 Enermax Infiniti 650w (28a,28a,30a) Thermaltake Kandalf SuperTower 
Mouse
A4 tech Swop-3 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Low Fps in SC2 from 5870?