Overclock.net › Forums › Components › Sound Cards and Computer Audio › Can't enable 5.1 on Creative X-Fi
New Posts  All Forums:Forum Nav:

Can't enable 5.1 on Creative X-Fi

post #1 of 4
Thread Starter 
Hello

I've been trying to enable 5.1 audio on my setup, but I seem to be having some problems. I am using a Creative X-Fi Titanium Fatality paired with a set of Logitech Z-906 speakers, over analog connection. Both the speakers and the sound card are set to use 5.1, but when I go into the audio testing mode, this happens:

• If I test the front left satellite, sound comes out of both front and rear left satellites.
• If I test the front right satellite, sound comes out of both front and rear right satellites.
• If I test the subwoofer, center channel, or either rear channel, nothing happens.

I've tested all 5 speakers, and they are all working. I've also double checked all connections, and like I said, 5.1 is enabled on the speaker control deck. What is wrong here?

Cheers
Normandy
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600k @ 4.6GHz ASUS P8P67 Deluxe 2x MSI GTX580 Lightning 8GB Corsair Vengeance 1866MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 2TB Samsung SH-B123L Blu-Ray Windows 7 Ultimate x64 Alienware OptX AW2310 
KeyboardPowerCaseMouse
Logitech G510 Corsair AX1200 Corsair Obsidian 800D Logitech G700 
Mouse Pad
Razer Goliathus Extended 
  hide details  
Reply
Normandy
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600k @ 4.6GHz ASUS P8P67 Deluxe 2x MSI GTX580 Lightning 8GB Corsair Vengeance 1866MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 2TB Samsung SH-B123L Blu-Ray Windows 7 Ultimate x64 Alienware OptX AW2310 
KeyboardPowerCaseMouse
Logitech G510 Corsair AX1200 Corsair Obsidian 800D Logitech G700 
Mouse Pad
Razer Goliathus Extended 
  hide details  
Reply
post #2 of 4
Any chance you plugged in side speakers to the front/back inputs? That's really what it sounds like. Get your sound card and speaker manuals just to make sure.
post #3 of 4
i had this happening on my Z-5500s aswell the reason was i just plugged them in the wrong spots on the back of the subwoofer haha ;D + also check the analog cables that go in the sound card because they can do such things also
600T Awesomeness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K 4.3 GHz @ 1.22v MSI Z77A-G43 GeForce GTX 570 Twin Frozr II Corsair Vengeance LP 8 GB DDR3-1600 Kit 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB SSD - Barracuda Green 2TB Noctua NH-D14 Windows 7 Ultimate 64-bit Samsung SyncMaster 2333HD 
KeyboardPowerCaseMouse
Logitech G510 Gaming keyboard Corsair HX750W Corsair 600T Logitech G9x Gaming Laser Mouse 
  hide details  
Reply
600T Awesomeness
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 3570K 4.3 GHz @ 1.22v MSI Z77A-G43 GeForce GTX 570 Twin Frozr II Corsair Vengeance LP 8 GB DDR3-1600 Kit 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB SSD - Barracuda Green 2TB Noctua NH-D14 Windows 7 Ultimate 64-bit Samsung SyncMaster 2333HD 
KeyboardPowerCaseMouse
Logitech G510 Gaming keyboard Corsair HX750W Corsair 600T Logitech G9x Gaming Laser Mouse 
  hide details  
Reply
post #4 of 4
Thread Starter 
Figured out what it was. Apparently I shouldn't have any effects selected on the Z-906 control deck, since those are for surround emulation. Guess I should read instruction manuals every now and then biggrin.gif

Regardless, thanks for the help! + Rep
Normandy
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600k @ 4.6GHz ASUS P8P67 Deluxe 2x MSI GTX580 Lightning 8GB Corsair Vengeance 1866MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 2TB Samsung SH-B123L Blu-Ray Windows 7 Ultimate x64 Alienware OptX AW2310 
KeyboardPowerCaseMouse
Logitech G510 Corsair AX1200 Corsair Obsidian 800D Logitech G700 
Mouse Pad
Razer Goliathus Extended 
  hide details  
Reply
Normandy
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 2600k @ 4.6GHz ASUS P8P67 Deluxe 2x MSI GTX580 Lightning 8GB Corsair Vengeance 1866MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 2TB Samsung SH-B123L Blu-Ray Windows 7 Ultimate x64 Alienware OptX AW2310 
KeyboardPowerCaseMouse
Logitech G510 Corsair AX1200 Corsair Obsidian 800D Logitech G700 
Mouse Pad
Razer Goliathus Extended 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Can't enable 5.1 on Creative X-Fi