Overclock.net › Forums › AMD › AMD - General › New Build, Won't turn On
New Posts  All Forums:Forum Nav:

New Build, Won't turn On

post #1 of 19
Thread Starter 
I just finished my new sig rig, and when I press the power button nothing happens. It doesn't turn on, it doesn't do anything. I didn't use standoffs because the case manual specifically said not to, and it only came with 2. What could the problem be?
post #2 of 19
The standoffs are a ground, you need those.

You do have the ATX power connector plugged in, right? And the CPU power connector?

Is your CMOS cleared?
The Butthurt Box
(21 items)
 
   
CPUMotherboardGraphicsGraphics
Intel Core i5 2500K P67 Professional AMD Radeon HD 6950 unlock NVIDIA GeForce GTX 460 2gb 
RAMRAMHard DriveHard Drive
G.Skill Ripjaws G.Skill Ripjaws Intel X25-V Seagate Barracuda 
Hard DriveOptical DriveOSMonitor
WD Goflex USB 3.0 24x DVD R/W DL Win7 Ultermate 64 Acer 20in 1600x900 
MonitorMonitorMonitorKeyboard
Compaq 20in 1600x900 17in Dell 1280x1024 19in Gateway 1280x1024 Razer Blackwidow mech w/ cherry MX blues 
PowerCaseMouseAudio
Kingwin LZ-750 HAF 932 + sound activated lights Logitech G500 Rosewill USB headset 
CPUMotherboardGraphicsRAM
Pentium 4 3.2ghz w/ HT HP Intel IGP 4gb Mushkin DDR2 
Hard DriveOSPowerCase
80gb sata WinXP Pro HP OEM HP Small form factor 
  hide details  
Reply
The Butthurt Box
(21 items)
 
   
CPUMotherboardGraphicsGraphics
Intel Core i5 2500K P67 Professional AMD Radeon HD 6950 unlock NVIDIA GeForce GTX 460 2gb 
RAMRAMHard DriveHard Drive
G.Skill Ripjaws G.Skill Ripjaws Intel X25-V Seagate Barracuda 
Hard DriveOptical DriveOSMonitor
WD Goflex USB 3.0 24x DVD R/W DL Win7 Ultermate 64 Acer 20in 1600x900 
MonitorMonitorMonitorKeyboard
Compaq 20in 1600x900 17in Dell 1280x1024 19in Gateway 1280x1024 Razer Blackwidow mech w/ cherry MX blues 
PowerCaseMouseAudio
Kingwin LZ-750 HAF 932 + sound activated lights Logitech G500 Rosewill USB headset 
CPUMotherboardGraphicsRAM
Pentium 4 3.2ghz w/ HT HP Intel IGP 4gb Mushkin DDR2 
Hard DriveOSPowerCase
80gb sata WinXP Pro HP OEM HP Small form factor 
  hide details  
Reply
post #3 of 19
Thread Starter 
It only came with 2 though...it says if it's ATX don't use them.
post #4 of 19
Are any of the motherboards LEDs on? if not the PSU might be DOA or perhaps the motherboard.
If there are any LED's on read which one is red and it will tell you where the problem is coming from.
Dark Wasp
(13 items)
 
Zebra II
(19 items)
 
Water Arc Mini
(16 items)
 
CPUMotherboardGraphicsRAM
i7 7700K Asus ROG Z270 Code 2x GTX 980 Ti SC Corsair Dominator 16GB DDR4 @3200 
Hard DriveHard DriveOSMonitor
Samsung 960 Evo M.2 Samsung 850 Pro 1 TB Windows 10 LG 34UM95 3440x1440 34" 
KeyboardPowerCaseMouse
WASD mechanical brown swithces Seasonic 850w Platinum Caselabs Merlin SM8 Black Razer Deathadder Chroma 
Audio
Audioengine A2 + D1 DAC 
CPUMotherboardGraphicsRAM
i7 3770k  Asus Maximus V Gene Asus GTX 670 DCII  Samsung 8GB @1866 
Hard DriveCoolingCoolingCooling
Samsung 830 Series 256GB SSD EK Supremacy Acetal nickel Dual 240 Black Ice GT Stealth EK GTX 670 DCII waterblock 
MonitorKeyboardPowerCase
Dell ultrasharp U2412m WASD mechanical keyboard Corsair AX750 Fractal Arc Mini 
MouseMouse PadAudioAudio
Steelseries Sensei Razer Megasoma Audioengine A2 Beyerdynamic Custom One Pro 
  hide details  
Reply
Dark Wasp
(13 items)
 
Zebra II
(19 items)
 
Water Arc Mini
(16 items)
 
CPUMotherboardGraphicsRAM
i7 7700K Asus ROG Z270 Code 2x GTX 980 Ti SC Corsair Dominator 16GB DDR4 @3200 
Hard DriveHard DriveOSMonitor
Samsung 960 Evo M.2 Samsung 850 Pro 1 TB Windows 10 LG 34UM95 3440x1440 34" 
KeyboardPowerCaseMouse
WASD mechanical brown swithces Seasonic 850w Platinum Caselabs Merlin SM8 Black Razer Deathadder Chroma 
Audio
Audioengine A2 + D1 DAC 
CPUMotherboardGraphicsRAM
i7 3770k  Asus Maximus V Gene Asus GTX 670 DCII  Samsung 8GB @1866 
Hard DriveCoolingCoolingCooling
Samsung 830 Series 256GB SSD EK Supremacy Acetal nickel Dual 240 Black Ice GT Stealth EK GTX 670 DCII waterblock 
MonitorKeyboardPowerCase
Dell ultrasharp U2412m WASD mechanical keyboard Corsair AX750 Fractal Arc Mini 
MouseMouse PadAudioAudio
Steelseries Sensei Razer Megasoma Audioengine A2 Beyerdynamic Custom One Pro 
  hide details  
Reply
post #5 of 19
Thread Starter 
Nope, nothing happens at all. No LED's and nothing from the psu.
post #6 of 19
Thread Starter 
Is there an LED on the psu to tell me it's on? I mean nothing happens at all.
post #7 of 19
Well, my guess is that the PSU is dead (assuming you plugged all the cables to the mobo correctly).

Also, just in case you overlooked this, your PSU comes with a switch outside, next to where you plug the cord to the wall that will turn on and off the power. If you have that in "O" instead of "I" try putting it on "I".
Dark Wasp
(13 items)
 
Zebra II
(19 items)
 
Water Arc Mini
(16 items)
 
CPUMotherboardGraphicsRAM
i7 7700K Asus ROG Z270 Code 2x GTX 980 Ti SC Corsair Dominator 16GB DDR4 @3200 
Hard DriveHard DriveOSMonitor
Samsung 960 Evo M.2 Samsung 850 Pro 1 TB Windows 10 LG 34UM95 3440x1440 34" 
KeyboardPowerCaseMouse
WASD mechanical brown swithces Seasonic 850w Platinum Caselabs Merlin SM8 Black Razer Deathadder Chroma 
Audio
Audioengine A2 + D1 DAC 
CPUMotherboardGraphicsRAM
i7 3770k  Asus Maximus V Gene Asus GTX 670 DCII  Samsung 8GB @1866 
Hard DriveCoolingCoolingCooling
Samsung 830 Series 256GB SSD EK Supremacy Acetal nickel Dual 240 Black Ice GT Stealth EK GTX 670 DCII waterblock 
MonitorKeyboardPowerCase
Dell ultrasharp U2412m WASD mechanical keyboard Corsair AX750 Fractal Arc Mini 
MouseMouse PadAudioAudio
Steelseries Sensei Razer Megasoma Audioengine A2 Beyerdynamic Custom One Pro 
  hide details  
Reply
Dark Wasp
(13 items)
 
Zebra II
(19 items)
 
Water Arc Mini
(16 items)
 
CPUMotherboardGraphicsRAM
i7 7700K Asus ROG Z270 Code 2x GTX 980 Ti SC Corsair Dominator 16GB DDR4 @3200 
Hard DriveHard DriveOSMonitor
Samsung 960 Evo M.2 Samsung 850 Pro 1 TB Windows 10 LG 34UM95 3440x1440 34" 
KeyboardPowerCaseMouse
WASD mechanical brown swithces Seasonic 850w Platinum Caselabs Merlin SM8 Black Razer Deathadder Chroma 
Audio
Audioengine A2 + D1 DAC 
CPUMotherboardGraphicsRAM
i7 3770k  Asus Maximus V Gene Asus GTX 670 DCII  Samsung 8GB @1866 
Hard DriveCoolingCoolingCooling
Samsung 830 Series 256GB SSD EK Supremacy Acetal nickel Dual 240 Black Ice GT Stealth EK GTX 670 DCII waterblock 
MonitorKeyboardPowerCase
Dell ultrasharp U2412m WASD mechanical keyboard Corsair AX750 Fractal Arc Mini 
MouseMouse PadAudioAudio
Steelseries Sensei Razer Megasoma Audioengine A2 Beyerdynamic Custom One Pro 
  hide details  
Reply
post #8 of 19
Thread Starter 
Oohh..now there is a green LED on towards the bottom of the motherboard, bottom right corner.

It says sb power near it.
post #9 of 19
is the front panel power button plugged into the right header on the mobo? Try unplugging all and carefully jumping each colored pair with a screwdriver until it comes on.
    
CPUMotherboardGraphicsRAM
Intel i5 2500k | 4.5Ghz @ uknownV Gigabyte GA-Z68-D3 ASUS EAH6970 | 1000/1300 1.3v 2x2GB Corsair Dominator 1600Mhz 8-8-8 
Hard DriveOSMonitorPower
Samsung Spinpoint F3 500GB Windows 7 Ultimate 64-Bit BenQ G2222HDL + Hanns-G HQ191D Sapphire FirePSU 625w 
Case
GlobalWin YCC-61F1B (Modding planned) 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i5 2500k | 4.5Ghz @ uknownV Gigabyte GA-Z68-D3 ASUS EAH6970 | 1000/1300 1.3v 2x2GB Corsair Dominator 1600Mhz 8-8-8 
Hard DriveOSMonitorPower
Samsung Spinpoint F3 500GB Windows 7 Ultimate 64-Bit BenQ G2222HDL + Hanns-G HQ191D Sapphire FirePSU 625w 
Case
GlobalWin YCC-61F1B (Modding planned) 
  hide details  
Reply
post #10 of 19
Basic Troubleshooting...here we go.

Remove all components from the case and lay them out on a non conductive surface (the comment about stand offs being a ground is misleading).

Plug in all the cables etc.

Use anything metal to short the two pins that would normally connect to the Power Switch of your case.

Chances are your components will now fire right up. If not remove all peripherals and attempt this again with just the power supply connected to the motherboard. Still nothing? Pull all the expansion cards (Graphics etc) and see if the board will power up with nothing at all installed except the CPU, RAM and powersupply. Still nothing? Pull the RAM...does the board light up at least? Then one or more memory modules are bad. Still nothing? Better test the PSU then. Unplug the PSU from the board. Jumper the green wire and black wire on the 24 pin plug using a paperclip or any short bare wire. PSU will start up...if not you have a bad PSU.

Hope that helps.
Shop Dog
(13 items)
 
 
CPUMotherboardGraphicsRAM
E8400 Asus Blitz Formula SE HD3870X2 G Skill 2 x 2GB DDR2 800 
Hard DriveOptical DriveOSMonitor
Velociraptor 150GB LG DVD Burner Vista Ultimate 64 AOC 21.5" LED 1080p 
KeyboardPowerCaseMouse
Deck Legend Silverstone 750 Modular OverClock Edition Lian Li V1100 Logitech Trackball 
Mouse Pad
Nope 
  hide details  
Reply
Shop Dog
(13 items)
 
 
CPUMotherboardGraphicsRAM
E8400 Asus Blitz Formula SE HD3870X2 G Skill 2 x 2GB DDR2 800 
Hard DriveOptical DriveOSMonitor
Velociraptor 150GB LG DVD Burner Vista Ultimate 64 AOC 21.5" LED 1080p 
KeyboardPowerCaseMouse
Deck Legend Silverstone 750 Modular OverClock Edition Lian Li V1100 Logitech Trackball 
Mouse Pad
Nope 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD - General
Overclock.net › Forums › AMD › AMD - General › New Build, Won't turn On