Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Can't connect through RDP?
New Posts  All Forums:Forum Nav:

Can't connect through RDP? - Page 3

post #21 of 46
Thread Starter 
I would like to say that I CAN successfully connect to the remote terminal server IP at work. Just attempted that and it worked fine.

I feel like it can't be something with my network because people can connect perfectly to me.

Could it possibly be some type of settings on my Dad's laptop?

Or could it be (and forgive me because I'm not too familiar with Verizon FiOS gateways/routers) because I am the primary connection to the FiOS router? It doesn't look like our old Linksys when one person was the primary and everyone else connected to it as well. It appears to be every wired connection is just part of the LAN.

Anyone got any advice?
post #22 of 46
Thread Starter 
Quote:
Originally Posted by tjwurzburger View Post
Did you maybe have your remote desktop turned off when collecting the netstat results on your machine? That would explain the missing 3389 perplexity, at least on your box.

For current testing, just double check that firewall and antivirus are disabled on your father's machine, and obviously that RDP is turned on.



Here's the weird part. If either the middle or bottom radio button is selected on this dialog, then port 3389 should be listening and visible with netstat. Since it's not in the two files that you sent me, something is definitely wrong.

The next thing to check are the services running on your father's machine. There are several that apply, but let's start with those that I have circled below:

Sorry Joe but I'm gonna have to get back to you tomorrow (I love how "gonna" isn't a filtered incorrect word on Firefox...epic) as my dad is using the computer right now.

I didn't check the services but I will definitely do it tomorrow around lunchtime.

In the meantime (I won't read this tonight, I'll read it tomorrow morning before work), if I want to connect to my home computer via my work computer to verify an established connection (which I'm sure should work), what do I have to do? Our home network runs the same IP when we aren't talking about private IPs (once again, not sure what it's called, dare I say public IP?) so I don't know how to access this computer directly if the public IP is the same as my Dad's. This isn't my primary concern, so if it's too complicated I'll just hold off until I can figure my real issue out.

But thanks for all your help tonight, I'll do some researching tomorrow and definitely check that out again for you Joe.

If it's any consolation, I enabled all those services on my PC, ran Netstat, and still didn't receive a 3389 port.

Oh my

EDIT: I also checked the registry to confirm the port number. It is indeed 3389. I'm so lost.
Edited by xyeLz - 7/26/11 at 7:00pm
post #23 of 46
Quote:
Originally Posted by xyeLz View Post
If it's any consolation, I enabled all those services on my PC, ran Netstat, and still didn't receive a 3389 port.

Oh my
If your remote desktop is on (and working) then some port is listening for incoming connections. It's TCP port 3389 by default, but it is possible that another is being used in your case. You can check by opening up regedit and navigating to HKLM\\SYSTEM\\CurrentControlSet\\Control\\Terminal Server\\WinStations\\RDP-Tcp. The value is called PortNumber and is usually set to 0x00000d3d (a.k.a. 3389).

As for your question about connecting to your PC from an external machine, it can be done but it may involve some port forwarding and other complications. It is also quite possible that your ISP is blocking ports/protocols in between your office and home, but it's not uncommon for them to open up firewall entries, especially if you have a static external IP address.

As to your original question about trying to connect to your father's machine, I know that it should "just work". Because it obviously is not at the moment, you might want to reconsider using a free product/service to achieve your goals ... unless you enjoy the intellectual challenge of fixing an irritating tech support problem.

Again I've used VNC for years and it works very well, especially for machines on the same private LAN. You might also try LogMeIn for your work-to-home solution.

I'll check back tomorrow to see if you had any luck. Feel free to PM me if you can think of anything I can do to assist.
SpaceHeater v3
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T BE 4.113GHz Gigabyte GA-890FXA-UD5 (Rev3.1) PowerColor HD6950 2GB + MSI GTX 460 Cyclone HyperX Genesis DDR3 (4GBx2) 1713MHz 
Hard DriveOSMonitorKeyboard
Crucial m4 64GB | WD Blk 1TB | Barracuda 2TB RAID0 Win7 Ultimate x64 / Ubuntu 10.10 x86_64 27" Planar 1080p + Dell 1901FP in portrait Das Keyboard Model S Professional 
PowerCaseMouse
CoolerMaster 800W 80+ Gold CoolerMaster HAF 912 Logitech M570 Trackball 
  hide details  
Reply
SpaceHeater v3
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T BE 4.113GHz Gigabyte GA-890FXA-UD5 (Rev3.1) PowerColor HD6950 2GB + MSI GTX 460 Cyclone HyperX Genesis DDR3 (4GBx2) 1713MHz 
Hard DriveOSMonitorKeyboard
Crucial m4 64GB | WD Blk 1TB | Barracuda 2TB RAID0 Win7 Ultimate x64 / Ubuntu 10.10 x86_64 27" Planar 1080p + Dell 1901FP in portrait Das Keyboard Model S Professional 
PowerCaseMouse
CoolerMaster 800W 80+ Gold CoolerMaster HAF 912 Logitech M570 Trackball 
  hide details  
Reply
post #24 of 46
Thread Starter 
Quote:
Originally Posted by tjwurzburger View Post
If your remote desktop is on (and working) then some port is listening for incoming connections. It's TCP port 3389 by default, but it is possible that another is being used in your case. You can check by opening up regedit and navigating to HKLM\\SYSTEM\\CurrentControlSet\\Control\\Terminal Server\\WinStations\\RDP-Tcp. The value is called PortNumber and is usually set to 0x00000d3d (a.k.a. 3389).

As for your question about connecting to your PC from an external machine, it can be done but it may involve some port forwarding and other complications. It is also quite possible that your ISP is blocking ports/protocols in between your office and home, but it's not uncommon for them to open up firewall entries, especially if you have a static external IP address.

As to your original question about trying to connect to your father's machine, I know that it should "just work". Because it obviously is not at the moment, you might want to reconsider using a free product/service to achieve your goals ... unless you enjoy the intellectual challenge of fixing an irritating tech support problem.

Again I've used VNC for years and it works very well, especially for machines on the same private LAN. You might also try LogMeIn for your work-to-home solution.

I'll check back tomorrow to see if you had any luck. Feel free to PM me if you can think of anything I can do to assist.
I know I should be in bed but I realized how early it is.

I do want to figure out WHY this isn't working, for intellectual purposes. Though I'm also very stubborn and don't want to install programs when this, realistically, should work.

According to my registry, the port is still the default 3389. This baffles me as to why my father can connect to me though. Perhaps his port is set to something different? Would that have any effect?
post #25 of 46
Quote:
Originally Posted by xyeLz View Post
I also checked the registry to confirm the port number. It is indeed 3389. I'm so lost.
LOL, that's just awesome! I'm sure there's a logical explanation ... I just don't know what it is. One workaround to get a more definitive answer about ports in use would be to utilize the excellent TCPView by Mark Russinovich. Once you come up with a method to verify "what right looks like" on your machine then it should be easier to replicate it on your father's box.

EDIT. It's good that the port is 3389 on your box, and that connections to your machine do work. That all makes sense. The only thing that doesn't is why we cannot see 3389 in netstat on your machine, but that's a secondary issue really. I'm sure it will show up in TCPView.

The more pertinent question is whether 3389 will show up on your father's machine. If not, then we know it's not listening for incoming connections and can troubleshoot that way. If it is there on his machine, then that means something else is in play (firewall, etc.)
Edited by tjwurzburger - 7/26/11 at 8:28pm
SpaceHeater v3
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T BE 4.113GHz Gigabyte GA-890FXA-UD5 (Rev3.1) PowerColor HD6950 2GB + MSI GTX 460 Cyclone HyperX Genesis DDR3 (4GBx2) 1713MHz 
Hard DriveOSMonitorKeyboard
Crucial m4 64GB | WD Blk 1TB | Barracuda 2TB RAID0 Win7 Ultimate x64 / Ubuntu 10.10 x86_64 27" Planar 1080p + Dell 1901FP in portrait Das Keyboard Model S Professional 
PowerCaseMouse
CoolerMaster 800W 80+ Gold CoolerMaster HAF 912 Logitech M570 Trackball 
  hide details  
Reply
SpaceHeater v3
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T BE 4.113GHz Gigabyte GA-890FXA-UD5 (Rev3.1) PowerColor HD6950 2GB + MSI GTX 460 Cyclone HyperX Genesis DDR3 (4GBx2) 1713MHz 
Hard DriveOSMonitorKeyboard
Crucial m4 64GB | WD Blk 1TB | Barracuda 2TB RAID0 Win7 Ultimate x64 / Ubuntu 10.10 x86_64 27" Planar 1080p + Dell 1901FP in portrait Das Keyboard Model S Professional 
PowerCaseMouse
CoolerMaster 800W 80+ Gold CoolerMaster HAF 912 Logitech M570 Trackball 
  hide details  
Reply
post #26 of 46
Look if authentication is enabled

Open Remote Desktop Connection by clicking the Start button, clicking All Programs, clicking Accessories, and then clicking Remote Desktop Connection.
In the Remote Desktop Connection dialog box, click Options, and then click the Advanced tab.
post #27 of 46
Thread Starter 
Quote:
Originally Posted by tjwurzburger View Post
LOL, that's just awesome!
I love how you can share in the humor with me. Haha.

I am at work now and (OH MAN YOU'RE GONNA LOVE THIS ONE) I just ran Netstat with -a and -n and even my work computer's command prompt doesn't show 3389! We use RDP all the time to connect to the terminal server so maybe the terminal server will have that port showing, but I can check that later.

I will try the program you gave me when I get home and see what it shows.

As for the "authentication" as mentioned by another poster. It is set to say "Warn me".
post #28 of 46
Quote:
Originally Posted by xyeLz View Post
I love how you can share in the humor with me. Haha.

I am at work now and (OH MAN YOU'RE GONNA LOVE THIS ONE) I just ran Netstat with -a and -n and even my work computer's command prompt doesn't show 3389! We use RDP all the time to connect to the terminal server so maybe the terminal server will have that port showing, but I can check that later.

I will try the program you gave me when I get home and see what it shows.

As for the "authentication" as mentioned by another poster. It is set to say "Warn me".
And on the other pc?
post #29 of 46
Thread Starter 
Quote:
Originally Posted by Spooony View Post
And on the other pc?
Sorry, it's the same for both.
post #30 of 46
Quote:
Originally Posted by xyeLz View Post
I just ran Netstat with -a and -n and even my work computer's command prompt doesn't show 3389!
Maybe that's an elevation issue? Try running your command prompt as an administrator, then doing the netstat -a -n. Other than that TCPView is a great free utility that does the same thing (and more).

It is odd, though. On my Win7 Ultimate x64 machines, netstat works all day long and is an easy way to see if RDP is listening on 3389. Most perplexing!
SpaceHeater v3
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T BE 4.113GHz Gigabyte GA-890FXA-UD5 (Rev3.1) PowerColor HD6950 2GB + MSI GTX 460 Cyclone HyperX Genesis DDR3 (4GBx2) 1713MHz 
Hard DriveOSMonitorKeyboard
Crucial m4 64GB | WD Blk 1TB | Barracuda 2TB RAID0 Win7 Ultimate x64 / Ubuntu 10.10 x86_64 27" Planar 1080p + Dell 1901FP in portrait Das Keyboard Model S Professional 
PowerCaseMouse
CoolerMaster 800W 80+ Gold CoolerMaster HAF 912 Logitech M570 Trackball 
  hide details  
Reply
SpaceHeater v3
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T BE 4.113GHz Gigabyte GA-890FXA-UD5 (Rev3.1) PowerColor HD6950 2GB + MSI GTX 460 Cyclone HyperX Genesis DDR3 (4GBx2) 1713MHz 
Hard DriveOSMonitorKeyboard
Crucial m4 64GB | WD Blk 1TB | Barracuda 2TB RAID0 Win7 Ultimate x64 / Ubuntu 10.10 x86_64 27" Planar 1080p + Dell 1901FP in portrait Das Keyboard Model S Professional 
PowerCaseMouse
CoolerMaster 800W 80+ Gold CoolerMaster HAF 912 Logitech M570 Trackball 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Can't connect through RDP?