Overclock.net › Forums › Graphics Cards › AMD/ATI › 6970 2GB Problem
New Posts  All Forums:Forum Nav:

6970 2GB Problem

post #1 of 9
Thread Starter 
Hey,
I have an ATI 6970 2GB graphic card. When I put it into a X16 PCI-express slot, its fan works, but it makes no image at all. It's linked to my monitor with a DVI cable. The screen just stays black.

Anyone has an idea?
Thanks!
post #2 of 9
clear the cmos :

take out gfx card , take out the battery , unplug the power cable .. hold down power for 10 seconds so the system loses power completely and has no memory ( bios will be on default settings now ) .. then connect it all back up and switch it on see if u get a display .

If not , rma . or it could be your mobo's x16 slot .
Edited by Xristo - 7/26/11 at 4:58pm
    
CPUMotherboardGraphicsRAM
Intel i5 7600k @ 5Ghz, 1.312v Asus Prime Z270-AR msi GTX 1080 32GB Corsair Vengeance DDR4 3Ghz 
Hard DriveCoolingOSMonitor
Transcend SSD220S 120GB  Corsair H80i V2 Windows 10 Pro 64bit AOC AG322FCX 32" Curved LED 144hz 1920x1080 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Antec Quattro 1000w Thermaltake Versa N27 msi Gaming series 
Mouse PadAudio
Razer Goliathus Steelseries Siberia V2  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i5 7600k @ 5Ghz, 1.312v Asus Prime Z270-AR msi GTX 1080 32GB Corsair Vengeance DDR4 3Ghz 
Hard DriveCoolingOSMonitor
Transcend SSD220S 120GB  Corsair H80i V2 Windows 10 Pro 64bit AOC AG322FCX 32" Curved LED 144hz 1920x1080 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Antec Quattro 1000w Thermaltake Versa N27 msi Gaming series 
Mouse PadAudio
Razer Goliathus Steelseries Siberia V2  
  hide details  
Reply
post #3 of 9
Quote:
Originally Posted by Xristo View Post
clear the cmos , take out the battery and unplug the power cable .. hold down power for 10 seconds then connect it all back up and it should work man .
Very helpful to remember this. Perfect, complete way to reset your hardware.
ContrastFX
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T GIGABYTE GA-990FXA-UD3 XFX Radeon HD 6870 Mushkin Blackline 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda 500GB LG DVD±RW SuperMulti Drive Corsair H60 Windows 8 Developer Preview 64bit 
MonitorKeyboardPowerCase
ASUS MS246 1920x1080 iRocks RF-6570 Antec HCG-520 LIAN LI Lancool PC-K58W 
  hide details  
Reply
ContrastFX
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1100T GIGABYTE GA-990FXA-UD3 XFX Radeon HD 6870 Mushkin Blackline 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda 500GB LG DVD±RW SuperMulti Drive Corsair H60 Windows 8 Developer Preview 64bit 
MonitorKeyboardPowerCase
ASUS MS246 1920x1080 iRocks RF-6570 Antec HCG-520 LIAN LI Lancool PC-K58W 
  hide details  
Reply
post #4 of 9
If your card card has a dual bios switch, trying switching to the other bios if clearing cmos does not work.
post #5 of 9
Quote:
Originally Posted by wermad View Post
If your card card has a dual bios switch, trying switching to the other bios if clearing cmos does not work.

this too .

should only not display if it was a bad bios flash , if you havent played with the bios it shoudnt be the problem .

did you flash another bios onto your 6970 ?
Edited by Xristo - 7/26/11 at 5:02pm
    
CPUMotherboardGraphicsRAM
Intel i5 7600k @ 5Ghz, 1.312v Asus Prime Z270-AR msi GTX 1080 32GB Corsair Vengeance DDR4 3Ghz 
Hard DriveCoolingOSMonitor
Transcend SSD220S 120GB  Corsair H80i V2 Windows 10 Pro 64bit AOC AG322FCX 32" Curved LED 144hz 1920x1080 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Antec Quattro 1000w Thermaltake Versa N27 msi Gaming series 
Mouse PadAudio
Razer Goliathus Steelseries Siberia V2  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i5 7600k @ 5Ghz, 1.312v Asus Prime Z270-AR msi GTX 1080 32GB Corsair Vengeance DDR4 3Ghz 
Hard DriveCoolingOSMonitor
Transcend SSD220S 120GB  Corsair H80i V2 Windows 10 Pro 64bit AOC AG322FCX 32" Curved LED 144hz 1920x1080 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Antec Quattro 1000w Thermaltake Versa N27 msi Gaming series 
Mouse PadAudio
Razer Goliathus Steelseries Siberia V2  
  hide details  
Reply
post #6 of 9
Same thing happened a week ago, rma fixed it. It was dead.


Sent from my iPhone using Tapatalk
Desktop
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k [4.7 GHz] Asus P8P67 Pro B3 [2001 BIOS] MSI 7970 Lighting [Stock] G.Skill Ripjaws X 2x4GB [1600 MHz] 
Hard DriveOSMonitorKeyboard
Crucial M4 128GB + 2TB Raid 0 Cavier Black Windows 7 [Ultimate x64] [Dell U2412HM] + [HP 2311x] RosewillRK-9000 
PowerCaseMouse
Silverstone Strider [1500w] Corsair 300R Razer Deathadder 
  hide details  
Reply
Desktop
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k [4.7 GHz] Asus P8P67 Pro B3 [2001 BIOS] MSI 7970 Lighting [Stock] G.Skill Ripjaws X 2x4GB [1600 MHz] 
Hard DriveOSMonitorKeyboard
Crucial M4 128GB + 2TB Raid 0 Cavier Black Windows 7 [Ultimate x64] [Dell U2412HM] + [HP 2311x] RosewillRK-9000 
PowerCaseMouse
Silverstone Strider [1500w] Corsair 300R Razer Deathadder 
  hide details  
Reply
post #7 of 9
Clearing the cmos should fix the problem , in rare cases it might not . Very unlucky to get a faulty gpu . Hope it all works out for you op .
    
CPUMotherboardGraphicsRAM
Intel i5 7600k @ 5Ghz, 1.312v Asus Prime Z270-AR msi GTX 1080 32GB Corsair Vengeance DDR4 3Ghz 
Hard DriveCoolingOSMonitor
Transcend SSD220S 120GB  Corsair H80i V2 Windows 10 Pro 64bit AOC AG322FCX 32" Curved LED 144hz 1920x1080 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Antec Quattro 1000w Thermaltake Versa N27 msi Gaming series 
Mouse PadAudio
Razer Goliathus Steelseries Siberia V2  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i5 7600k @ 5Ghz, 1.312v Asus Prime Z270-AR msi GTX 1080 32GB Corsair Vengeance DDR4 3Ghz 
Hard DriveCoolingOSMonitor
Transcend SSD220S 120GB  Corsair H80i V2 Windows 10 Pro 64bit AOC AG322FCX 32" Curved LED 144hz 1920x1080 
KeyboardPowerCaseMouse
Razer Blackwidow Ultimate Antec Quattro 1000w Thermaltake Versa N27 msi Gaming series 
Mouse PadAudio
Razer Goliathus Steelseries Siberia V2  
  hide details  
Reply
post #8 of 9
Did you plug in the 6 pin power thing? I sometimes forget ....
    
CPUMotherboardGraphicsRAM
Core i7 5930k MSI X99S SLI GTX 1080 32GB Crucial DDR4 
Hard DriveHard DriveCoolingCooling
(3x) Crucial 256GB (768gb RAID0) WD 3TB EK Supremacy EVO + D5 Vario GT-AP15 
CoolingMonitorMonitorKeyboard
2X HWLABS GTX360 (2x) 1440p QHD PLS MicroBoard 40" 4k MVA Corsair K70 RGB 
PowerCaseMouseAudio
Corsair RM1000 Custom Build Logitech G900 Yamaha RX-V465 + 5.1 Surround 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 5930k MSI X99S SLI GTX 1080 32GB Crucial DDR4 
Hard DriveHard DriveCoolingCooling
(3x) Crucial 256GB (768gb RAID0) WD 3TB EK Supremacy EVO + D5 Vario GT-AP15 
CoolingMonitorMonitorKeyboard
2X HWLABS GTX360 (2x) 1440p QHD PLS MicroBoard 40" 4k MVA Corsair K70 RGB 
PowerCaseMouseAudio
Corsair RM1000 Custom Build Logitech G900 Yamaha RX-V465 + 5.1 Surround 
  hide details  
Reply
post #9 of 9
Quote:
Originally Posted by jasonkidd123 View Post
Hey,
I have an ATI 6970 2GB graphic card. When I put it into a X16 PCI-express slot, its fan works, but it makes no image at all. It's linked to my monitor with a DVI cable. The screen just stays black.

Anyone has an idea?
Thanks!
please make sure your PSU meets the specification's of
550 Watt or greater power supply with one 150W 8-pin PCI Express® power connector and one 75W 6-pin PCI Express® power connector recommended

also what i would do is go into your bios and see if its set to PCI-E and not onboard or pci or whatever with another video card of course then switch back to retest.
Likwid Dutch
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k p8p67 Ws revolution B3 Rev 3.0 Sapphire 6990 G.SKILL Ripjaws X Series 8GB 
Hard DriveOptical DriveOSMonitor
Sata 6 1Tb in raid 0 SH-S203N Windows 7 64bit L246WP 
KeyboardPowerCaseMouse
Logitech Ultra Slim AX1200 Haf 932 Death Adder left handed 
Mouse Pad
Rocketfish gaming pad 
  hide details  
Reply
Likwid Dutch
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k p8p67 Ws revolution B3 Rev 3.0 Sapphire 6990 G.SKILL Ripjaws X Series 8GB 
Hard DriveOptical DriveOSMonitor
Sata 6 1Tb in raid 0 SH-S203N Windows 7 64bit L246WP 
KeyboardPowerCaseMouse
Logitech Ultra Slim AX1200 Haf 932 Death Adder left handed 
Mouse Pad
Rocketfish gaming pad 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › 6970 2GB Problem