Overclock.net › Forums › Intel › Intel Motherboards › No drive detected in windows 7 installation
New Posts  All Forums:Forum Nav:

No drive detected in windows 7 installation

post #1 of 8
Thread Starter 
Hey guys - was wondering if you could help me out. I have a asRock p67 extreme4 motherboard and set up the drives in the bios to IDE. It shows the drive in the bios but when i try to install windows 7 - it does not show any hard drive. Does anyone have any advice that will help me get the hard drive to show in Windows 7 installation? Would appreciate any suggestions!
SIG RIG
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7-4770K (@4.2) MSI Z87 mPower MSI GTX 770 Lightning 16gb DDR3 1600 
Hard DriveMonitorPowerCase
256GB SSD, 64GB SSD, 2x1TB Drives in Raid 0 2 x Acer 3D GD235HZbid PC Power and Cooling 750W SLI COOLER MASTER Storm Stryker 
  hide details  
Reply
SIG RIG
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7-4770K (@4.2) MSI Z87 mPower MSI GTX 770 Lightning 16gb DDR3 1600 
Hard DriveMonitorPowerCase
256GB SSD, 64GB SSD, 2x1TB Drives in Raid 0 2 x Acer 3D GD235HZbid PC Power and Cooling 750W SLI COOLER MASTER Storm Stryker 
  hide details  
Reply
post #2 of 8
Try setting the SATA connections to AHCI.
post #3 of 8
Sounds like it may need a driver installed from the MB CD.

I usually only see this though when you are using RAID or AHCI.
Ryzen Gaming
(19 items)
 
Ryzen HTPC
(11 items)
 
HTPC
(13 items)
 
CPUMotherboardGraphicsRAM
Amd 1700x Asus Crosshair VI Hero Rx 560 (waiting for Vega) edit... Vega sucks...... GSkill Trident Z 
Hard DriveHard DriveHard DriveHard Drive
Plextor m.2 512GB WD 600GB Velociraptor Ocz 400GB SSD Crucial m500 512GB SSD 
Optical DriveCoolingOSMonitor
LG Blu-ray Burner EK waterloop Windows 10 PRO 64bit LG 4k Freesync 
MonitorMonitorKeyboardPower
Asus 23" IPS Asus 23" IPS Gigabyte Mechanical Corsair 1500w 
CaseMouseAudio
Thermaltake x9 Logitech Sounblaster X-Fi  
CPUMotherboardGraphicsRAM
AMD 1700 Asus x370 Prime AMD RX 460 Corsair 16GB 
Hard DriveOptical DriveOSMonitor
Samsung 960 Evo 250GB LG HDDVD/Bluray Windows 10 PRO 64-bit Epson 8350 Projector 100" screen 
KeyboardPowerCase
Lenovo handheld keyboard Roswill 500w 80 Platinum Thermaltake HTPC 
CPUMotherboardRAMHard Drive
AMD A10 5700 ASRock fm2+ 16GB Samsung Wonder RAM 60GB SSD 
Hard DriveOptical DriveOSMonitor
WD Black 1TB LG Blu-ray Burner Windows 10 PRO x64 60" Panasonic vt plasma 
PowerCase
Antec 350 Antec 
  hide details  
Reply
Ryzen Gaming
(19 items)
 
Ryzen HTPC
(11 items)
 
HTPC
(13 items)
 
CPUMotherboardGraphicsRAM
Amd 1700x Asus Crosshair VI Hero Rx 560 (waiting for Vega) edit... Vega sucks...... GSkill Trident Z 
Hard DriveHard DriveHard DriveHard Drive
Plextor m.2 512GB WD 600GB Velociraptor Ocz 400GB SSD Crucial m500 512GB SSD 
Optical DriveCoolingOSMonitor
LG Blu-ray Burner EK waterloop Windows 10 PRO 64bit LG 4k Freesync 
MonitorMonitorKeyboardPower
Asus 23" IPS Asus 23" IPS Gigabyte Mechanical Corsair 1500w 
CaseMouseAudio
Thermaltake x9 Logitech Sounblaster X-Fi  
CPUMotherboardGraphicsRAM
AMD 1700 Asus x370 Prime AMD RX 460 Corsair 16GB 
Hard DriveOptical DriveOSMonitor
Samsung 960 Evo 250GB LG HDDVD/Bluray Windows 10 PRO 64-bit Epson 8350 Projector 100" screen 
KeyboardPowerCase
Lenovo handheld keyboard Roswill 500w 80 Platinum Thermaltake HTPC 
CPUMotherboardRAMHard Drive
AMD A10 5700 ASRock fm2+ 16GB Samsung Wonder RAM 60GB SSD 
Hard DriveOptical DriveOSMonitor
WD Black 1TB LG Blu-ray Burner Windows 10 PRO x64 60" Panasonic vt plasma 
PowerCase
Antec 350 Antec 
  hide details  
Reply
post #4 of 8
Thread Starter 
Yeah I am not using Raid or AHCI so there should be no driver to install
SIG RIG
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7-4770K (@4.2) MSI Z87 mPower MSI GTX 770 Lightning 16gb DDR3 1600 
Hard DriveMonitorPowerCase
256GB SSD, 64GB SSD, 2x1TB Drives in Raid 0 2 x Acer 3D GD235HZbid PC Power and Cooling 750W SLI COOLER MASTER Storm Stryker 
  hide details  
Reply
SIG RIG
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7-4770K (@4.2) MSI Z87 mPower MSI GTX 770 Lightning 16gb DDR3 1600 
Hard DriveMonitorPowerCase
256GB SSD, 64GB SSD, 2x1TB Drives in Raid 0 2 x Acer 3D GD235HZbid PC Power and Cooling 750W SLI COOLER MASTER Storm Stryker 
  hide details  
Reply
post #5 of 8
But you should be using AHCI, especially if you have a SATA hard drive and a Windows 7 OS. IDE is for legacy stuff, AHCI enables NCQ and other features on your hard drive.
post #6 of 8
This happens every now and then...like I have one 500GB hard drive that will not show up in a windows 7 install. However, I can RAID it and the array will show up fine. I have seen it before. If your RAID controller will let you try making an array of one disk and try it. I've seen three drives (including my own) that did this and I've done that before as a work arround. Though keep in mind I've seen a LOT of drives...

Just using AHCI didn't help it out.

I honestly think there is somthing wrong with the drives...I probably should have RMA'ed them. If this was XP i would just think it needs a driver, but in windows 7? For a normal every day hard drive? I don't think any additional drivers will help.
My System
(16 items)
 
  
CPUMotherboardGraphicsGraphics
2600K @ 4.7GHz Asus P8P67 B3 GTX 580 EVGA Hydro Copper 2 GTX 580 EVGA  
RAMHard DriveOptical DriveOS
4x4GB G.Skill Ripjaws bunch of 'em Blu-Ray For movies Windows 8.1 
MonitorMonitorKeyboardPower
24.4" Hans G HH251 X2 Yamakasi DS270  Blah 1000watt Super Flower 
CaseMouseMouse PadAudio
Built into Desk Microsoft SideWinder X8 Comfy one... Creative Extreme Gamer 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsGraphics
2600K @ 4.7GHz Asus P8P67 B3 GTX 580 EVGA Hydro Copper 2 GTX 580 EVGA  
RAMHard DriveOptical DriveOS
4x4GB G.Skill Ripjaws bunch of 'em Blu-Ray For movies Windows 8.1 
MonitorMonitorKeyboardPower
24.4" Hans G HH251 X2 Yamakasi DS270  Blah 1000watt Super Flower 
CaseMouseMouse PadAudio
Built into Desk Microsoft SideWinder X8 Comfy one... Creative Extreme Gamer 
  hide details  
Reply
post #7 of 8
Thread Starter 
You would think Microsoft would fix a problem like this... so there is no true fix for this?
SIG RIG
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7-4770K (@4.2) MSI Z87 mPower MSI GTX 770 Lightning 16gb DDR3 1600 
Hard DriveMonitorPowerCase
256GB SSD, 64GB SSD, 2x1TB Drives in Raid 0 2 x Acer 3D GD235HZbid PC Power and Cooling 750W SLI COOLER MASTER Storm Stryker 
  hide details  
Reply
SIG RIG
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7-4770K (@4.2) MSI Z87 mPower MSI GTX 770 Lightning 16gb DDR3 1600 
Hard DriveMonitorPowerCase
256GB SSD, 64GB SSD, 2x1TB Drives in Raid 0 2 x Acer 3D GD235HZbid PC Power and Cooling 750W SLI COOLER MASTER Storm Stryker 
  hide details  
Reply
post #8 of 8
Hey, just throwing an idea... have you tried reversing the sata cable... (99% cases this won't do crap, but hey, can't shoot a guy for trying?).

Also maybe an alternate sata cable? Sure it works for one method, but not another.. Maybe your mobo isn't quite designed for win7? I've never been a fan of asrock, been curious as to their multiple feature functionality, but it's always been a bit "out there" for me. (My opinion only, no dissing intended to asrock fans).

Maybe check how the powering up process is for wiring for the sata power plugs to the hdd. Try to rebalance the power pull, even though you have an awesome psu..

- Le_Loup
    
CPUMotherboardGraphicsGraphics
i5, 4670k, 4.2ghz MSI Z87-GD65 GAMING (MS-7845) MSI Nvidia GeForce GTX 760 MSI Nvidia GeForce GTX 760 
RAMHard DriveOptical DriveCooling
4x 4gb Corsair 1600 C9, XMP 1.2 2x1tb (sata6, Raid 0), 2x 1tb data drives, 4x 2... Sata: DVD DL Burner w/lite scribe corsair h100i w/2x120mm rad internal. 1x 120 re... 
OSMonitorKeyboardPower
Windows 8.1 3x 24" RL2455HM BenQ Logitech G15 Keyboard (Original with G1-G18 but... TR2 RX 1200W ThermalTake 
CaseMouseMouse PadAudio
Antec P280 Black With Window/Side Panel Razer Naga Hex Shaw @ Home Mouse Pad Xonar Dx 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
i5, 4670k, 4.2ghz MSI Z87-GD65 GAMING (MS-7845) MSI Nvidia GeForce GTX 760 MSI Nvidia GeForce GTX 760 
RAMHard DriveOptical DriveCooling
4x 4gb Corsair 1600 C9, XMP 1.2 2x1tb (sata6, Raid 0), 2x 1tb data drives, 4x 2... Sata: DVD DL Burner w/lite scribe corsair h100i w/2x120mm rad internal. 1x 120 re... 
OSMonitorKeyboardPower
Windows 8.1 3x 24" RL2455HM BenQ Logitech G15 Keyboard (Original with G1-G18 but... TR2 RX 1200W ThermalTake 
CaseMouseMouse PadAudio
Antec P280 Black With Window/Side Panel Razer Naga Hex Shaw @ Home Mouse Pad Xonar Dx 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › No drive detected in windows 7 installation