Overclock.net › Forums › Consumer Electronics › Home Audio › Hi-Fi Gear › Ugh I'm out of my realm here, need advice for 5.1 setup
New Posts  All Forums:Forum Nav:

Ugh I'm out of my realm here, need advice for 5.1 setup - Page 2

post #11 of 14
Thread Starter 
Actually, I guess if worse came to worse and I don't ever find a solution to this, I could just have the output of the M-Audio, and my sound card to the 5.1 receiver. I'd just have to switch the Windows Audio settings every time, like I do now, and the sound won't be nearly as good from the M-Audio as it is from my sound card.

But that way, I can still listen to the clean signal from my sound card for movies and music and stuff, and just use the M-audio when I want to play guitar.
Zealotry
(14 items)
 
  
CPUMotherboardGraphicsHard Drive
Pentium G3258  MSI Z97S SLI Krait Edition EVGA SC GTX 570 Crucial C300 128GB + 5TB Storage 
OSMonitorPowerAudio
Windows 7 Ultimate QNIX 27" IPS  Corsair 800TX Xonar Essence ST 
  hide details  
Reply
Zealotry
(14 items)
 
  
CPUMotherboardGraphicsHard Drive
Pentium G3258  MSI Z97S SLI Krait Edition EVGA SC GTX 570 Crucial C300 128GB + 5TB Storage 
OSMonitorPowerAudio
Windows 7 Ultimate QNIX 27" IPS  Corsair 800TX Xonar Essence ST 
  hide details  
Reply
post #12 of 14
I had suspected that Guitar Rig could handle more than one audio device at a time, it doesn't look like it can though. If you switch to your soundcard in the Audio/Midi settings it disables the M-Audio input? Also ASIO complicates things with multiple devices, even if Guitar rig could handle 2 sound devices I'm not sure you'd get them both with ASIO.
Not SLi any more
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4.0 Asus P6TD-Deluxe EVGA GTX770 SC 6GB XMS3 @1530 cas7 
Hard DriveHard DriveHard DriveOptical Drive
Intel X25-M 80GB OCZ Agility 120GB Intel X25-M 40GB LG Blue ROM DVD RW 
CoolingOSMonitorKeyboard
Water cooled w/ T-Balancer BigNG Win 7 x64 Asus PB298Q Cherry 4100L 
PowerCaseMouseMouse Pad
Corsair HX1000 MM UFO-U2 R.A.T. 7 Contagion G.L.I.D.E 9 
AudioAudio
Xonar Essence STX SR80i, DT770 or HT-R518 w/ Monitor Audio BR's 
  hide details  
Reply
Not SLi any more
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4.0 Asus P6TD-Deluxe EVGA GTX770 SC 6GB XMS3 @1530 cas7 
Hard DriveHard DriveHard DriveOptical Drive
Intel X25-M 80GB OCZ Agility 120GB Intel X25-M 40GB LG Blue ROM DVD RW 
CoolingOSMonitorKeyboard
Water cooled w/ T-Balancer BigNG Win 7 x64 Asus PB298Q Cherry 4100L 
PowerCaseMouseMouse Pad
Corsair HX1000 MM UFO-U2 R.A.T. 7 Contagion G.L.I.D.E 9 
AudioAudio
Xonar Essence STX SR80i, DT770 or HT-R518 w/ Monitor Audio BR's 
  hide details  
Reply
post #13 of 14
Thread Starter 
Quote:
Originally Posted by Darren9 View Post
I had suspected that Guitar Rig could handle more than one audio device at a time, it doesn't look like it can though. If you switch to your soundcard in the Audio/Midi settings it disables the M-Audio input? Also ASIO complicates things with multiple devices, even if Guitar rig could handle 2 sound devices I'm not sure you'd get them both with ASIO.
Well yes and no.

I've tried using all of the other ASIO devices in GR4. The only one that gave me outputted sound from the soundcard while the Fast Track was connected, was the same one I normally use when connecting my headphones (pictured in my post above). Except in the Recording tab of "Sound" in Windows, I enabled the Mic input (I've also tried line in). I had to connect the red/white output from the Fast Track to my sound card mic in. Sound did come out from my sound card, but like I said, it was terrible.

If I have the Xonar ST ASIO as the device, it gives me two options for input, "IN-00" and "IN-01". The outputs are only "L" and "R".

And yeah, you are right about ASIO not liking multiple devices at once.

The only ASIO device that seems to let me use more than one at a time is ASIO4all v2. Except I always get errors when mixing and matching input/output. For instance if I have it say input is M-Audio, output is Xonar ST sound card, it doesn't work.

The routing only has the option as the Xonar ST out, the input says "not connected".
Zealotry
(14 items)
 
  
CPUMotherboardGraphicsHard Drive
Pentium G3258  MSI Z97S SLI Krait Edition EVGA SC GTX 570 Crucial C300 128GB + 5TB Storage 
OSMonitorPowerAudio
Windows 7 Ultimate QNIX 27" IPS  Corsair 800TX Xonar Essence ST 
  hide details  
Reply
Zealotry
(14 items)
 
  
CPUMotherboardGraphicsHard Drive
Pentium G3258  MSI Z97S SLI Krait Edition EVGA SC GTX 570 Crucial C300 128GB + 5TB Storage 
OSMonitorPowerAudio
Windows 7 Ultimate QNIX 27" IPS  Corsair 800TX Xonar Essence ST 
  hide details  
Reply
post #14 of 14
I'm curious if it will work without ASIO, with the Fast Track as an in and the Essence as an out in Guitar Rig. I don't think ASIO can handle more than one device at the same time, even if it can detect them. It's been a couple of years since I struggled with this stuff, I'm not sure what WASAPI will do if you have shared mode available, you could be limited to windows and direct sound though with two soundcards on one application.
Not SLi any more
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4.0 Asus P6TD-Deluxe EVGA GTX770 SC 6GB XMS3 @1530 cas7 
Hard DriveHard DriveHard DriveOptical Drive
Intel X25-M 80GB OCZ Agility 120GB Intel X25-M 40GB LG Blue ROM DVD RW 
CoolingOSMonitorKeyboard
Water cooled w/ T-Balancer BigNG Win 7 x64 Asus PB298Q Cherry 4100L 
PowerCaseMouseMouse Pad
Corsair HX1000 MM UFO-U2 R.A.T. 7 Contagion G.L.I.D.E 9 
AudioAudio
Xonar Essence STX SR80i, DT770 or HT-R518 w/ Monitor Audio BR's 
  hide details  
Reply
Not SLi any more
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4.0 Asus P6TD-Deluxe EVGA GTX770 SC 6GB XMS3 @1530 cas7 
Hard DriveHard DriveHard DriveOptical Drive
Intel X25-M 80GB OCZ Agility 120GB Intel X25-M 40GB LG Blue ROM DVD RW 
CoolingOSMonitorKeyboard
Water cooled w/ T-Balancer BigNG Win 7 x64 Asus PB298Q Cherry 4100L 
PowerCaseMouseMouse Pad
Corsair HX1000 MM UFO-U2 R.A.T. 7 Contagion G.L.I.D.E 9 
AudioAudio
Xonar Essence STX SR80i, DT770 or HT-R518 w/ Monitor Audio BR's 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hi-Fi Gear
Overclock.net › Forums › Consumer Electronics › Home Audio › Hi-Fi Gear › Ugh I'm out of my realm here, need advice for 5.1 setup