Overclock.net › Forums › AMD › AMD Motherboards › M4A89TD pro or Crosshair V formula
New Posts  All Forums:Forum Nav:

M4A89TD pro or Crosshair V formula - Page 2

post #11 of 14
I own and have tested all the 3 main mobos mentioned in this thread - take the Crosshair V Formula if you have the budget else lacking the budget, get the Asrock 9 series models esp. the ~US$100 970 Extreme4 if you can.

HTH
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
post #12 of 14
Quote:
Originally Posted by daito View Post
my cousin got a 4 Gb ram stick and his mobo died once he installed it

i'm guessing his psu was the reason 'cause its a 350 W that comes installed in a cheap case
This doesn't sound right to me. If you think this is the problem you might just be dealing with a memory configuration problem and the Mobo is fine. If the Mobo is truly "dead' I bet the reason was something other than just putting a memory stick in it and this of course means you had better figure out what was really the problem before you go swapping mobos, because the same thing might just happen again.
    
CPUMotherboardGraphicsRAM
AMD FX-4170 @ 4.86 Ghz ASUS M5A97 EVO 2 x PowerColor AX6790 Crossfire 16GB (4 x 4GB) SAMSUNG MV-3V4G3D @1890 Mhz 8-9-9 
Hard DriveOptical DriveCoolingOS
2x Corsair Force 3 120 GB SSD External USB AMD stock cooler Win7 Ultimate 
MonitorKeyboardPowerCase
ASUS 23" DVI Fullsize, solid. OCZ ModXStream Pro 500W CM Praetorian 730 Black 
Mouse
Has red light on bottom 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD FX-4170 @ 4.86 Ghz ASUS M5A97 EVO 2 x PowerColor AX6790 Crossfire 16GB (4 x 4GB) SAMSUNG MV-3V4G3D @1890 Mhz 8-9-9 
Hard DriveOptical DriveCoolingOS
2x Corsair Force 3 120 GB SSD External USB AMD stock cooler Win7 Ultimate 
MonitorKeyboardPowerCase
ASUS 23" DVI Fullsize, solid. OCZ ModXStream Pro 500W CM Praetorian 730 Black 
Mouse
Has red light on bottom 
  hide details  
Reply
post #13 of 14
Crosshair V, as others have said.

Absolutely the best mobo I've ever overclocked with.
post #14 of 14
Thread Starter 
Quote:
Originally Posted by Erick;14443615 
Wait for it, it will appear there where ever (where?) you live. Someday.... biggrin.gif

i don't think it'll appear, ever frown.gif
i live in UAE and the only place i can get pc hardware from is in dubai and unfortunately they LOVE intel and HATE amd , not the sellers ofc , but most of the customers, u can say 99% use intel , why? 'cause apparently its better
i use amd 'cause its good for gaming and suits my budget biggrin.gif
thats why they don't sell amd mobos or cpus , u cant find except the top mobos and cpus ('cause they cost more = more profit for the seller), so if you want to go with amd you'll find very limited choices and you'll have to look around in shops untill you find 1 piece that suits you tongue.gif
Quote:
Originally Posted by Jagged_Steel;14447293 
This doesn't sound right to me. If you think this is the problem you might just be dealing with a memory configuration problem and the Mobo is fine. If the Mobo is truly "dead' I bet the reason was something other than just putting a memory stick in it and this of course means you had better figure out what was really the problem before you go swapping mobos, because the same thing might just happen again.

problem is i couldn't get into the bios and memOK button didn't work thinking.gif all i get is a beeping sound and the memory led on
i tried his ram on my mobo and it worked after configuring it biggrin.gif
tested the gpu and psu and they worked
except for the cpu which i didn't test
he said he smelt something burnt after installing the ram and switching it on, nothing looks burnt on the mobo , maybe under the heat sinks confused.gif
Dragon
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 955 Asus M4A89GTD pro Sapphire 5870 ref.  4 GB Kingston hyperX 1600 cl9 
Hard DriveHard DriveOptical DriveOS
WD 1 TB black WD 1 TB green LG DVD-RW Win 7 ultimate 64bit 
MonitorPowerCase
LG 21.5" 1080p Corsair TX850 w HAF 932 
  hide details  
Reply
Dragon
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 955 Asus M4A89GTD pro Sapphire 5870 ref.  4 GB Kingston hyperX 1600 cl9 
Hard DriveHard DriveOptical DriveOS
WD 1 TB black WD 1 TB green LG DVD-RW Win 7 ultimate 64bit 
MonitorPowerCase
LG 21.5" 1080p Corsair TX850 w HAF 932 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › M4A89TD pro or Crosshair V formula