Overclock.net › Forums › Video Games › PC Gaming › Sims 3 help!
New Posts  All Forums:Forum Nav:

Sims 3 help!

post #1 of 4
Thread Starter 
If someone can help me,please do it! My Sims 3 crashes all the time and I still can not get it why.The grapfics card is updated,the windows is updated,I play with low setings,but nothing!!! Sometimes it appears a black screen of death or all sorts on green lines appear and the computer is crashing.Tis happens to the sims 2 also. if is needed i have a directx diagnose if will help.Also,the screen flases black and then a message appears and says that the driver has stoped working.Thank you!!!
Edited by mateidobrescu - 7/28/11 at 12:50am
My System
(13 items)
 
  
CPUGraphicsOS
i3 540 3.07GHz NVidia GeForce 9500 GT Windows 7 Ultimate x32 
  hide details  
Reply
My System
(13 items)
 
  
CPUGraphicsOS
i3 540 3.07GHz NVidia GeForce 9500 GT Windows 7 Ultimate x32 
  hide details  
Reply
post #2 of 4
Welcome to OCN. Can you please setup your system specifications so we can see what hardware you're running?

You can do this by clicking User CP at the top of the page. Once you've done that, on the left side you'll see a bunch of options, look for "Add System". Click that, and add your specifications. Once you've done that, that will help us help you in the long run.

When you get an error stating that the display driver has stopped working, that can mean a few things.

1. GPU instability. Usually caused by an overclock that is NOT stable.

2. Drivers. Make sure you update to the latest drivers from the manufacturers website, and NOT Windows.

What I recommend you do is completely uninstall your graphics drivers, and reinstall the newest drivers from the manufacturers website.
post #3 of 4
The artifacting followed by a driver crash would make me guess your video card is overheating. The Sims 3 has been known to do this. When you run the game, force v-sync.

Right click on your desktop, and select "NVIDIA Control panel". On the tree on the left, under "3D Settings", select "Manage 3D Settings". Scroll towards the bottom, and set the last option, "Vertical sync" to "Force on". Click "Apply" and close it. You may reverse this change if you wish when you are not running the game.

Additionally, the stability of the game itself has been known to be increased by disabling DEP (Data Execution Prevention). If you have any crashes to the desktop (where the game just instantly closes itself), this is a very likely cause. Here are instructions for that.

http://help.thesims.com/app/answers/...sims%203%20dep
post #4 of 4
Thread Starter 
I forced it but it did not work.
My System
(13 items)
 
  
CPUGraphicsOS
i3 540 3.07GHz NVidia GeForce 9500 GT Windows 7 Ultimate x32 
  hide details  
Reply
My System
(13 items)
 
  
CPUGraphicsOS
i3 540 3.07GHz NVidia GeForce 9500 GT Windows 7 Ultimate x32 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Sims 3 help!