Overclock.net › Forums › Intel › Intel CPUs › Upgrade to i5 from 955, BC2 slows down?
New Posts  All Forums:Forum Nav:

Upgrade to i5 from 955, BC2 slows down?

post #1 of 13
Thread Starter 
So I recently upgraded from my 955be to the i5. I also upgraded my 4890 to a 6950. I hade the 6950 for about a week before I got my new board and cpu. During that time I didn't have any random slowdown issues with bad company 2.

Since I upgraded my board and cpu, all ot the sudden my fps will randomly drop to 2-3 for about 5 seconds. I know that this has been a common issue, but I'm not finding anything that gives me a fix. Could it be vdroop?

The game is certainly playable, but it is very annoying!
Edited by fuloran1 - 7/30/11 at 11:57am
post #2 of 13
Old drivers uninstalled? Motherboard drivers installed?
post #3 of 13
Thread Starter 
Quote:
Originally Posted by SkippyDogg View Post
Old drivers uninstalled? Motherboard drivers installed?
You think it could be a driver issue? I kind of doubt it, it seems to be a common problem. And yes, my board drivers are installed.
post #4 of 13
Quote:
Originally Posted by fuloran1 View Post
You think it could be a driver issue? I kind of doubt it, it seems to be a common problem. And yes, my board drivers are installed.
Possibly they can conflict with each other. I would also try disabling MSI Afterburner if you have it, BC2 doesn't like it and causes slow downs(with me) on start up and white screen game crashes. That or CPU throttling, how are your temperatures?
post #5 of 13
Quote:
Originally Posted by fuloran1 View Post
You think it could be a driver issue? I kind of doubt it, it seems to be a common problem. And yes, my board drivers are installed.
Driver issues are common problems. (especially if you didn't wipe the OS after switching platforms)

Upgrading from a 955 to an i5 2500k and having less performance in BFBC2 is not a common problem.
Why upgrade?
(14 items)
 
Why overclock?!
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 760 ASUS 55i Sabertooth EVGA 960 4GB 8gb 1600mhz Vengeance 
Hard DriveHard DriveOSMonitor
120gb Intel 320 (OS) 500gb Samsung 850 Evo Win 7 64 Viewsonic VX2250-Wm 
PowerCaseMouseAudio
Seasonic G 550w Gold Lancool PC-K9B Logitech G5 X-Fi Titanium/AT-H700 
CPUMotherboardGraphicsRAM
Core i5 4690k Asus Z97 Sabertooth mk2 EVGA 970 8gb Kingston 1833mhz 
Hard DriveHard DriveCoolingOS
128GB Samsung 830 500GB Samsung 840 Evo allota fans but quiet! Win 7 64 
MonitorKeyboardPowerCase
Dell U2311H Rev. A01 Mechanical w/ Cherry Blues NZXT Hale 650w NZXT Phantom - white 
MouseMouse PadAudio
Anker CG100 Steelseries 9HD Sennheiser HD555 
  hide details  
Reply
Why upgrade?
(14 items)
 
Why overclock?!
(15 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 760 ASUS 55i Sabertooth EVGA 960 4GB 8gb 1600mhz Vengeance 
Hard DriveHard DriveOSMonitor
120gb Intel 320 (OS) 500gb Samsung 850 Evo Win 7 64 Viewsonic VX2250-Wm 
PowerCaseMouseAudio
Seasonic G 550w Gold Lancool PC-K9B Logitech G5 X-Fi Titanium/AT-H700 
CPUMotherboardGraphicsRAM
Core i5 4690k Asus Z97 Sabertooth mk2 EVGA 970 8gb Kingston 1833mhz 
Hard DriveHard DriveCoolingOS
128GB Samsung 830 500GB Samsung 840 Evo allota fans but quiet! Win 7 64 
MonitorKeyboardPowerCase
Dell U2311H Rev. A01 Mechanical w/ Cherry Blues NZXT Hale 650w NZXT Phantom - white 
MouseMouse PadAudio
Anker CG100 Steelseries 9HD Sennheiser HD555 
  hide details  
Reply
post #6 of 13
please tell me you did a reinstall of windows 7 when you upgraded? if not thats your issue!
post #7 of 13
Hey OP, try removing your graphics card drivers and then rebooting and installing the new ones. Its most likely that. tongue.gif
Quote:
Originally Posted by pmrballer123;14405632 
please tell me you did a reinstall of windows 7 when you upgraded? if not thats your issue!

I've changed platforms like 4-5 times without reinstalling and my performance has been just fine. tongue.gif
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
post #8 of 13
Quote:
Originally Posted by Razi3l View Post
Hey OP, try removing your graphics card drivers and then rebooting and installing the new ones. Its most likely that.



I've changed platforms like 4-5 times without reinstalling and my performance has been just fine.
not suppose to do that, things can get sticky and cause havoc
post #9 of 13
Thread Starter 
Quote:
Originally Posted by pmrballer123 View Post
not suppose to do that, things can get sticky and cause havoc
And you are speaking from experience? I have also never reinstalled windows on a new hardware install (unless I was doing a new version of windows too), just uninstalled the old drivers. I have always heard how you supposedly have to reinstall the OS, but I think its crap.
post #10 of 13
Thread Starter 
Got it resolved, found a couple of hidden devices with drivers still installed (sound card and such) and played a couple of rounds with no issues. Thanks guys!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › Upgrade to i5 from 955, BC2 slows down?