Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Acer Pew72, plain white screen after start up
New Posts  All Forums:Forum Nav:

Acer Pew72, plain white screen after start up

post #1 of 4
Thread Starter 
If i go through safe mode everything shows up just fine, if I try and start normally you see everything until it passes the Loading screen, everything goes white, you can hear the main sounds of start up and there is some moving pinkish red lines at the top of the screen.
First build
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k GIGABYTE GA-Z68X-UD3H-B3 Radeon HD 6850 8gig G.Skill Ripjaws 1600 DDR3 
Hard DriveOSMonitorPower
3.16 TB of HDD space. SSD(s) soon Windows 7 Ultimate x64 32" viore Ultra X3 1000w 
Case
CM Storm Sniper 
  hide details  
Reply
First build
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k GIGABYTE GA-Z68X-UD3H-B3 Radeon HD 6850 8gig G.Skill Ripjaws 1600 DDR3 
Hard DriveOSMonitorPower
3.16 TB of HDD space. SSD(s) soon Windows 7 Ultimate x64 32" viore Ultra X3 1000w 
Case
CM Storm Sniper 
  hide details  
Reply
post #2 of 4
I would go into safemode and attempt to uninstall/reinstall the video drivers, although it's probably more likely the IGP has a hardware failure and will be unfixable.
Spit in God's Eye
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-5960x @ 4.26 ghz core / 3.53 ghz uncore - 1.... AsRock X99 Extreme3 EVGA GTX980 Ti 16gb (4x4gb) Crucial DDR4 2133 CL15  
Hard DriveHard DriveHard DriveOptical Drive
A-Data SP600 256gb SSD (C:) Samsung 840 EVO 1TB SSD (D:) Seagate 2TB Hybrid Drive (E:) LITE-ON 24x DVDRW 
CoolingOSMonitorKeyboard
Corsair H110 Win 10 x64 HP 2511x ( 25" 1080p ) AZIO L70 
PowerCaseMouseAudio
Corsair TX750 Antec 300 (Modded) Logitech M100 Onboard 
  hide details  
Reply
Spit in God's Eye
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7-5960x @ 4.26 ghz core / 3.53 ghz uncore - 1.... AsRock X99 Extreme3 EVGA GTX980 Ti 16gb (4x4gb) Crucial DDR4 2133 CL15  
Hard DriveHard DriveHard DriveOptical Drive
A-Data SP600 256gb SSD (C:) Samsung 840 EVO 1TB SSD (D:) Seagate 2TB Hybrid Drive (E:) LITE-ON 24x DVDRW 
CoolingOSMonitorKeyboard
Corsair H110 Win 10 x64 HP 2511x ( 25" 1080p ) AZIO L70 
PowerCaseMouseAudio
Corsair TX750 Antec 300 (Modded) Logitech M100 Onboard 
  hide details  
Reply
post #3 of 4
Thread Starter 
Yea I honestly figured it was the drivers I just didnt want to go do a bunch of unnecessary stuff, didnt think it would be unfixable tho. Im at the area for uninstalling the drivers, where do i find the correct drivers to reinstall tho and will the screen work without the drivers so i can actually get the new ones installed?
First build
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k GIGABYTE GA-Z68X-UD3H-B3 Radeon HD 6850 8gig G.Skill Ripjaws 1600 DDR3 
Hard DriveOSMonitorPower
3.16 TB of HDD space. SSD(s) soon Windows 7 Ultimate x64 32" viore Ultra X3 1000w 
Case
CM Storm Sniper 
  hide details  
Reply
First build
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k GIGABYTE GA-Z68X-UD3H-B3 Radeon HD 6850 8gig G.Skill Ripjaws 1600 DDR3 
Hard DriveOSMonitorPower
3.16 TB of HDD space. SSD(s) soon Windows 7 Ultimate x64 32" viore Ultra X3 1000w 
Case
CM Storm Sniper 
  hide details  
Reply
post #4 of 4
Quote:
Originally Posted by Velvetdreams21 View Post
Yea I honestly figured it was the drivers I just didnt want to go do a bunch of unnecessary stuff, didnt think it would be unfixable tho. Im at the area for uninstalling the drivers, where do i find the correct drivers to reinstall tho and will the screen work without the drivers so i can actually get the new ones installed?
If you uninstall the video drivers it'll go back to Microsoft's default drivers so you'll still be able to download the correct drivers. Just find out what graphics card you have and download them from the manufacture support site. If your unsure what graphics card you have, download the program GPU-Z.

AMD/ATI:
http://support.amd.com/us/gpudownload/Pages/index.aspx

Nvidia:
http://www.nvidia.com/Download/index.aspx?lang=en-us

Intel:
http://downloadcenter.intel.com/
My Baby
(0 items)
  
Reply
My Baby
(0 items)
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Laptops and Netbooks
Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Acer Pew72, plain white screen after start up