Overclock.net › Forums › Video Games › PC Gaming › Cant open Shogun 2!
New Posts  All Forums:Forum Nav:

Cant open Shogun 2!

post #1 of 4
Thread Starter 
Hello there. I've been having this annoying problem, since yesterday, where i came home from a months vacation. I can't open shogun 2: total war. When i try to open it, i get the steam startup message, but then it disappears, and nothing opens. Ive tryed updating, and reinstalling drivers. I have got directx11. Ive reinstalled steam, reinstalled the game twice now, and i have now also tryed verifying the game cache files, through the local files team in steam, shogun properties. What to do?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x4 955 MSI 770-C45 ATI Radeon HD 5750 - 4GB DDR3 1600MHZ, KINGSTON HYPER-X 
Hard DriveOSMonitorPower
500GB SATAII WD HARDDISK, 7200RPM Windows 7 HP 64bit ASUS VK222H 500W Power Supply 
Case
Black ATX 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x4 955 MSI 770-C45 ATI Radeon HD 5750 - 4GB DDR3 1600MHZ, KINGSTON HYPER-X 
Hard DriveOSMonitorPower
500GB SATAII WD HARDDISK, 7200RPM Windows 7 HP 64bit ASUS VK222H 500W Power Supply 
Case
Black ATX 
  hide details  
Reply
post #2 of 4
Right Click on Steam -> Run as Administrator.

See if that works and makes Shogun 2 work, that happened to me with The Witcher 2 few days ago.
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Intel Core i7 7700k ASUS Maximus IX Formula EVGA GTX1080 Ti *soon* EVGA GTX1080 Ti *soon* 
RAMHard DriveHard DriveHard Drive
16GB Corsair Dominator Platinum 2666MHz CL16 Samsung 950 PRO M.2 512GB WD Red 4TB WD Green 1TB 
CoolingOSMonitorKeyboard
Corsair H110i GT Windows 10 PRO ASUS ROG Swift PG279Q Corsair K70 RGB MX Brown 
PowerCaseMouseMouse Pad
EVGA Supernova T2 850W Phanteks Enthoo Luxe Logitech G900 Chaos Spectrum Razer Destructor 2 
AudioAudioAudio
Beyerdynamic DT-770 PRO 80ohm JDS O2+ODAC Zalman MIC-M1 
  hide details  
Reply
post #3 of 4
Thread Starter 
Doesnt work
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x4 955 MSI 770-C45 ATI Radeon HD 5750 - 4GB DDR3 1600MHZ, KINGSTON HYPER-X 
Hard DriveOSMonitorPower
500GB SATAII WD HARDDISK, 7200RPM Windows 7 HP 64bit ASUS VK222H 500W Power Supply 
Case
Black ATX 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x4 955 MSI 770-C45 ATI Radeon HD 5750 - 4GB DDR3 1600MHZ, KINGSTON HYPER-X 
Hard DriveOSMonitorPower
500GB SATAII WD HARDDISK, 7200RPM Windows 7 HP 64bit ASUS VK222H 500W Power Supply 
Case
Black ATX 
  hide details  
Reply
post #4 of 4
Quote:
SEGA Support

If you are not able to start Shogun 2: Total War then please delete the preferences.script.txt file you will find at the following location:


- Windows Vista:

C:\\Users\\username\\AppData\\Roaming\\The Creative Assembly\\Shogun2\\scripts


- Windows XP:

C:\\Users\\username\\Documents and Settings\\Application Data\\The Creative Assembly\\Shogun2\\scripts


In order to access this folder, please ensure that the option Show hidden files and folders is active:

- Go to the Control Panel and enable Classic View

- Select Folder Options

- Select View

- From Advanced Settings enable locate Hidden files and folders.

- Select ‘Show hidden files and folders’

- Click Ok


This will then reset the settings option and allow you to access the game.

this is my fix. it worked for me!

IF!! it does not work for you ill post this http://forums.steampowered.com/forum...1961976&page=3 the link to were i found it. it has some other folder deleting fixes as well i see.
You can also try install the latest Microsoft Visual C++ 2008 redistributable. It is possible that a later patch uses a more updated version of Visual C++.

All of my Visual C++ 2005, 2008, and 2010 files are the latest. Shogun 2 runs fine on my computer.

Edit: Also install VC++ 2005 SP1 redistributable.
Edited by Riou - 8/3/11 at 8:41am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Cant open Shogun 2!