Overclock.net › Forums › Graphics Cards › AMD/ATI › Bad Company 2, XFX 5770 issue!
New Posts  All Forums:Forum Nav:

Bad Company 2, XFX 5770 issue!

post #1 of 8
Thread Starter 
I'm having a weird issue with my rig and bad company 2. When I'm in a server( any server), I'll be running around doing the usual. The game would suddenly pause to 1fps for 3-5 seconds and then bounce back up again as normal. Usually happens 3ish times during a server if I play any setting from start to finish. I play at 1920 x 1080 and everything is set up high except shadows(medium) and I'm not running any AA. Any suggestions?
The BAWS!
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 955 BE Asus M5A97 EVO Sapphire 6870 Gskill RipJaws DDR3 1600 2x4GB 
Hard DriveOptical DriveCoolingOS
Western Digital LG super multi lightscribe Corsair H50 with Coolermaster R4 in push/pull Win 7 Ultimate 64bit 
MonitorKeyboardPowerCase
23" Acer LED 60hz $8 local computer store brand Corsair 750TX CM 690 II 
MouseMouse Pad
CM Sentinel Advance Steel Series 
  hide details  
Reply
The BAWS!
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 955 BE Asus M5A97 EVO Sapphire 6870 Gskill RipJaws DDR3 1600 2x4GB 
Hard DriveOptical DriveCoolingOS
Western Digital LG super multi lightscribe Corsair H50 with Coolermaster R4 in push/pull Win 7 Ultimate 64bit 
MonitorKeyboardPowerCase
23" Acer LED 60hz $8 local computer store brand Corsair 750TX CM 690 II 
MouseMouse Pad
CM Sentinel Advance Steel Series 
  hide details  
Reply
post #2 of 8
Quote:
Originally Posted by JonnyFenix View Post
I'm having a weird issue with my rig and bad company 2. When I'm in a server( any server), I'll be running around doing the usual. The game would suddenly pause to 1fps for 3-5 seconds and then bounce back up again as normal. Usually happens 3ish times during a server if I play any setting from start to finish. I play at 1920 x 1080 and everything is set up high except shadows(medium) and I'm not running any AA. Any suggestions?
Happens to me at the start of every match but then never comes back
post #3 of 8
That is just ATI drivers, try SC2 lol 25 seconds of lost match time every round waiting for the map to load.
    
CPUMotherboardGraphicsRAM
2500k ASUS Maximus 4 Gene Z Sapphire 7950 OC G. Skill Ripjaws Z  
Hard DriveHard DriveCoolingOS
Mushkin Chronos Enhanced Deluxe Hitachi  Noctua NH-C14 Windows 7 Pro 
KeyboardPowerCaseMouse
Coolermaster Storm Quickfire Pro MX brown switches OCZ ZX 850 Lian Li PC-V600F CM Storm 
Mouse PadAudioOther
Silverstone black glass Roccat Kave  140mm blue LED Areocool Sharks 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
2500k ASUS Maximus 4 Gene Z Sapphire 7950 OC G. Skill Ripjaws Z  
Hard DriveHard DriveCoolingOS
Mushkin Chronos Enhanced Deluxe Hitachi  Noctua NH-C14 Windows 7 Pro 
KeyboardPowerCaseMouse
Coolermaster Storm Quickfire Pro MX brown switches OCZ ZX 850 Lian Li PC-V600F CM Storm 
Mouse PadAudioOther
Silverstone black glass Roccat Kave  140mm blue LED Areocool Sharks 
  hide details  
Reply
post #4 of 8
It happens at the start of a match for me but never comes back after that.
X79
(15 items)
 
First build ever
(10 items)
 
LGA 775
(9 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 3820 @4.3ghz stock volts Asus P9X79 Deluxe Sapphire Xtreme 5830 Crossfire @ 950/1200 16gb G Skill Sniper 2133mhz 
Hard DriveOptical DriveCoolingOS
OCZ Vertex 2 + 1TB WD Caviar Blue (Asus SSD Cac... Lite On DVD RW Noctua NH-D14 SE 2011 Windows 7 Pro 64 
MonitorKeyboardPowerCase
Hannspree HF237 Razer Black Widow Ultimate Rosewill Xtreme 950w Antec P280  
MouseMouse PadAudio
R.A.T. 7 Ripper XXL Klipsch Pro Media 2.1 (With onboard) 
CPUMotherboardGraphicsRAM
Athlon II X4 635 @ 3.5 on 1.34v GIGABYTE GA-890GPA-UD3H ATI Radeon HD 5770  12gb DDR3 (HyperX & Patriot) 
Hard DriveOptical DriveCoolingOS
500gb WD Caviar Blue Lite On 24x Noctua NH-D14 Windows 7 Pro 64 
PowerCase
Antec Neo Eco 400w NZXT Gamma 
CPUMotherboardGraphicsRAM
e5400 @ 3.6ghz EVGA nForce 750i SLI Galaxy GT240 512mb GDDR5 4gb of g skill DDR2 800 @ 867mhz 
Hard DriveCoolingOSPower
WD Blue 500gb Cooler Master Hyper N520 W7 Pro 64 bit Antec Neo Eco 400w 
Case
Lancool (Lian Li) K7 
  hide details  
Reply
X79
(15 items)
 
First build ever
(10 items)
 
LGA 775
(9 items)
 
CPUMotherboardGraphicsRAM
Intel Core i7 3820 @4.3ghz stock volts Asus P9X79 Deluxe Sapphire Xtreme 5830 Crossfire @ 950/1200 16gb G Skill Sniper 2133mhz 
Hard DriveOptical DriveCoolingOS
OCZ Vertex 2 + 1TB WD Caviar Blue (Asus SSD Cac... Lite On DVD RW Noctua NH-D14 SE 2011 Windows 7 Pro 64 
MonitorKeyboardPowerCase
Hannspree HF237 Razer Black Widow Ultimate Rosewill Xtreme 950w Antec P280  
MouseMouse PadAudio
R.A.T. 7 Ripper XXL Klipsch Pro Media 2.1 (With onboard) 
CPUMotherboardGraphicsRAM
Athlon II X4 635 @ 3.5 on 1.34v GIGABYTE GA-890GPA-UD3H ATI Radeon HD 5770  12gb DDR3 (HyperX & Patriot) 
Hard DriveOptical DriveCoolingOS
500gb WD Caviar Blue Lite On 24x Noctua NH-D14 Windows 7 Pro 64 
PowerCase
Antec Neo Eco 400w NZXT Gamma 
CPUMotherboardGraphicsRAM
e5400 @ 3.6ghz EVGA nForce 750i SLI Galaxy GT240 512mb GDDR5 4gb of g skill DDR2 800 @ 867mhz 
Hard DriveCoolingOSPower
WD Blue 500gb Cooler Master Hyper N520 W7 Pro 64 bit Antec Neo Eco 400w 
Case
Lancool (Lian Li) K7 
  hide details  
Reply
post #5 of 8
Thread Starter 
It happens in the beginning as well for me, but should it be doing it in game, while I'm getting my murder on?
The BAWS!
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 955 BE Asus M5A97 EVO Sapphire 6870 Gskill RipJaws DDR3 1600 2x4GB 
Hard DriveOptical DriveCoolingOS
Western Digital LG super multi lightscribe Corsair H50 with Coolermaster R4 in push/pull Win 7 Ultimate 64bit 
MonitorKeyboardPowerCase
23" Acer LED 60hz $8 local computer store brand Corsair 750TX CM 690 II 
MouseMouse Pad
CM Sentinel Advance Steel Series 
  hide details  
Reply
The BAWS!
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 955 BE Asus M5A97 EVO Sapphire 6870 Gskill RipJaws DDR3 1600 2x4GB 
Hard DriveOptical DriveCoolingOS
Western Digital LG super multi lightscribe Corsair H50 with Coolermaster R4 in push/pull Win 7 Ultimate 64bit 
MonitorKeyboardPowerCase
23" Acer LED 60hz $8 local computer store brand Corsair 750TX CM 690 II 
MouseMouse Pad
CM Sentinel Advance Steel Series 
  hide details  
Reply
post #6 of 8
driver sweeper in safe mode to remove driver then a fresh reinstall, should only happen at beginning of a round.
    
CPUMotherboardGraphicsRAM
2500k ASUS Maximus 4 Gene Z Sapphire 7950 OC G. Skill Ripjaws Z  
Hard DriveHard DriveCoolingOS
Mushkin Chronos Enhanced Deluxe Hitachi  Noctua NH-C14 Windows 7 Pro 
KeyboardPowerCaseMouse
Coolermaster Storm Quickfire Pro MX brown switches OCZ ZX 850 Lian Li PC-V600F CM Storm 
Mouse PadAudioOther
Silverstone black glass Roccat Kave  140mm blue LED Areocool Sharks 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
2500k ASUS Maximus 4 Gene Z Sapphire 7950 OC G. Skill Ripjaws Z  
Hard DriveHard DriveCoolingOS
Mushkin Chronos Enhanced Deluxe Hitachi  Noctua NH-C14 Windows 7 Pro 
KeyboardPowerCaseMouse
Coolermaster Storm Quickfire Pro MX brown switches OCZ ZX 850 Lian Li PC-V600F CM Storm 
Mouse PadAudioOther
Silverstone black glass Roccat Kave  140mm blue LED Areocool Sharks 
  hide details  
Reply
post #7 of 8
Thread Starter 
Did that as well. Tried newer and older drivers.
The BAWS!
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 955 BE Asus M5A97 EVO Sapphire 6870 Gskill RipJaws DDR3 1600 2x4GB 
Hard DriveOptical DriveCoolingOS
Western Digital LG super multi lightscribe Corsair H50 with Coolermaster R4 in push/pull Win 7 Ultimate 64bit 
MonitorKeyboardPowerCase
23" Acer LED 60hz $8 local computer store brand Corsair 750TX CM 690 II 
MouseMouse Pad
CM Sentinel Advance Steel Series 
  hide details  
Reply
The BAWS!
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 955 BE Asus M5A97 EVO Sapphire 6870 Gskill RipJaws DDR3 1600 2x4GB 
Hard DriveOptical DriveCoolingOS
Western Digital LG super multi lightscribe Corsair H50 with Coolermaster R4 in push/pull Win 7 Ultimate 64bit 
MonitorKeyboardPowerCase
23" Acer LED 60hz $8 local computer store brand Corsair 750TX CM 690 II 
MouseMouse Pad
CM Sentinel Advance Steel Series 
  hide details  
Reply
post #8 of 8
Quote:
Originally Posted by JonnyFenix View Post
Did that as well. Tried newer and older drivers.
I had that issue until I went in and uninstalled some old drivers that were hanging around.

Open a command prompt and type
set devmgr_show_nonpresent_devices=1

Then open device mgr, and enable "show hidden devices". Devices that are greyed out are not installed currently. If its something you use currently, like an ipod or something that just isnt plugged in atm, obviously ignore that.

Hope this helps!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Bad Company 2, XFX 5770 issue!