Overclock.net › Forums › Graphics Cards › AMD/ATI › Crashing black screen with Sapphire 5770
New Posts  All Forums:Forum Nav:

Crashing black screen with Sapphire 5770

post #1 of 12
Thread Starter 
The computer has frequent crashes with no warning that dump you into a black screen when running graphically intensive programs. The 5770 and the CPU are watercooled, and they never get above 35C.

If you run Furmark the computer will crash within about 5 minutes, even at stock settings. Prime95 passes the blend test for 8+ hours (stopped running the test after that).

Specs:
AMD 7750 BE
AMD Sapphire 5770
Neo ECO 400W PSU
Biostar AM2+ motherboard
G.Skill 2x2gb DDR2 1066 RAM
Windows 7 32 bit

The latest drivers from AMD are installed.


Any ideas?
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
post #2 of 12
your PSU... frown.gif

your GPU temps.. smile.gif

.. My gut says anemic 400W PSU is to blame..could very well be your drivers though.. I run the 11.4's to avoid any issues with newer games, the newer the driver, the worse performance got.. and the more issues I had with glitches/crashes etc.
post #3 of 12
Thread Starter 
The Neo Eco 400 is a quality Antec unit that Phadreus would recommend...

Anyways, do you think it could be dying? It's pretty new (about 1 year old). I will try to remove the drivers and install those older ones.
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
post #4 of 12
Well.. I too smoked a Antec Neo/Eco 400W.. running a OC'd 5770+e8400/DFI-T2RS.. everything was aircooled.. only 2x HDD's and no lights. All in all ...not a big load, but the PSU could not handle the fast current demand of the GPU.. it died in-game, 73F ambients so temps were of no concern for it..
post #5 of 12
Thread Starter 
I have a powersupply I could use to power the graphics alone, separately from the rest of the computer. Might try that.
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
post #6 of 12
It could be chipped GPU core. Who did mount watterblock?
TT Mozart Sx
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500k @4600MHz 1.30v ASrock P67 Extreme4 Ati HD5770 1GB Corsair 8GB 
Hard DriveOSMonitorKeyboard
WD Black 640GB Win7 64bit 27" LCD Sharkoon black 
PowerCaseMouseMouse Pad
550W TT Mozart Sx Gigabyte M8000 fUnc sUrface 
  hide details  
Reply
TT Mozart Sx
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500k @4600MHz 1.30v ASrock P67 Extreme4 Ati HD5770 1GB Corsair 8GB 
Hard DriveOSMonitorKeyboard
WD Black 640GB Win7 64bit 27" LCD Sharkoon black 
PowerCaseMouseMouse Pad
550W TT Mozart Sx Gigabyte M8000 fUnc sUrface 
  hide details  
Reply
post #7 of 12
I've had bad luck with the new drivers(11.5,11.6,&11.7),So I've been using 11.4,Any other driver other than 11.4 loaded I can't even start BFBC2,Try AMD/ATI driver 11.4:http://support.amd.com/us/gpudownload/windows/previous/11/Pages/radeon.aspx?os=Windows%20Vista%20-%2064-Bit%20Edition&rev=11.4
Black Edition
(17 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X4 870K @ 4.60 ASUS A68HM-Plus FM2+ MSI GeForce GTX 970 OC Crucial Ballistix Sports (8GB.) (DDR3-1600) 
Hard DriveHard DriveHard DriveHard Drive
SanDisk SSD Plus 240GB. Toshiba (500GB.) Hitachi Deskstar (500GB.) WD Ultra Passport 
Optical DriveCoolingOSMonitor
Samsung DVD Burner 24X SH-224DB/BEBE Cooler Master Hyper T4 Windows 10 Pro x64 Samsung S23A350H 23" 1080p 
KeyboardPowerCaseMouse
Logitech G105 Gaming Keyboard CORSAIR CX series CX600M 600W Thermaltake V3 Black Edition Logitech G300s Gaming Mouse 
Audio
ASUS DG 5.1 DD 
  hide details  
Reply
Black Edition
(17 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X4 870K @ 4.60 ASUS A68HM-Plus FM2+ MSI GeForce GTX 970 OC Crucial Ballistix Sports (8GB.) (DDR3-1600) 
Hard DriveHard DriveHard DriveHard Drive
SanDisk SSD Plus 240GB. Toshiba (500GB.) Hitachi Deskstar (500GB.) WD Ultra Passport 
Optical DriveCoolingOSMonitor
Samsung DVD Burner 24X SH-224DB/BEBE Cooler Master Hyper T4 Windows 10 Pro x64 Samsung S23A350H 23" 1080p 
KeyboardPowerCaseMouse
Logitech G105 Gaming Keyboard CORSAIR CX series CX600M 600W Thermaltake V3 Black Edition Logitech G300s Gaming Mouse 
Audio
ASUS DG 5.1 DD 
  hide details  
Reply
post #8 of 12
I tried using older drivers, and my GPU still crashed after 6 minutes of running Furmark.

Any other suggestions?
post #9 of 12
I tried using older drivers(11.4), and my GPU still crashed after 6 minutes of running Furmark.

Any other suggestions?

EDIT: Sorry posted twice by accident.
post #10 of 12
if temps are in order.. only drivers or poor PSU can be blame.. especially running stock
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Crashing black screen with Sapphire 5770