Overclock.net › Forums › General Hardware › General Processor Discussions › Quick Question Regarding my CPU
New Posts  All Forums:Forum Nav:

Quick Question Regarding my CPU

post #1 of 2
Thread Starter 
Okay so since I got a new job I've acquired the money to build a decent gaming rig. I went ahead and decided to wait for BD to come out to decide whether to get a 4100 or 8100 or just get a i5 2500k if benchmarks don't match up.

I got my new Gigabyte 6950 1GB yesterday and it's factory overclocked atm to 870 core clock speed. I decided to test it out before overclocking it more myself and while playing TF2, Witcher 2, Brothers in Arms Hell's Highway, and Brink I definitely noticed that the performance is the exact same as my old 6770. FPS does not change at all between 800x600 resolution and 1080p (my monitors native rez) nor does it change beyond 1-2 fps between low and maxed out settings. Basically I'm getting sub 30fps in a 2-3 year old game.

This naturally led me to believe that my CPU or RAM is bottlenecking me (they're pretty crappy/old). I have a non-overclocked phenom 9600 2.3GHz and 4GB (2x2) corsair 800mhz RAM. I got these parts on a real budget build a year after college and never had the money to do real upgrades until now. Also, I'm running the 6950 on PCIe 1.0 x16.

My question is, are these two parts holding back my GPU? I'd just like to confirm because

1. AMD system monitor doesn't show full use (70-85% CPU and RAM use)

2. Make sure my card isn't faulty


Thanks for any responses guys. I'd just like to put my mind at ease that a new CPU+RAM+Mobo will get me some good use out of my 6950.
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k ASRock P67 Extreme4 Gen3 MSI 280X Gaming G.Skill 8GB (4x2GB) 240 DIMM 1600 
Hard DriveHard DriveOSPower
WD Caviar Black TB Crucial 128 GB SSD Windows 8.1 CoolerMaster GX Series 650w 
MouseMouse Pad
Razer DeathAdder SteelSeries QcK 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k ASRock P67 Extreme4 Gen3 MSI 280X Gaming G.Skill 8GB (4x2GB) 240 DIMM 1600 
Hard DriveHard DriveOSPower
WD Caviar Black TB Crucial 128 GB SSD Windows 8.1 CoolerMaster GX Series 650w 
MouseMouse Pad
Razer DeathAdder SteelSeries QcK 
  hide details  
Reply
post #2 of 2
It is probably the crappy CPU combined with PCI-e 1.0, I don't think anything is faulty or broken though. The 6950 should blow right through all of those besides the Witcher 2.
    
CPUMotherboardGraphicsRAM
i7 3770k Gigabyte Z77-UD5H-WB Golden GTX 670 Windforce 3X 2 x 4GB GSkill RipJawsX 
Hard DriveCoolingOSMonitor
OCZ Vertex 4 64GB- WD Caviar Black 1TB Noctua NH-D14 Windows 7 Dell U2311H IPS 
KeyboardPowerCaseMouse
xArmor iOne U9BL MX Blues Seasonic x750 LIAN LI PC-T60B Logitech G500 
Audio
Modded JVC HA-RX900 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 3770k Gigabyte Z77-UD5H-WB Golden GTX 670 Windforce 3X 2 x 4GB GSkill RipJawsX 
Hard DriveCoolingOSMonitor
OCZ Vertex 4 64GB- WD Caviar Black 1TB Noctua NH-D14 Windows 7 Dell U2311H IPS 
KeyboardPowerCaseMouse
xArmor iOne U9BL MX Blues Seasonic x750 LIAN LI PC-T60B Logitech G500 
Audio
Modded JVC HA-RX900 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: General Processor Discussions
Overclock.net › Forums › General Hardware › General Processor Discussions › Quick Question Regarding my CPU