Overclock.net › Forums › AMD › AMD Motherboards › New Crosshair V wont boot at all!
New Posts  All Forums:Forum Nav:

New Crosshair V wont boot at all!

post #1 of 8
Thread Starter 
Plugged everything in and when I flip the switch for the PSU itself, the motherboard switches stay lit but when I press the power button on my case nothing lights up and it wont boot AT ALL. Is this a defective board?


Help!!


I am using 4GB G.Skill Flare ram if that has anything to do with it.
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
post #2 of 8
Quote:
Originally Posted by tianh View Post
Plugged everything in and when I flip the switch for the PSU itself, the motherboard switches stay lit but when I press the power button on my case nothing lights up and it wont boot AT ALL. Is this a defective board?


Help!!


I am using 4GB G.Skill Flare ram if that has anything to do with it.
I think the Crosshair has a power button on the board it self. Try turning it on with that. The wiring to your case buttons could be wrong.
Vega922
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 965 Gigabyte GA-990FXA-UD5 EVGA GTS-450 G-Skill Eco 1600 2x2 
Hard DriveOptical DriveOSMonitor
1.5Tb Hitatchi LG CD/DVDRW Windows 7 Professional x64 AOC e2343F 
KeyboardPowerCaseMouse
Gigabyte GK-K6800 Cooler Master GX650 Cooler Master HAF 922 Gigabyte GM-M6800 
  hide details  
Reply
Vega922
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 965 Gigabyte GA-990FXA-UD5 EVGA GTS-450 G-Skill Eco 1600 2x2 
Hard DriveOptical DriveOSMonitor
1.5Tb Hitatchi LG CD/DVDRW Windows 7 Professional x64 AOC e2343F 
KeyboardPowerCaseMouse
Gigabyte GK-K6800 Cooler Master GX650 Cooler Master HAF 922 Gigabyte GM-M6800 
  hide details  
Reply
post #3 of 8
Thread Starter 
Quote:
Originally Posted by Binski99 View Post
I think the Crosshair has a power button on the board it self. Try turning it on with that. The wiring to your case buttons could be wrong.
Yep the button is lit, but when I press it nothing happens still. I rechecked the case buttons and everything is plugged in correctly. Damn.
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
post #4 of 8
Thread Starter 
I was reading further into this and it definitely cant be my PSU because my computer was working today. Im simply swapping motherboards from a crosshair iv to a crosshair V. Sigh..
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
post #5 of 8
Thread Starter 
Well swapped back to my Crosshair IV and everything works fine. motherboard returned and ordered a new one, lets see what happens.
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
post #6 of 8
Probally a DOA board, good luck with RMA.

FYI, I'm sure you got the ATX 8-pin connected, but one other thing to check for is that your card has two 75W 6-pin PCIe connectors. If the video card drew too much current through the board it may not turn on at all.
post #7 of 8
Thread Starter 
Quote:
Originally Posted by ALUCARDVPR View Post
Probally a DOA board, good luck with RMA.

FYI, I'm sure you got the ATX 8-pin connected, but one other thing to check for is that your card has two 75W 6-pin PCIe connectors. If the video card drew too much current through the board it may not turn on at all.
Yep my graphics card has two pci-e 6 pin connectors. What are you saying, that only one should be plugged in instead of two?
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
Black Beauty
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom x4 955 BE C3 ASUS Crosshair V Formula ASUS 6950 1800 MHz G.Skill Flare 
Hard DrivePowerCaseMouse
120 GB OCZ Vertex 2 Cooler Master Silent ProM 850W Corsair Obsidian 650d Razer Deathadder 
  hide details  
Reply
post #8 of 8
Quote:
Originally Posted by tianh View Post
Yep my graphics card has two pci-e 6 pin connectors. What are you saying, that only one should be plugged in instead of two?
No, I'm saying to make sure that both are connected. But you got it
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › New Crosshair V wont boot at all!