Overclock.net › Forums › Intel › Intel - General › Burning smell from my case
New Posts  All Forums:Forum Nav:

Burning smell from my case - Page 2

post #11 of 13
Or maybe a fly was sleeping on some kind of component inside you PSU.
Poor thing your burned it up

Seriously, let your computer runs at idle for some time and check if the smell disapears.
Frenchy French
(14 items)
 
Upgrade 2013
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel i5 4670K Asus Z87-A Asus GTX 680 G.Skill Ripjaws XL 
Hard DriveCoolingOSKeyboard
CRUCIAL M4 128 Go SSD Corsair hydro series h60 (2013 Edition) Windows 7 Razer Blackwidow Ultimate 
PowerCaseMouseAudio
Corsair HX 850 W Antec 1200 Razer Mamba Razer Megalodon 
  hide details  
Reply
Frenchy French
(14 items)
 
Upgrade 2013
(12 items)
 
 
CPUMotherboardGraphicsRAM
Intel i5 4670K Asus Z87-A Asus GTX 680 G.Skill Ripjaws XL 
Hard DriveCoolingOSKeyboard
CRUCIAL M4 128 Go SSD Corsair hydro series h60 (2013 Edition) Windows 7 Razer Blackwidow Ultimate 
PowerCaseMouseAudio
Corsair HX 850 W Antec 1200 Razer Mamba Razer Megalodon 
  hide details  
Reply
post #12 of 13
Hey...check that psu ASAP. Thats what's making the smell.

The psu is the only component that will cause an electrical smell strong enough to reach throught the house.

Same thing happened to me...THE PSU WAS CHEAP...But I also may have blocked the fan airflow, cuz it was at the bottom of my case and my Computer sits on top a stack of DVD Cases.

Make sure the PSU fan is getting air flow.
My System
(16 items)
 
Lappy
(8 items)
 
 
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1055T @ 3.710GHz Asus M4A88TD-V Evo/USB3 CXF HIS 6950 2gb X Sapphire Unlocked 6950 2gb 8GB DDR3 1333 @ 1412mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 500gb Lite on 12x Blu-Ray Burner Corsiar H50 Windows 7 64-bit 
MonitorPowerCaseAudio
Vizio 120hz 47in 1080p Thermaltake Black Widow 850w Lian Li Armoursuit PC-P50 Sumsung 5.1 1000W 
Other
Acellero Twin Trubo Pro II 
CPUGraphicsRAMHard Drive
Intel I7 second gen. 2670qm 7690m xt 8gb DDR3 1333 750gb 5400rpm 2.5'' 
Optical DriveOSMonitorAudio
Blu-ray Rom Combo Windows 7 Home premium Modded B156HW01 V.4 AOU 95% color gamut 15.6" l... Beats Audio 
  hide details  
Reply
My System
(16 items)
 
Lappy
(8 items)
 
 
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1055T @ 3.710GHz Asus M4A88TD-V Evo/USB3 CXF HIS 6950 2gb X Sapphire Unlocked 6950 2gb 8GB DDR3 1333 @ 1412mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 500gb Lite on 12x Blu-Ray Burner Corsiar H50 Windows 7 64-bit 
MonitorPowerCaseAudio
Vizio 120hz 47in 1080p Thermaltake Black Widow 850w Lian Li Armoursuit PC-P50 Sumsung 5.1 1000W 
Other
Acellero Twin Trubo Pro II 
CPUGraphicsRAMHard Drive
Intel I7 second gen. 2670qm 7690m xt 8gb DDR3 1333 750gb 5400rpm 2.5'' 
Optical DriveOSMonitorAudio
Blu-ray Rom Combo Windows 7 Home premium Modded B156HW01 V.4 AOU 95% color gamut 15.6" l... Beats Audio 
  hide details  
Reply
post #13 of 13
Thread Starter 
InfernoReaper, yeah, I tried to look around for burn marks, but couldn't find any. It definitely *could* be my mobo tho :/

GlockZoR IV, I'm pretty sure my TIM is okay, because the temps are fine. Mugen 3 is a PITA to install, so I'm afraid I won't take it off and renew the thermal paste once again. It could be, though, that some of the TIM got around the socket on the install, but it should be non-conductive.

And yeah, the two above commenters, I'm kinda definite it's not my PSU. The smell comes from totally elsewhere. I've let the comp idle for like an day now, cleaned it thoroughly, and it's been without problems (and I can't smell anything in my room anymore...) since. There's not much I can do, so I'm afraid I'll let the things settle, restore my clocks etc. and see if there's still some problems going on. Hopefully nothing was permanently damaged

Thanks for the replies, I'll come back to the matter if there's something to be brought up
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500K Asus P8P67 Pro MSI HD 6870 Hawk 2x4GB DDR3 Ripjaws-X 1600Mhz CL9 
Hard DriveOptical DriveOSMonitor
40GB Intel 320 Series SSD, 1TB WD Caviar Blue *none* Windows 7 x64 26" 1920x1200 
PowerCase
Corsair HX650W Bitfenix Shinobi Black 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500K Asus P8P67 Pro MSI HD 6870 Hawk 2x4GB DDR3 Ripjaws-X 1600Mhz CL9 
Hard DriveOptical DriveOSMonitor
40GB Intel 320 Series SSD, 1TB WD Caviar Blue *none* Windows 7 x64 26" 1920x1200 
PowerCase
Corsair HX650W Bitfenix Shinobi Black 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel - General
Overclock.net › Forums › Intel › Intel - General › Burning smell from my case