Overclock.net › Forums › Intel › Intel Motherboards › Ok, so I need help...:/
New Posts  All Forums:Forum Nav:

Ok, so I need help...:/

post #1 of 6
Thread Starter 
So I have a gigabyte p67a-ud7-b3 bios version f3h.

Scenario: I had win7 installed on an SSD, then I had two 1 tb's as data drives. I bought a third 1 tb to raid 1 with one of the one I already had. I installed it, windows recognized it and I made it a drive. Then I went into the bios and to raid I made PCH SATA Control Mode = RAID(XHD).

Here is where I hit the problems, now I get a BSOD during boot and I can't get back into windows at all. I have data on the drives and I don't want to lose it but even if I put that setting back to IDE it won't work. Keeps putting back to RAID. What do I do?
Hope Solo
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k @ 4.5GHZ P67A-UD7-B3 Asus GTX 580 DCII 4 x 4GB 1600 Ripjaws X 
Hard DriveOptical DriveOSMonitor
SSD: Intel 320 series 120GB/3 x Samsung F3 1TB Asus Win 7 Pro 2 x Asus 23" VH232 
KeyboardPowerCaseMouse
Alienware TactX Cooler Master 850W HAF 932 R.A.T. 7 
Mouse Pad
Alienware 
  hide details  
Reply
Hope Solo
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k @ 4.5GHZ P67A-UD7-B3 Asus GTX 580 DCII 4 x 4GB 1600 Ripjaws X 
Hard DriveOptical DriveOSMonitor
SSD: Intel 320 series 120GB/3 x Samsung F3 1TB Asus Win 7 Pro 2 x Asus 23" VH232 
KeyboardPowerCaseMouse
Alienware TactX Cooler Master 850W HAF 932 R.A.T. 7 
Mouse Pad
Alienware 
  hide details  
Reply
post #2 of 6
You're getting the BSOD because you don't have AHCI/RAID drivers installed on the OS. You could run a repair with your windows install DVD.

The bios shouldn't revert the controller to RAID, if you've selected IDE. If (for whatever magical reason) it's detecting that the drives have array information, and forcing the RAID after you post, and you've already established a RAID 1 relationship between two of your drives, then you could attempt to delete the RAID volume from the RAID configuration manager which pops up briefly after you pass the post.
    
CPUMotherboardGraphicsRAM
Xeon E5645 Asus Rampage II Gene eVGA GTX460 SSC 3x4GB Corsair Dominator PC3-12800 
Hard DriveHard DriveHard DriveOS
Crucial C300 64GB Seagate Momentus XT 750 Western Digital GP 2TB EARS Windows 7 Premium 
MonitorKeyboardPowerCase
Asus VE278Q DSI SMK-88 Seasonic X-660 Lian Li U6B 2011 SE 
MouseMouse Pad
Logitech G500 KAI.g3 HIEN - HARD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Xeon E5645 Asus Rampage II Gene eVGA GTX460 SSC 3x4GB Corsair Dominator PC3-12800 
Hard DriveHard DriveHard DriveOS
Crucial C300 64GB Seagate Momentus XT 750 Western Digital GP 2TB EARS Windows 7 Premium 
MonitorKeyboardPowerCase
Asus VE278Q DSI SMK-88 Seasonic X-660 Lian Li U6B 2011 SE 
MouseMouse Pad
Logitech G500 KAI.g3 HIEN - HARD 
  hide details  
Reply
post #3 of 6
Thread Starter 
so it worked when i went in and turned PCH to AHCI mode, i could boot and everything...what should i do.
Hope Solo
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k @ 4.5GHZ P67A-UD7-B3 Asus GTX 580 DCII 4 x 4GB 1600 Ripjaws X 
Hard DriveOptical DriveOSMonitor
SSD: Intel 320 series 120GB/3 x Samsung F3 1TB Asus Win 7 Pro 2 x Asus 23" VH232 
KeyboardPowerCaseMouse
Alienware TactX Cooler Master 850W HAF 932 R.A.T. 7 
Mouse Pad
Alienware 
  hide details  
Reply
Hope Solo
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k @ 4.5GHZ P67A-UD7-B3 Asus GTX 580 DCII 4 x 4GB 1600 Ripjaws X 
Hard DriveOptical DriveOSMonitor
SSD: Intel 320 series 120GB/3 x Samsung F3 1TB Asus Win 7 Pro 2 x Asus 23" VH232 
KeyboardPowerCaseMouse
Alienware TactX Cooler Master 850W HAF 932 R.A.T. 7 
Mouse Pad
Alienware 
  hide details  
Reply
post #4 of 6
Make these changes in the registry, then reboot to windows and install the latest Intel drivers, then go set BIOS to RAID and you'll be good to go.

Enable switching between all IDE/AHCI/RAID modes by changing "Start" Values in these keys to 0 (Win 7 / Vista ONLY)
Code:
HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Services\\Msahci\\Start
HKEY_LOCAL_MACHINE\\System\\CurrentControlSet\\Services\\Pciide\\Start  
HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\iaStorV\\Start
http://downloadcenter.intel.com/Sear...age+Technology
    
CPUMotherboardGraphicsRAM
Intel i7 980X EE ES Gigabyte GA-X58A-UD7 GIGABYTE GV-R587SO-1GD SOC 1GB GDDR5 Mushkin 998826 Ridgeback / 998966 Radioactive 
OSMonitorPower
Vista Business x64 SP2 Asus Designo MS238H 23" LED NZXT HALE90 750W 80+ GOLD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7 980X EE ES Gigabyte GA-X58A-UD7 GIGABYTE GV-R587SO-1GD SOC 1GB GDDR5 Mushkin 998826 Ridgeback / 998966 Radioactive 
OSMonitorPower
Vista Business x64 SP2 Asus Designo MS238H 23" LED NZXT HALE90 750W 80+ GOLD 
  hide details  
Reply
post #5 of 6
Thread Starter 
so, i will try that, but if it doesn't work editing that in my registry will it damage anything? i don't ever mess with the registry so i do not know.

EDIT::

well i did that all of them were 0 with the exception of the last one "iaStorv" so I changed that to 0 booted again. I got through the boot and now i set the raid 1 up in bios. Now when i get to the desktop though it has a windows that says
"You must restart your computer to apply these changes"
but i haven't even done anything yet...any suggestion? also how do i make sure that the raid was successful in windows is there a way to check? thanks.

DOUBLE EDIT::

So, rep to Isdmeasap you helped me a lot, i appreciate it! it worked! i booted forget that last part, i got hdtune and it says "Intel Raid 1" thank you i'm very grateful. Overclocknet rules.
Edited by coleweezy23 - 8/11/11 at 3:08pm
Hope Solo
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k @ 4.5GHZ P67A-UD7-B3 Asus GTX 580 DCII 4 x 4GB 1600 Ripjaws X 
Hard DriveOptical DriveOSMonitor
SSD: Intel 320 series 120GB/3 x Samsung F3 1TB Asus Win 7 Pro 2 x Asus 23" VH232 
KeyboardPowerCaseMouse
Alienware TactX Cooler Master 850W HAF 932 R.A.T. 7 
Mouse Pad
Alienware 
  hide details  
Reply
Hope Solo
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-2600k @ 4.5GHZ P67A-UD7-B3 Asus GTX 580 DCII 4 x 4GB 1600 Ripjaws X 
Hard DriveOptical DriveOSMonitor
SSD: Intel 320 series 120GB/3 x Samsung F3 1TB Asus Win 7 Pro 2 x Asus 23" VH232 
KeyboardPowerCaseMouse
Alienware TactX Cooler Master 850W HAF 932 R.A.T. 7 
Mouse Pad
Alienware 
  hide details  
Reply
post #6 of 6
Nice to see you got it finally!

Yes it is perfectly safe, and for anyone that reads this later and needs a fix for error 0x0000007b there is a Microsoft page that shows you how to do this (Or will do it for you automatically with a "Fix").
http://support.microsoft.com/kb/922976
    
CPUMotherboardGraphicsRAM
Intel i7 980X EE ES Gigabyte GA-X58A-UD7 GIGABYTE GV-R587SO-1GD SOC 1GB GDDR5 Mushkin 998826 Ridgeback / 998966 Radioactive 
OSMonitorPower
Vista Business x64 SP2 Asus Designo MS238H 23" LED NZXT HALE90 750W 80+ GOLD 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7 980X EE ES Gigabyte GA-X58A-UD7 GIGABYTE GV-R587SO-1GD SOC 1GB GDDR5 Mushkin 998826 Ridgeback / 998966 Radioactive 
OSMonitorPower
Vista Business x64 SP2 Asus Designo MS238H 23" LED NZXT HALE90 750W 80+ GOLD 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Ok, so I need help...:/