Overclock.net › Forums › Video Games › PC Gaming › Battlefield Bad Company 2 (Help)
New Posts  All Forums:Forum Nav:

Battlefield Bad Company 2 (Help)

post #1 of 10
Thread Starter 
Whenever I try to join a game it wont connect. I played this game for over 125 hours and never had this problem. No matter which server I chose, Vietnam DLC or normal BC2, It wont connect.

Checked if it was my firewall and that was not a problem.
Reinstalled the game and that did not fix it either.
Verified the game with Steam and it showed up as fine.


When I click to join a server it shows this for about 30 seconds.




After about 30 secondsof the "Please Wait" screen, it will display this message.

post #2 of 10
have you tried reseting your modem? Sometimes it can get whacked out or the NAT setting is wrong. mY modem will do this sometimes and I can not connect my phone or girlfriends ipad to it until i reset it.
post #3 of 10
^ But try just unplugging it first. Reinstalling drivers is such a pain...
UltraMini
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690K Asrock Z97E-ITX/ac Gigabyte N970IX-OC-4GD Kingston HyperX 
Hard DriveCoolingOSMonitor
Seagate ST1000LM014 2.5" SSHD Zalman CNPS2X Windows 10 Pro Monoprice MPG24FHD 24" 144Hz Gaming Monitor 
KeyboardPowerCaseMouse
Corsair K70 w/ Red Backlight & MX Blue Switches HDPLEX HiFi 250W DC-ATX v2 NFC Systems S4 Mini Zowie FK1 
Mouse PadAudio
Razer Goliathus (Chinese Knockoff) Phillips SHP9500 w/ Vmoda Boom Pro Microphone 
  hide details  
Reply
UltraMini
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690K Asrock Z97E-ITX/ac Gigabyte N970IX-OC-4GD Kingston HyperX 
Hard DriveCoolingOSMonitor
Seagate ST1000LM014 2.5" SSHD Zalman CNPS2X Windows 10 Pro Monoprice MPG24FHD 24" 144Hz Gaming Monitor 
KeyboardPowerCaseMouse
Corsair K70 w/ Red Backlight & MX Blue Switches HDPLEX HiFi 250W DC-ATX v2 NFC Systems S4 Mini Zowie FK1 
Mouse PadAudio
Razer Goliathus (Chinese Knockoff) Phillips SHP9500 w/ Vmoda Boom Pro Microphone 
  hide details  
Reply
post #4 of 10
try a new soldier.
then after sometime go back to the one you've been using.
mOjO
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2400 3.1 Ghz. ASUS P8H61-M LE R2.0 EVGA GTX 960 2GB SSC 16GB Corsair Vengeance Pro 
Hard DriveOptical DriveOSMonitor
120 gb SSD LG dvd burner Win 7 Home Prem. 64 Bit Quasar 32" 1080p 
PowerCaseMouse
Solid Gear 300 Watt Mini ITX RoseWill Wired 
  hide details  
Reply
mOjO
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2400 3.1 Ghz. ASUS P8H61-M LE R2.0 EVGA GTX 960 2GB SSC 16GB Corsair Vengeance Pro 
Hard DriveOptical DriveOSMonitor
120 gb SSD LG dvd burner Win 7 Home Prem. 64 Bit Quasar 32" 1080p 
PowerCaseMouse
Solid Gear 300 Watt Mini ITX RoseWill Wired 
  hide details  
Reply
post #5 of 10
right just leave the power to the modem off for about a minute, and plug back in and see what happens. If all else fails go into your modem settings and put your PC's IP address into the DMZ so it will for sure be and open NAT.

Quote:
Originally Posted by hat1324 View Post
^ But try just unplugging it first. Reinstalling drivers is such a pain...
post #6 of 10
Thread Starter 
I can connect to the internet just fine but my game wont connect to servers.
After crawling upstairs with a broken leg to reset the modem, it still doesnt work.

Any other things I could try?
Edited by Shaded War - 8/14/11 at 12:31pm
post #7 of 10
start a new soldier
mOjO
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2400 3.1 Ghz. ASUS P8H61-M LE R2.0 EVGA GTX 960 2GB SSC 16GB Corsair Vengeance Pro 
Hard DriveOptical DriveOSMonitor
120 gb SSD LG dvd burner Win 7 Home Prem. 64 Bit Quasar 32" 1080p 
PowerCaseMouse
Solid Gear 300 Watt Mini ITX RoseWill Wired 
  hide details  
Reply
mOjO
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2400 3.1 Ghz. ASUS P8H61-M LE R2.0 EVGA GTX 960 2GB SSC 16GB Corsair Vengeance Pro 
Hard DriveOptical DriveOSMonitor
120 gb SSD LG dvd burner Win 7 Home Prem. 64 Bit Quasar 32" 1080p 
PowerCaseMouse
Solid Gear 300 Watt Mini ITX RoseWill Wired 
  hide details  
Reply
post #8 of 10
Thread Starter 
Quote:
Originally Posted by bleuborsh View Post
start a new soldier
I was going to try that and it asked for another cd key and im not going to pay for another one.
post #9 of 10
You shouldn't need a new key to create another soldier, only if you want to create another user it will ask this.
Struggle
(13 items)
 
  
CPUMotherboardGraphicsRAM
QX9650 @ 3.6GHz XFX 790i Ultra SLI GTX280 702/1405/2468 2 x 2GB DDR3 Corsair Dominator 1,333MHz 
Hard DriveOptical DriveOSMonitor
60GB OCZ Summit SSD, WD VelociRaptor, Seagate 1TB LG DVD R/W Windows 7 Pro 64-bit Dell 24" (1920x1200) 
KeyboardPowerCaseMouse
Logitech G19 Fujitech 800W Asus Vento 3600 (Black) Razor Mamba 
  hide details  
Reply
Struggle
(13 items)
 
  
CPUMotherboardGraphicsRAM
QX9650 @ 3.6GHz XFX 790i Ultra SLI GTX280 702/1405/2468 2 x 2GB DDR3 Corsair Dominator 1,333MHz 
Hard DriveOptical DriveOSMonitor
60GB OCZ Summit SSD, WD VelociRaptor, Seagate 1TB LG DVD R/W Windows 7 Pro 64-bit Dell 24" (1920x1200) 
KeyboardPowerCaseMouse
Logitech G19 Fujitech 800W Asus Vento 3600 (Black) Razor Mamba 
  hide details  
Reply
post #10 of 10
Thread Starter 
Problem solved. My NAT type was at moderate and that caused problems connecting to 95% of the servers.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Battlefield Bad Company 2 (Help)