Overclock.net › Forums › Graphics Cards › Graphics Cards - General › What would you do? (replace, refund, etc)
New Posts  All Forums:Forum Nav:

What would you do? (replace, refund, etc)

post #1 of 12
Thread Starter 
Hey guys

I'm curious to see what you would do in my case.
I made some upgrades to my machine one of them being a graphics card. First time around I chose a MSI 6970 Lightning after it was finally in stock. It worked the first week and then proceeded to not work by freezing and give me black screens. Upgrading the PSU to a Corsair AX850 did not solve the problem.
It upset me that this expensive card failed dam you msi/amd! Ok let's try Nvidia which is what I wanted in the first place. I then chose the Gigabyte GTX570 SOC (GV-N570SO-13I). My objective was a fast card that's quite. Fast with out me having to OC it. This was a good option.
This is what I have at the moment but the card makes me uneasy. In two or three ocassions it has failed to post when booting and doing the usual cable, seating, switching slots didn't really resolve the problem. It just started working again. The card presents no problems in windows.
So I submitted a ticket to Gigabyte to see what they would tell me. The response they gave me doesn't give me any confidence at all. This is what I'm paying almost $360+ for?

Here is the ticket:
Quote:
Hello
I just bought this card and it works most of the time. The problem I'm having is that sometimes when I turn on the PC I get the bios error POST sounds: 1 long 2 short.
When that happens the video card's LED's don't light up or if they do they eventually turn off and the fans run at full speed or fast.
Here is what I've done:
Change PCI-E power cables.
Re-seat the card on the graphic slot.
Change graphic slot.
Use my old graphics card: ATI 4850, when I do this the computer works.
Then I reverted my motherboards bios from F14P back to version F13.
I re-install the GTX570 and it doesn't work.
I just leave the system for a bit...and try again.
Now the machine boots up. I have no idea why...
In windows doing benchmarks (kombuster for an hour, 3dmark 11, Heaven DX11) or playing games there aren't any lockups, artifacts, heat problems. Everything is fine. It's just booting up that it sometimes doesn't work.
I will continue to test with bios version F13 but I don't know if that could affect it.

Please advise what I should do.
Thanks!



-------------------------------------------------------------------------------
Model Name : GV-N570SO-13I
--------------------------
PCB ver : 1
Driver Ver : 257.33
Serial No. : *****
Purchase Dealer : newegg.com
-------------------------------------------------------------------------------
Motherboard Brand : GIGABYTE
Model : ex58-ud4p
Operation System : Win 7 64-bit SP : 1


6GB OCZ 1600Mhz
i7 920 stock
Crucial M4 128GB
Hitachi 2TB 7200RPM
DVD-R Drive
Corsair AX850 PSU
HAF 932 Case
Dell 2407WFP display
Motherboard bios: F14P
Response to ticket:
Quote:
Dear Customer,

That relates to the video error code, have you tried moving the card over to the 2nd PCIe slot to test the results?
Also for the driver please use the latest directly off nvidia website and test with DX10 instead of DX10 by removing it and reloading DX10
Did I explain my self incorrectly in the ticket?
I feel like getting a refund for a second time with a different card manufacturer. Then maybe try at it a third time with a different manufacturer (evga?).
These "premium" cards don't feel like it at all.
Thanks for any input.
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
post #2 of 12
Quote:
Originally Posted by eizen View Post
Hey guys

I'm curious to see what you would do in my case.
I made some upgrades to my machine one of them being a graphics card. First time around I chose a MSI 6970 Lightning after it was finally in stock. It worked the first week and then proceeded to not work by freezing and give me black screens. Upgrading the PSU to a Corsair AX850 did not solve the problem.
It upset me that this expensive card failed dam you msi/amd! Ok let's try Nvidia which is what I wanted in the first place. I then chose the Gigabyte GTX570 SOC (GV-N570SO-13I). My objective was a fast card that's quite. Fast with out me having to OC it. This was a good option.
This is what I have at the moment but the card makes me uneasy. In two or three ocassions it has failed to post when booting and doing the usual cable, seating, switching slots didn't really resolve the problem. It just started working again. The card presents no problems in windows.
So I submitted a ticket to Gigabyte to see what they would tell me. The response they gave me doesn't give me any confidence at all. This is what I'm paying almost $360+ for?

Here is the ticket:


Response to ticket:


Did I explain my self incorrectly in the ticket?
I feel like getting a refund for a second time with a different card manufacturer. Then maybe try at it a third time with a different manufacturer (evga?).
These "premium" cards don't feel like it at all.
Thanks for any input.
Support these days keeps getting worse and worse. I don't blame you for your feelings...

It sounds like a pure motherboard error to me. Have you tried onboard several times? If it posts every time consistently with onboard, then it has to do with your pci-e slots, or even possibly your south bridge.

Do you have a spare compatible mobo laying around???

-Jack
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
post #3 of 12
Thread Starter 
I've never had a problem posting/booting up with my old ATI 4850.
But maybe it was a motherboard bios thing. (I reverted back to an older bios. Taking notes in the future would be better than trying to remember if it posted once I went back to the old bios.)

The decision is to keep testing the card or send it back before the 30day return period is up lol
Just a little confused at this point.
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
post #4 of 12
Quote:
Originally Posted by eizen View Post
I've never had a problem posting/booting up with my old ATI 4850.
But maybe it was a motherboard bios thing. (I reverted back to an older bios. Taking notes in the future would be better than trying to remember if it posted once I went back to the old bios.)

The decision is to keep testing the card or send it back before the 30day return period is up lol
Just a little confused at this point.
Return the card. Get your money back until you know what the problem is, then you might be able to fix the problem, and finally, get the working card you desire!
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
post #5 of 12
Hey Eizen, When you say you can't post/boot do you mean when you start up your computer after being off?

Do you hear the post? Does all your fans come on but don't boot? Does it take you a second try to boot up? Does your system have troubles if it falls asleep, waking up by shaking mouse?

Curious, is your RAM over clocked?
     
  hide details  
Reply
     
  hide details  
Reply
post #6 of 12
Thread Starter 
Quote:
Originally Posted by Arizonian View Post
Hey Eizen, When you say you can't post/boot do you mean when you start up your computer after being off?

Do you hear the post? Does all your fans come on but don't boot? Does it take you a second try to boot up? Does your system have troubles if it falls asleep, waking up by shaking mouse?

Curious, is your RAM over clocked?
Yes, when it's been off and I turn it on. It didn't boot and gave me the bios error beeps of when there is no video card present (one long beep and two short). Everything works as normal except the video card. The solution was just waiting it out and then it worked again. What's interesting is that in one of those ocassions I installed the ATI 4850 while having the Gigabyte installed on the second PCI-E #2 slot and booted into windows. While in windows the GTX570 was NOT detected. After some shutdowns and reboots it just appeared and was present in windows device manager.

Nope, no troubles with sleeping or waking up.
My ram was not OC'd just set to run at it's stated speed by using manual settings.

Right now I'm using the gtx570 just fine for the past 2-3 days.
The only thing I can think of was maybe it was the bios that I was running on the mobo. But my old card still worked with no problems with that bios... I rolled back to a non-beta version.
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
post #7 of 12
Quote:
Originally Posted by jetboy623 View Post
Support these days keeps getting worse and worse.
Noticed the same thing
    
CPUMotherboardGraphicsRAM
2500K Asus P8Z68-V Gigabyte GTX 480 SOC 8gb DDR3 1600 c9 Ripjaws 
Hard DriveMonitorPowerCase
Too many to list 1920 x 1200, 24" Acer Corsair 650TX Naving Benching Station 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
2500K Asus P8Z68-V Gigabyte GTX 480 SOC 8gb DDR3 1600 c9 Ripjaws 
Hard DriveMonitorPowerCase
Too many to list 1920 x 1200, 24" Acer Corsair 650TX Naving Benching Station 
  hide details  
Reply
post #8 of 12
Thread Starter 
Blah...it failed again today.
Just a little over a week since last time.
Here's a video:
http://youtu.be/Vg8Fmg2s5ok

I think it's time to send it back.
Could it be the mobo? I don't think so since it works with the 4850. Is there any reason why the mobo wouldn't work with this newer card?

Edit2:deleted I had already mentioned it in the initial post
Edited by eizen - 8/22/11 at 8:18pm
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
post #9 of 12
Quote:
Originally Posted by eizen View Post
Blah...it failed again today.
Just a little over a week since last time.
Here's a video:
http://youtu.be/Vg8Fmg2s5ok

I think it's time to send it back.
Could it be the mobo? I don't think so since it works with the 4850. Is there any reason why the mobo wouldn't work with this newer card?

Edit2:deleted I had already mentioned it in the initial post
Yep, definitely NOT the mobo... for obvious reasons. According to your computer specs in your sig, you already RMA'd it. Good job!

This whole issue was weird from the start
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
post #10 of 12
Thread Starter 
As an update:

It's been about two weeks since I got a THIRD video card. Is it too soon to be posting? Not sure but anyways...

This time I went back to MSI but got a GTX570 Twin Frozr iii. Also I ordered it from Amazon rather than newegg (they were out of stock at the time). The first interesting thing I noticed was that when I received the card from Amazon it was different than the msi 6970 lightning from newegg. The 570 from Amazon had a taped bag. I don't recall having to remove a tape from the 6970 (I may be mistaken though). What was truely different was that the 570's heatsink (the entire silver part) had a sort of heath shrink wrap on it so I had to peel it off. That made me feel that it was really a new card. Looking back, the 6970 lightning from newegg didn't have the adhered plastic to the card which makes me think if it was really a new card or one that was returned as a "oh nvm I don't want this card".

All that aside my new 570 works! I haven't had any trouble with it even with my i7 920 @4.2Ghz. It is a tad louder than the gigabyte 570 but who cares at this point as long as it works.
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
Sleeping Monster
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 GAEX58-UD4P MSI GTX570 Twin Frozr iii Samsung Green Dual channel Kit 
Hard DriveHard DriveOptical DriveCooling
Hitachi WD Black LG DVD-R Noctua NH-D14 
OSMonitorMonitorKeyboard
Win 7 64 Pro DELL 2407WFP DELL u2412m Das Keyboard Pro 
PowerCaseMouseMouse Pad
Corsair AX850 600T SE Coolermaster/Logitech Steelseries 4HD 
AudioAudioAudio
Fiio 10e Beyerdynamic DT 990 250Ohm Premium Logitech G930 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards - General
Overclock.net › Forums › Graphics Cards › Graphics Cards - General › What would you do? (replace, refund, etc)