Overclock.net › Forums › Graphics Cards › AMD/ATI › Toxic Edition 6950 Power Issues?
New Posts  All Forums:Forum Nav:

Toxic Edition 6950 Power Issues?

post #1 of 7
Thread Starter 
Hi all! I recently made a thread on Sapphire's forums for support and then realized like one person visits a day... I imagine you guys will be more helpful anyways

Ok, so I've got a strange situation here. Today, my shiny pair of the new Sapphire 6950s came in the mail along with my replacement PSU, an Antec HCG-900 (900W).

After 3 hours of cleaning and cable re-organization, I found, much to my chagrin, that the cards were not being recognized on boot-up (got the "no vga" beep sequence). What they were doing though, is blasting air at 100% fan speed. They also had a little red light on in the back. Some googling told me both of these were most likely signs of insufficient power.

I tried only one card next. No cigar.
The other. Nope.

Hmmm, must be the PSU! Faulty rail? I tried an old older card (actually both a HD4870 and an 8800GT) with two 6 pin power connectors (the toxic 6950 has an 8 and a 6) and everything worked just fine. Strange, maybe the 2 pin add-on to the 6 pin connector doesn't work?

I then tried one card with my old 600W supply. Lo and behold...still doesn't work!?

I'm out of ideas, what the hell is my problem? My PSU definitely seems on the level, and there are no doubts about it being able to handle a single 6950. Mobo and ports are clearly OK too. The only thing I can think of is that both cards are bad, but the chances of that seem oh so slim...

I'd appreciate the advice!
Thanks OCN
post #2 of 7
Use a corsair PSU? They are the most reliable.
Computer 1
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z77-V PRO EVGA GTX 770 ACX Corsair 2 x 4GB DDR3 1600MHz 
Hard DriveHard DriveCoolingOS
Samsung 840 Evo 250GB Western Digital Blue 1TB Cooler Master Hyper 212 EVO Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VS248H-P Cooler Master Quickfire Rapid MX Blue Corsair AX650 Fractal Design Define R4 
MouseMouse PadAudioAudio
Logitech G502 YuHua Gaming Mouse Pad Logitech Z323 Sennheiser HD 558 
Audio
Creative Soundblaster Z 
  hide details  
Reply
Computer 1
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z77-V PRO EVGA GTX 770 ACX Corsair 2 x 4GB DDR3 1600MHz 
Hard DriveHard DriveCoolingOS
Samsung 840 Evo 250GB Western Digital Blue 1TB Cooler Master Hyper 212 EVO Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VS248H-P Cooler Master Quickfire Rapid MX Blue Corsair AX650 Fractal Design Define R4 
MouseMouse PadAudioAudio
Logitech G502 YuHua Gaming Mouse Pad Logitech Z323 Sennheiser HD 558 
Audio
Creative Soundblaster Z 
  hide details  
Reply
post #3 of 7
i think it can be your pic-e slot which is causing problem? because 900W should be more then enough to run 1 HD 6950...you can try asking for replacement for the card or just try changing your PSU to crossair as the above member mentioned.
post #4 of 7
Perhaps find a unused card and test that? Google and see if other people have had this problem.
Computer 1
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z77-V PRO EVGA GTX 770 ACX Corsair 2 x 4GB DDR3 1600MHz 
Hard DriveHard DriveCoolingOS
Samsung 840 Evo 250GB Western Digital Blue 1TB Cooler Master Hyper 212 EVO Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VS248H-P Cooler Master Quickfire Rapid MX Blue Corsair AX650 Fractal Design Define R4 
MouseMouse PadAudioAudio
Logitech G502 YuHua Gaming Mouse Pad Logitech Z323 Sennheiser HD 558 
Audio
Creative Soundblaster Z 
  hide details  
Reply
Computer 1
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z77-V PRO EVGA GTX 770 ACX Corsair 2 x 4GB DDR3 1600MHz 
Hard DriveHard DriveCoolingOS
Samsung 840 Evo 250GB Western Digital Blue 1TB Cooler Master Hyper 212 EVO Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VS248H-P Cooler Master Quickfire Rapid MX Blue Corsair AX650 Fractal Design Define R4 
MouseMouse PadAudioAudio
Logitech G502 YuHua Gaming Mouse Pad Logitech Z323 Sennheiser HD 558 
Audio
Creative Soundblaster Z 
  hide details  
Reply
post #5 of 7
Ti-89 Titanium
(13 items)
 
 
CPUMotherboardRAMHard Drive
Motorola 68k @16 MHz Ti-89 HW4 256 KB 2.6 MB Flash ROM 
OSMonitorPowerCase
Ti-89 OS 3.10 LCD Dot-Matrix 160x100 4x 1.5V AAA Ti-89 HW4 Black 
CPUMotherboardGraphicsRAM
Intel Core™ i7 930 Gigabyte GA-X58A-UD3R 2.0 Gigabyte GTX 470 SOC G.Skill RX 2x4GB 1600C8 
Hard DriveHard DriveOptical DriveCooling
PNY Prevail Elite 120GB Hitachi 7K1000.C 1TB LG GH24LS50 Noctua NH-C12P SE14 
OSOSMonitorKeyboard
Windows 8 Pro x64 Lubuntu 13.10 x64 Samsung BX2250 Logitech Illuminated 
PowerCaseMouseAudio
Be Quiet! S.P. E⁷ 600W Fractal Design Core 3000 Logitech G300 AKG K240 Studio 
  hide details  
Reply
Ti-89 Titanium
(13 items)
 
 
CPUMotherboardRAMHard Drive
Motorola 68k @16 MHz Ti-89 HW4 256 KB 2.6 MB Flash ROM 
OSMonitorPowerCase
Ti-89 OS 3.10 LCD Dot-Matrix 160x100 4x 1.5V AAA Ti-89 HW4 Black 
CPUMotherboardGraphicsRAM
Intel Core™ i7 930 Gigabyte GA-X58A-UD3R 2.0 Gigabyte GTX 470 SOC G.Skill RX 2x4GB 1600C8 
Hard DriveHard DriveOptical DriveCooling
PNY Prevail Elite 120GB Hitachi 7K1000.C 1TB LG GH24LS50 Noctua NH-C12P SE14 
OSOSMonitorKeyboard
Windows 8 Pro x64 Lubuntu 13.10 x64 Samsung BX2250 Logitech Illuminated 
PowerCaseMouseAudio
Be Quiet! S.P. E⁷ 600W Fractal Design Core 3000 Logitech G300 AKG K240 Studio 
  hide details  
Reply
post #6 of 7
I never really did like antec PSUs...bad +12v rail(s)!
Edited by Osea23 - 8/17/11 at 9:39am
Computer 1
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z77-V PRO EVGA GTX 770 ACX Corsair 2 x 4GB DDR3 1600MHz 
Hard DriveHard DriveCoolingOS
Samsung 840 Evo 250GB Western Digital Blue 1TB Cooler Master Hyper 212 EVO Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VS248H-P Cooler Master Quickfire Rapid MX Blue Corsair AX650 Fractal Design Define R4 
MouseMouse PadAudioAudio
Logitech G502 YuHua Gaming Mouse Pad Logitech Z323 Sennheiser HD 558 
Audio
Creative Soundblaster Z 
  hide details  
Reply
Computer 1
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K ASUS P8Z77-V PRO EVGA GTX 770 ACX Corsair 2 x 4GB DDR3 1600MHz 
Hard DriveHard DriveCoolingOS
Samsung 840 Evo 250GB Western Digital Blue 1TB Cooler Master Hyper 212 EVO Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VS248H-P Cooler Master Quickfire Rapid MX Blue Corsair AX650 Fractal Design Define R4 
MouseMouse PadAudioAudio
Logitech G502 YuHua Gaming Mouse Pad Logitech Z323 Sennheiser HD 558 
Audio
Creative Soundblaster Z 
  hide details  
Reply
post #7 of 7
Back when i got my shiny new 9800GTs it done somthing similar, downgraded to a 9600gt and it worked fine, im guesseing it was somthing to do with a bad Pci-e slot.

My suggestion is RMA motherboard if two differet cards and PSUs dont work.
    
CPUMotherboardGraphicsRAM
i7 950 4GHz 1.26V Asus P6X58D-E 6950 Powercolor 2GB (Dual Fan) 6GB Gskill 
Hard DriveOSMonitorPower
1TB Sata 3 + 250GB + 500GB Win 7 Professional 64Bit LG Flatron E2260V-PN + 2x(19' 3:3) Coolermaster 1000w Silent Pro 
Case
Coolermaster CM690 II 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 950 4GHz 1.26V Asus P6X58D-E 6950 Powercolor 2GB (Dual Fan) 6GB Gskill 
Hard DriveOSMonitorPower
1TB Sata 3 + 250GB + 500GB Win 7 Professional 64Bit LG Flatron E2260V-PN + 2x(19' 3:3) Coolermaster 1000w Silent Pro 
Case
Coolermaster CM690 II 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Toxic Edition 6950 Power Issues?