Overclock.net › Forums › Graphics Cards › AMD/ATI › Bad Company 2 BSOD while Patching? 5770's fault?
New Posts  All Forums:Forum Nav:

Bad Company 2 BSOD while Patching? 5770's fault?

post #1 of 8
Thread Starter 
So, I recently got a new hard drive and am reinstalling all my stuff on it. I have everything back in, have the newest drivers for everything. Everything has been working fine EXCEPT for bad company 2.

I installed it from the cd, and every time I click the game it goes straight to the game; it doesn't check my game version like it used to. So, I went to the bad company folder and manually clicked the update exe. It gets about a quarter of the way through and then boom, Blue Screen of Death. Every. Time.

What am I doing wrong? After some research people claimed that their graphics cards were the problem, but my drivers are* up to date and it's not overclocked or anything. I really just don't understand. (I have a radeon 5770 right now).

Specs:
AMD Athlon II x4 620 Processor 2.6 Ghz
OCZ 4Gb DDR3 RAM
Windows 7 64 bit
1 TB Western Digital 7200 RPM SATA 3.0Gb/s
BIOSTAR TA790GXB3 AM3 AMD 790GX ATX AMD Motherboard
XFX HD-577X-ZNFC Radeon HD 5770 1GB 128-bit DDR5
OCZ ModXStream Pro 500W PSU
Edited by kire - 8/18/11 at 6:15am
post #2 of 8
What code do you get?
Updated Arc
(19 items)
 
Lenovo E330
(8 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E3-1270V3 GA-Z87X-UD4H Gigabyte GTX 780 Windforce OC R2 Gigabyte GTX 780 Windforce OC R2 
RAMHard DriveHard DriveHard Drive
Corsiar Vengeance Pro 1866 - 2x8GB Samsung 840 EVO 250GB Plextor M3 Pro 128GB Western Digital Red 3TB 
CoolingOSMonitorMonitor
CPU: Corsair H100 w/ 2x GT AP-15's fans Windows 8.1 Pro w/ Start is Back BenQ XL2420T Samsung XL2730 
KeyboardPowerCaseMouse
Duckie Shine 2 - MX Red Corsair AX750 Fractal Design - Arc Midi R2 Zowie AM 
Mouse PadAudioAudio
Steelseries QCK Mass Fiio E09K + Beyer Dynamic DT-770 pro's + Antli... Speakers: Argon 7460  
CPUMotherboardGraphicsRAM
i5 3210m@2.5Ghz ~3.1Ghz Turbo Lenovo HM77 GT 610m Kingston value pc3-12800 cl11 
Hard DriveOSMonitorPower
Crucial m4 - 128gb + Sandisk 16gb mSATA  Windows 7 Ultimate 64 bit 13.3 LED - 1366x768 90W 
  hide details  
Reply
Updated Arc
(19 items)
 
Lenovo E330
(8 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E3-1270V3 GA-Z87X-UD4H Gigabyte GTX 780 Windforce OC R2 Gigabyte GTX 780 Windforce OC R2 
RAMHard DriveHard DriveHard Drive
Corsiar Vengeance Pro 1866 - 2x8GB Samsung 840 EVO 250GB Plextor M3 Pro 128GB Western Digital Red 3TB 
CoolingOSMonitorMonitor
CPU: Corsair H100 w/ 2x GT AP-15's fans Windows 8.1 Pro w/ Start is Back BenQ XL2420T Samsung XL2730 
KeyboardPowerCaseMouse
Duckie Shine 2 - MX Red Corsair AX750 Fractal Design - Arc Midi R2 Zowie AM 
Mouse PadAudioAudio
Steelseries QCK Mass Fiio E09K + Beyer Dynamic DT-770 pro's + Antli... Speakers: Argon 7460  
CPUMotherboardGraphicsRAM
i5 3210m@2.5Ghz ~3.1Ghz Turbo Lenovo HM77 GT 610m Kingston value pc3-12800 cl11 
Hard DriveOSMonitorPower
Crucial m4 - 128gb + Sandisk 16gb mSATA  Windows 7 Ultimate 64 bit 13.3 LED - 1366x768 90W 
  hide details  
Reply
post #3 of 8
Thread Starter 
Quote:
Originally Posted by DoctorNick View Post
What code do you get?
I just realized that I didn't write it down...guess I'll try to update it again and find it for you guys. In the mean time, if there's any advice, I'll have my laptop out.
post #4 of 8
Roger that. Dosen't sound like a GPU problem, more like a harddisk issue. But lets have a look at that code

Edit: And in the meantime please fill out your system specs.
Edited by DoctorNick - 8/18/11 at 6:01am
Updated Arc
(19 items)
 
Lenovo E330
(8 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E3-1270V3 GA-Z87X-UD4H Gigabyte GTX 780 Windforce OC R2 Gigabyte GTX 780 Windforce OC R2 
RAMHard DriveHard DriveHard Drive
Corsiar Vengeance Pro 1866 - 2x8GB Samsung 840 EVO 250GB Plextor M3 Pro 128GB Western Digital Red 3TB 
CoolingOSMonitorMonitor
CPU: Corsair H100 w/ 2x GT AP-15's fans Windows 8.1 Pro w/ Start is Back BenQ XL2420T Samsung XL2730 
KeyboardPowerCaseMouse
Duckie Shine 2 - MX Red Corsair AX750 Fractal Design - Arc Midi R2 Zowie AM 
Mouse PadAudioAudio
Steelseries QCK Mass Fiio E09K + Beyer Dynamic DT-770 pro's + Antli... Speakers: Argon 7460  
CPUMotherboardGraphicsRAM
i5 3210m@2.5Ghz ~3.1Ghz Turbo Lenovo HM77 GT 610m Kingston value pc3-12800 cl11 
Hard DriveOSMonitorPower
Crucial m4 - 128gb + Sandisk 16gb mSATA  Windows 7 Ultimate 64 bit 13.3 LED - 1366x768 90W 
  hide details  
Reply
Updated Arc
(19 items)
 
Lenovo E330
(8 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E3-1270V3 GA-Z87X-UD4H Gigabyte GTX 780 Windforce OC R2 Gigabyte GTX 780 Windforce OC R2 
RAMHard DriveHard DriveHard Drive
Corsiar Vengeance Pro 1866 - 2x8GB Samsung 840 EVO 250GB Plextor M3 Pro 128GB Western Digital Red 3TB 
CoolingOSMonitorMonitor
CPU: Corsair H100 w/ 2x GT AP-15's fans Windows 8.1 Pro w/ Start is Back BenQ XL2420T Samsung XL2730 
KeyboardPowerCaseMouse
Duckie Shine 2 - MX Red Corsair AX750 Fractal Design - Arc Midi R2 Zowie AM 
Mouse PadAudioAudio
Steelseries QCK Mass Fiio E09K + Beyer Dynamic DT-770 pro's + Antli... Speakers: Argon 7460  
CPUMotherboardGraphicsRAM
i5 3210m@2.5Ghz ~3.1Ghz Turbo Lenovo HM77 GT 610m Kingston value pc3-12800 cl11 
Hard DriveOSMonitorPower
Crucial m4 - 128gb + Sandisk 16gb mSATA  Windows 7 Ultimate 64 bit 13.3 LED - 1366x768 90W 
  hide details  
Reply
post #5 of 8
Thread Starter 
Specs:
AMD Athlon II x4 620 Processor 2.6 Ghz
OCZ 4Gb DDR3 RAM
Windows 7 64 bit
1 TB Western Digital 7200 RPM SATA 3.0Gb/s
BIOSTAR TA790GXB3 AM3 AMD 790GX ATX AMD Motherboard
XFX HD-577X-ZNFC Radeon HD 5770 1GB 128-bit DDR5
OCZ ModXStream Pro 500W PSU
post #6 of 8
Quote:
Originally Posted by kire View Post
Specs:
AMD Athlon II x4 620 Processor 2.6 Ghz
OCZ 4Gb DDR3 RAM
Windows 7 64 bit
1 TB Western Digital 7200 RPM SATA 3.0Gb/s
BIOSTAR TA790GXB3 AM3 AMD 790GX ATX AMD Motherboard
XFX HD-577X-ZNFC Radeon HD 5770 1GB 128-bit DDR5
OCZ ModXStream Pro 500W PSU
Thank you. Now we just need the code.
Updated Arc
(19 items)
 
Lenovo E330
(8 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E3-1270V3 GA-Z87X-UD4H Gigabyte GTX 780 Windforce OC R2 Gigabyte GTX 780 Windforce OC R2 
RAMHard DriveHard DriveHard Drive
Corsiar Vengeance Pro 1866 - 2x8GB Samsung 840 EVO 250GB Plextor M3 Pro 128GB Western Digital Red 3TB 
CoolingOSMonitorMonitor
CPU: Corsair H100 w/ 2x GT AP-15's fans Windows 8.1 Pro w/ Start is Back BenQ XL2420T Samsung XL2730 
KeyboardPowerCaseMouse
Duckie Shine 2 - MX Red Corsair AX750 Fractal Design - Arc Midi R2 Zowie AM 
Mouse PadAudioAudio
Steelseries QCK Mass Fiio E09K + Beyer Dynamic DT-770 pro's + Antli... Speakers: Argon 7460  
CPUMotherboardGraphicsRAM
i5 3210m@2.5Ghz ~3.1Ghz Turbo Lenovo HM77 GT 610m Kingston value pc3-12800 cl11 
Hard DriveOSMonitorPower
Crucial m4 - 128gb + Sandisk 16gb mSATA  Windows 7 Ultimate 64 bit 13.3 LED - 1366x768 90W 
  hide details  
Reply
Updated Arc
(19 items)
 
Lenovo E330
(8 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E3-1270V3 GA-Z87X-UD4H Gigabyte GTX 780 Windforce OC R2 Gigabyte GTX 780 Windforce OC R2 
RAMHard DriveHard DriveHard Drive
Corsiar Vengeance Pro 1866 - 2x8GB Samsung 840 EVO 250GB Plextor M3 Pro 128GB Western Digital Red 3TB 
CoolingOSMonitorMonitor
CPU: Corsair H100 w/ 2x GT AP-15's fans Windows 8.1 Pro w/ Start is Back BenQ XL2420T Samsung XL2730 
KeyboardPowerCaseMouse
Duckie Shine 2 - MX Red Corsair AX750 Fractal Design - Arc Midi R2 Zowie AM 
Mouse PadAudioAudio
Steelseries QCK Mass Fiio E09K + Beyer Dynamic DT-770 pro's + Antli... Speakers: Argon 7460  
CPUMotherboardGraphicsRAM
i5 3210m@2.5Ghz ~3.1Ghz Turbo Lenovo HM77 GT 610m Kingston value pc3-12800 cl11 
Hard DriveOSMonitorPower
Crucial m4 - 128gb + Sandisk 16gb mSATA  Windows 7 Ultimate 64 bit 13.3 LED - 1366x768 90W 
  hide details  
Reply
post #7 of 8
Thread Starter 
Well, this time my screen just straight up froze. I'm trying to find a work around, downloading the patch manually from fileplanet that a friend recommended. Sorry if that's not enough information to work with
post #8 of 8
Have you tried reinstalling the game?
Edited by EastCoast - 8/18/11 at 8:20am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Bad Company 2 BSOD while Patching? 5770's fault?