post #11 of 11
Thread Starter 
Found the issue. MB changed my boot order when I enabled ACHI. Stupid Gigabyte. It's a known issue too (googled it).

Scared the hell out of me!