Overclock.net › Forums › Components › Sound Cards and Computer Audio › Logitech Z-5500 Subwoofer is not working correctly...
New Posts  All Forums:Forum Nav:

Logitech Z-5500 Subwoofer is not working correctly...

post #1 of 16
Thread Starter 
wondering if anyone had a fix for this...

the subwoofer doesnt make the boomy sound anymore..i have the subwoofer turned all the way up and cannot even feel it

is it fuse related or a dead subwoofer maybe...?

ive tried using it with my PC and PS3, but same issue...
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
post #2 of 16
did you have a power surge recently? inard amp could have fried
Hobbes
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4790K GA-Z97X-SOC Gigabyte GTX 1080 Gaming Samsung MV-3V4G3D/US 16GB 
Hard DriveCoolingOSKeyboard
Samsung 850 EVO 250GB EK Predator 240mm Windows 7 x64 Das Keyboard 4 Professional CherryMX Blue 
PowerCaseMouseAudio
Seasonic X750 Gold Corsair Carbide Air 540 Logitech G900 Schiit Bifrost Uber W/ USB Gen 2 DAC 
AudioAudioAudioAudio
Schiit Asgard 2 Headphone Amp Audioengine N22 Speaker Amp AudioQuest Nighthawk Audioengine P4 Monitors. 
  hide details  
Reply
Hobbes
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4790K GA-Z97X-SOC Gigabyte GTX 1080 Gaming Samsung MV-3V4G3D/US 16GB 
Hard DriveCoolingOSKeyboard
Samsung 850 EVO 250GB EK Predator 240mm Windows 7 x64 Das Keyboard 4 Professional CherryMX Blue 
PowerCaseMouseAudio
Seasonic X750 Gold Corsair Carbide Air 540 Logitech G900 Schiit Bifrost Uber W/ USB Gen 2 DAC 
AudioAudioAudioAudio
Schiit Asgard 2 Headphone Amp Audioengine N22 Speaker Amp AudioQuest Nighthawk Audioengine P4 Monitors. 
  hide details  
Reply
post #3 of 16
Could definitely be a blown fuse, that is the first thing to check. Also make sure to check your software, both the sound card's and media player's software to make sure you didn't turn the bass down or off on accident. Also is there a red or blue ring around the power button on your control pod? If not it probably is indeed a blown fuse.

[ame]http://www.youtube.com/watch?v=h3cqrIY74oc[/ame]
ZulliRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel C2D E6600 B2 EVGA 680i A1 Evga 8800GT OCZ 4GB DDR2 800 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 600 GB NEC DVD-RW Windows 7 Pro 64-bit BenQ V2400W 24" widescreen 
KeyboardPowerCaseMouse
Random Logitech OCZ GameXStream 700 Watt Antec P182 Logitech G700 
Mouse Pad
Razer Destructor 
  hide details  
Reply
ZulliRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel C2D E6600 B2 EVGA 680i A1 Evga 8800GT OCZ 4GB DDR2 800 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 600 GB NEC DVD-RW Windows 7 Pro 64-bit BenQ V2400W 24" widescreen 
KeyboardPowerCaseMouse
Random Logitech OCZ GameXStream 700 Watt Antec P182 Logitech G700 
Mouse Pad
Razer Destructor 
  hide details  
Reply
post #4 of 16
I don't have any experience with the Z-5500's, but if you have your original invoice/receipt, Logitech warranty is amazing and will probably replace the entire system no question's asked, and pay for return shipping if they even ask for it.

Hope someone can chime in and give you advice that may let you avoid doing that though, but if that is indeed the case, it's a rather painless process as long as you have the invoice.
post #5 of 16
Quote:
Originally Posted by Log1x;15182099 
I don't have any experience with the Z-5500's, but if you have your original invoice/receipt, Logitech warranty is amazing and will probably replace the entire system no question's asked, and pay for return shipping if they even ask for it.

Hope someone can chime in and give you advice that may let you avoid doing that though, but if that is indeed the case, it's a rather painless process as long as you have the invoice.

+1 on logitechs customer service. I had a mouse die and emailed them, told them it was like 2 years our of warranty, the only response I got back was an RMA number and an address to ship it to band.gif
Hobbes
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4790K GA-Z97X-SOC Gigabyte GTX 1080 Gaming Samsung MV-3V4G3D/US 16GB 
Hard DriveCoolingOSKeyboard
Samsung 850 EVO 250GB EK Predator 240mm Windows 7 x64 Das Keyboard 4 Professional CherryMX Blue 
PowerCaseMouseAudio
Seasonic X750 Gold Corsair Carbide Air 540 Logitech G900 Schiit Bifrost Uber W/ USB Gen 2 DAC 
AudioAudioAudioAudio
Schiit Asgard 2 Headphone Amp Audioengine N22 Speaker Amp AudioQuest Nighthawk Audioengine P4 Monitors. 
  hide details  
Reply
Hobbes
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4790K GA-Z97X-SOC Gigabyte GTX 1080 Gaming Samsung MV-3V4G3D/US 16GB 
Hard DriveCoolingOSKeyboard
Samsung 850 EVO 250GB EK Predator 240mm Windows 7 x64 Das Keyboard 4 Professional CherryMX Blue 
PowerCaseMouseAudio
Seasonic X750 Gold Corsair Carbide Air 540 Logitech G900 Schiit Bifrost Uber W/ USB Gen 2 DAC 
AudioAudioAudioAudio
Schiit Asgard 2 Headphone Amp Audioengine N22 Speaker Amp AudioQuest Nighthawk Audioengine P4 Monitors. 
  hide details  
Reply
post #6 of 16
Thread Starter 
i got the logitech speaker set from a 3rd party so no receipt etc...had the system for 3 years now...
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
post #7 of 16
Thread Starter 
there is red ring around the control pod power button...speakers still work but no more boomy bass
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
post #8 of 16
Have you checked your software? Did you accidentally turn the subwoofer off or down in whatever software you are using? Did you slide the EQ bands on the left side all the way down?
ZulliRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel C2D E6600 B2 EVGA 680i A1 Evga 8800GT OCZ 4GB DDR2 800 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 600 GB NEC DVD-RW Windows 7 Pro 64-bit BenQ V2400W 24" widescreen 
KeyboardPowerCaseMouse
Random Logitech OCZ GameXStream 700 Watt Antec P182 Logitech G700 
Mouse Pad
Razer Destructor 
  hide details  
Reply
ZulliRig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel C2D E6600 B2 EVGA 680i A1 Evga 8800GT OCZ 4GB DDR2 800 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 600 GB NEC DVD-RW Windows 7 Pro 64-bit BenQ V2400W 24" widescreen 
KeyboardPowerCaseMouse
Random Logitech OCZ GameXStream 700 Watt Antec P182 Logitech G700 
Mouse Pad
Razer Destructor 
  hide details  
Reply
post #9 of 16
Thread Starter 
Quote:
Originally Posted by Zulli85;15182413 
Have you checked your software? Did you accidentally turn the subwoofer off or down in whatever software you are using? Did you slide the EQ bands on the left side all the way down?

subwoofer is turned to the max and still no bass. tested this on all the different audio settings like stereo, stereo x2, prologic music, prologic movie etc.

i think its a blown sub.
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
M4800
(5 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-4800MQ Nvidia K2100M  2x4gb DDR3 1600mhz 128 GB SSD 
OS
Windows 7 64bit 
  hide details  
Reply
post #10 of 16
Quote:
Originally Posted by SpykeZ;15182189 
+1 on logitechs customer service. I had a mouse die and emailed them, told them it was like 2 years our of warranty, the only response I got back was an RMA number and an address to ship it to band.gif

-_____________-

I couldn't get Logitech to ship me a replacement receiver for my dead mouse for an entire year until it ran out of warranty and then they told me since it was out of warranty they couldn't help me.

Good cases, bad cases with every company.

\\Edit: Funny thing, Logitech is actually hovering at 1.25 out of 10 stars on reseller ratings for poor customer service. I've never seen such a bad rating -___-
Edited by astrallite - 10/5/11 at 2:10pm
DOS Gaming Beast
(13 items)
 
  
CPUGraphicsRAMHard Drive
Intel 3770k @ 4.3GHz GTX Titan @ 1136MHz 16GB DDR3 1600 CAS 8 OCZ Vertex EX 
OSMonitorPowerCase
Windows 7 Ultimate 32" 32LG70 IPS 120Hz LCD TV Corsair 1000W Coolermaster Cosmos 1000S 
  hide details  
Reply
DOS Gaming Beast
(13 items)
 
  
CPUGraphicsRAMHard Drive
Intel 3770k @ 4.3GHz GTX Titan @ 1136MHz 16GB DDR3 1600 CAS 8 OCZ Vertex EX 
OSMonitorPowerCase
Windows 7 Ultimate 32" 32LG70 IPS 120Hz LCD TV Corsair 1000W Coolermaster Cosmos 1000S 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Logitech Z-5500 Subwoofer is not working correctly...