post #1 of 1
Thread Starter 
Hi guys, I am a newbie here and I would like to possible confirm if my mobo is DOA. This is my second build ever and so I wanted to seek knowledgeable insight.

My build is as follows:
Gigabyte A75M-UD2H
AMD A8-3850
Corsair Builders Series CX 430 watt psu
G.Skill Ripjaws Series 8GB(2x4) 1600
NZXT Source 210 Elite

When I plug everything in (ATX12V included) the cpu and system fan begin spinning, usually for about 2 seconds, and then stopping. The front power LED on my case lights up and then turns off the same time the fans stop spinning.

At first I thought it was my psu, but after testing it in another machine, I found it to be working perfectly. Also, I thought the psu didn't have enough power, so I plugged in a 500 watt psu, which gives the same result. I did a bit of review reading and found that this build should be able to boot with a 380 watt psu, so I doubt that is the problem.

I've tried using different combinations of RAM modules in different slots, all of which had the same outcome.

I've removed the battery from the board to reset the CMOS, but that hasn't had any affect.

Two things to note:
I had a Cooler Master Hyper 212+ as the initial cooler, but I took it out because I thought that the big fan might draw more power and switched to the stock fan/heatsink.
Strangely, when I switched to the 500w psu it initially didn't boot. I then removed the hard drive and tried powering up again. Strangely enough, it booted and displayed something along the lines of "IDE MODE. Switching to ...." I'm not entirely sure what it said because this only happened twice.

From what I've been reading on the internet, it seems my mobo is DOA, but I would like other opinions. Oh, and while I was assembling, I'm not entirely sure if I was careful about discharging static from my hands. I was wearing latex gloves when handling the mobo most of the time. (Mobos aren't that sensitive to static, right?)

Also, when I was mounting the cooler, I did a pretty crappy job of applying thermal paste, so excess oozed out of the sides. I tried cleaning it up with Isopropyl Alcohol and coffee filters. Maybe the alcohol seeped in some where that damaged the processor? Could that have been an affecting factor?

Anyways, sorry for the long and convoluted post. Any advice on what I should do next?

Thanks