Overclock.net › Forums › Components › Mice › Logitech Setpoint 6.3 not detecting my G700.... My god SetPoint blows....
New Posts  All Forums:Forum Nav:

Logitech Setpoint 6.3 not detecting my G700.... My god SetPoint blows....

post #1 of 8
Thread Starter 
I just got a G700 to replace my old Razer mouse, and thinking that the drivers would be better or as good as the Razer mouse, I am uberuberuber diasappointed.

Plugged G700 in, downloaded 64bit manual installer, got everything down. But when I ran the Connect Utility included with the package, it would not detect the mouse. So, I installed the separate connection software which detects everything just fine. So I launched Setpoint 6.3, and it just KEPT on showing "Setpoint did not detect any supported devices." I ran the program in admin mode, plugged the mouse in different USB ports, rebooted the PC numerous times, disabled my previous mouse, uninstalled the previous mouse drivers, and it will just not detect my G700, redownloaded the Setpoint 5 times and now this mouse is just driving me insane. Been at this for 2 hours.... Someone please help.......................

Why does Logitech has such stupidly designed drivers where gaming mouse and regular mouse and keyboards make use of different driver sets and you need to install both? They should take a book from Razer (out of the box, software and macros done, in the game in 15 minutes)\

EDIT: The mouse works fine, able to switch DPIs (not sure what settings as I cannot open Setpoint :/), able to switch profiles, and the laser detects well. So I am 98% sure it isnt a hardware problem. The wireless dongle detects the mouse, the mouse charges, etc.
Edited by sloppyjoe123 - 10/5/11 at 8:15am
    
CPUMotherboardGraphicsRAM
i5 6500 @ stock MSI H110i Pro AC Asus GTX 1070 Gaming Strix OC 16Gb DDR4 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
1Tb Hitachi 5400RPM 2.5" HDD Intel 540s 240Gb SSD Noctua L9i Windows 10 Home Premium 
MonitorKeyboardPowerCase
PX2370 Filco Ninja Brown Switches Silverstone 500W SFX-L Gold Silverstone RVZ02 (Non-Windowed) 
MouseAudio
Razer DeathAdder Chroma Bose Companion II 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 6500 @ stock MSI H110i Pro AC Asus GTX 1070 Gaming Strix OC 16Gb DDR4 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
1Tb Hitachi 5400RPM 2.5" HDD Intel 540s 240Gb SSD Noctua L9i Windows 10 Home Premium 
MonitorKeyboardPowerCase
PX2370 Filco Ninja Brown Switches Silverstone 500W SFX-L Gold Silverstone RVZ02 (Non-Windowed) 
MouseAudio
Razer DeathAdder Chroma Bose Companion II 
  hide details  
Reply
post #2 of 8
You may want to start trying older Setpoint drivers.

I've had to do that in the past.
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
FX6300 Black M5A99X EVO R2.0 Nvidia GTS450 Team Vulcan PC3 12800 
Hard DriveOptical DriveCoolingOS
Samsung 840 PRO Asus DRW-1608P (x2) Custom Water Cooling Win7 (Ult), Win 8.1 & Win Server 2012 R2 
MonitorKeyboardPowerCase
2 X Samsung 915N Ducky Shine III, Blue Cherry/Blue LEDs PCP&C 1kw Lian Li PC-71 (W/Window) 
MouseAudio
Logiteck G400s none 
  hide details  
Reply
My System
(15 items)
 
  
CPUMotherboardGraphicsRAM
FX6300 Black M5A99X EVO R2.0 Nvidia GTS450 Team Vulcan PC3 12800 
Hard DriveOptical DriveCoolingOS
Samsung 840 PRO Asus DRW-1608P (x2) Custom Water Cooling Win7 (Ult), Win 8.1 & Win Server 2012 R2 
MonitorKeyboardPowerCase
2 X Samsung 915N Ducky Shine III, Blue Cherry/Blue LEDs PCP&C 1kw Lian Li PC-71 (W/Window) 
MouseAudio
Logiteck G400s none 
  hide details  
Reply
post #3 of 8
Word of advice, make sure to remove any trace of your Razer drivers. I forgot to do a complete uninstall before I got my M705, and I had major issues with SetPoint as well. Uninstall SetPoint and your Razer driver suite, then reinstall the SetPoint software you got with your mouse, then install the latest SetPoint (6.3) which you can get from the Logitech site. That should sort you out.
post #4 of 8
Setpoint is terrible. I dont use it for this and several other reasons.
It gets in the way of some of my bindings in certain games and is finicky as bawls.
Micro Mule
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 6700k MSI Z170I Gaming Pro AC Gigabyte GTX 1070 G1 Gaming 16GB GSkill Ripjaws V DDR4 3200 
Hard DriveCoolingMonitorPower
250GB Crucial MX200, 960GB Adata , 1TB WD Black Noctua NH-L12 LG 27UD68 4k Seasonic M12II 620W 
CaseMouseAudio
Corsair Obsidian 250D Logitech Performance Mouse MX Topping TP-30 Mk2, 2x Polk M10, Sony MDR-7506 
  hide details  
Reply
Micro Mule
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 6700k MSI Z170I Gaming Pro AC Gigabyte GTX 1070 G1 Gaming 16GB GSkill Ripjaws V DDR4 3200 
Hard DriveCoolingMonitorPower
250GB Crucial MX200, 960GB Adata , 1TB WD Black Noctua NH-L12 LG 27UD68 4k Seasonic M12II 620W 
CaseMouseAudio
Corsair Obsidian 250D Logitech Performance Mouse MX Topping TP-30 Mk2, 2x Polk M10, Sony MDR-7506 
  hide details  
Reply
post #5 of 8
Quote:
Originally Posted by sloppyjoe123;15187746 
I just got a G700 to replace my old Razer mouse, and thinking that the drivers would be better or as good as the Razer mouse, I am uberuberuber diasappointed.

Plugged G700 in, downloaded 64bit manual installer, got everything down. But when I ran the Connect Utility included with the package, it would not detect the mouse. So, I installed the separate connection software which detects everything just fine. So I launched Setpoint 6.3, and it just KEPT on showing "Setpoint did not detect any supported devices." I ran the program in admin mode, plugged the mouse in different USB ports, rebooted the PC numerous times, disabled my previous mouse, uninstalled the previous mouse drivers, and it will just not detect my G700, redownloaded the Setpoint 5 times and now this mouse is just driving me insane. Been at this for 2 hours.... Someone please help.......................

Why does Logitech has such stupidly designed drivers where gaming mouse and regular mouse and keyboards make use of different driver sets and you need to install both? They should take a book from Razer (out of the box, software and macros done, in the game in 15 minutes)\

EDIT: The mouse works fine, able to switch DPIs (not sure what settings as I cannot open Setpoint :/), able to switch profiles, and the laser detects well. So I am 98% sure it isnt a hardware problem. The wireless dongle detects the mouse, the mouse charges, etc.

Sir, you need to start reading what you are downloading. The answer to your question is found right where you downloaded the driver. You downloaded the smart driver, right next to it logitech explains that if you have probs installing it then try the 32/64 bit installer.
post #6 of 8
Thread Starter 
@pcfreak, I didnt even bother with the Smart installer. Went straight to the full 64bit installer.

Hi guys, thank you for helping, I did uninstall the Razer drivers and utility and installed the SP.

Btw, SP works on my laptop perfectly. Thank god, for onboard memory, I set the mouse up and use it on my desktop. :/ Seems like I have to live with this for now. Been trying to look for older SP drivers. didnt have much luck looking for the 64bit versions.
    
CPUMotherboardGraphicsRAM
i5 6500 @ stock MSI H110i Pro AC Asus GTX 1070 Gaming Strix OC 16Gb DDR4 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
1Tb Hitachi 5400RPM 2.5" HDD Intel 540s 240Gb SSD Noctua L9i Windows 10 Home Premium 
MonitorKeyboardPowerCase
PX2370 Filco Ninja Brown Switches Silverstone 500W SFX-L Gold Silverstone RVZ02 (Non-Windowed) 
MouseAudio
Razer DeathAdder Chroma Bose Companion II 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 6500 @ stock MSI H110i Pro AC Asus GTX 1070 Gaming Strix OC 16Gb DDR4 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
1Tb Hitachi 5400RPM 2.5" HDD Intel 540s 240Gb SSD Noctua L9i Windows 10 Home Premium 
MonitorKeyboardPowerCase
PX2370 Filco Ninja Brown Switches Silverstone 500W SFX-L Gold Silverstone RVZ02 (Non-Windowed) 
MouseAudio
Razer DeathAdder Chroma Bose Companion II 
  hide details  
Reply
post #7 of 8
You need to use Logitech Gaming Software, not Setpoint. -_- The program causes jitter with my g400, so I'd test it first.
Custom Build
(15 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 955 x4 Gigabyte 880GM-D2H MSI 5770  Corsair 
Hard DriveCoolingOSMonitor
Seagate Barracuda 7200RPM Cooler Master Hyper 212+ Windows 7 Ultimate 64 Bit Samsung Syncmaster 753DF 
KeyboardPowerCaseMouse
I-Rocks KR-6290 Coolmax 600W Coolermaster Elite 430 Black Logitech G400 
Mouse PadAudio
PureTrak Talent Realtek Onboard 
  hide details  
Reply
Custom Build
(15 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 955 x4 Gigabyte 880GM-D2H MSI 5770  Corsair 
Hard DriveCoolingOSMonitor
Seagate Barracuda 7200RPM Cooler Master Hyper 212+ Windows 7 Ultimate 64 Bit Samsung Syncmaster 753DF 
KeyboardPowerCaseMouse
I-Rocks KR-6290 Coolmax 600W Coolermaster Elite 430 Black Logitech G400 
Mouse PadAudio
PureTrak Talent Realtek Onboard 
  hide details  
Reply
post #8 of 8
Make sure you do not have other mouse controlling software installed.
Do you see the G700 here:
Launch SetPoint (Start > Programs > Logitech > G9x, G500, and G700 Gaming Mice > Device Settings).
If not please do the following:
You must be logged on as an administrator to perform these steps.
1.Open Device Manager by clicking the Start button , clicking Control Panel, clicking System and Maintenance, and then clicking Device Manager.* If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
2.In Device Manager, locate the device you want to update, and then double-click the device name.
3.Click the Driver tab.(Driver Provider should show Logitech)
4.Click update driver
5.Choose Browse my computer
6.Choose let me pick from list
7.Choose the Logitech driver

Reboot

That's the method I used on my roommates G700 and worked without a hitch.
Quote:
Originally Posted by baws;15195167 
You need to use Logitech Gaming Software, not Setpoint. -_- The program causes jitter with my g400, so I'd test it first.

No. You use Setpoint for the G700, not the Logitech Gaming Software.
Edited by dmasteR - 10/5/11 at 10:05pm
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Logitech Setpoint 6.3 not detecting my G700.... My god SetPoint blows....