Overclock.net › Forums › Video Games › PC Gaming › Mirror's Edge not running after "Preparing to Launch" window
New Posts  All Forums:Forum Nav:

Mirror's Edge not running after "Preparing to Launch" window

post #1 of 3
Thread Starter 
I bought Mirror's Edge when it was on sale and I finally got around to downloading it on steam I run it and I get the "Preparing to Launch" window, and the Mirror's Edge shows up in task manager for a few seconds though nothing happens on my screen. Any thought on how to fix this?

What I've tried:
-Re downloaded and verified game cache.
-Update Windows fully.
-Tried to update GPU drivers, somehow 11.9 drivers don;t actually install so I'm sitting at 11.5 (but that's a separate problem).
-Disabled both my antivirus programs.

Other than what is on that list any ideas as to what I can do?

Argosy
t7 v2
(14 items)
 
t7 v1
(13 items)
 
t7 v3
(15 items)
 
CPUMotherboardGraphicsRAM
1055T |3.96 GHz| MSI 790FX QuadroFX 540 8GB Gskill Sniper |1600 MHz| 
Hard DriveCoolingOSPower
Seagate Barracuda 250GB Xigmatek Thor's Hammer Ubuntu 11.10 Antec HGC 400W 
Case
Antec 100 
CPUMotherboardGraphicsRAM
i7 920 D0 |3.8 GHz| Foxconn BloodRage EVGA 9600GT 6 GB Corsair DDR3 |1604MHz| 
Hard DriveOptical DriveOSMonitor
1TB Caviar Black 24X Sony Optaric Windows 7 64 bit Acer LED 23" |1920x1080| 
KeyboardPowerCaseMouse
Razer Lycosa Antec HCG 400 Xigmatek Asgard Logitech G500 
Mouse Pad
SteelSeries 5L 
CPUGraphicsRAMHard Drive
Pentium 4 Dual Core 2.8 GHz GTX 480 3GB DDR2 533 2x 80 GB WD 
CoolingCoolingOSPower
Cooler Master Hyper 212+ Cooler Master Hyper 212+ Windows BVista 64-bit Corsair HX 850 
Case
Antec 1200 
  hide details  
Reply
t7 v2
(14 items)
 
t7 v1
(13 items)
 
t7 v3
(15 items)
 
CPUMotherboardGraphicsRAM
1055T |3.96 GHz| MSI 790FX QuadroFX 540 8GB Gskill Sniper |1600 MHz| 
Hard DriveCoolingOSPower
Seagate Barracuda 250GB Xigmatek Thor's Hammer Ubuntu 11.10 Antec HGC 400W 
Case
Antec 100 
CPUMotherboardGraphicsRAM
i7 920 D0 |3.8 GHz| Foxconn BloodRage EVGA 9600GT 6 GB Corsair DDR3 |1604MHz| 
Hard DriveOptical DriveOSMonitor
1TB Caviar Black 24X Sony Optaric Windows 7 64 bit Acer LED 23" |1920x1080| 
KeyboardPowerCaseMouse
Razer Lycosa Antec HCG 400 Xigmatek Asgard Logitech G500 
Mouse Pad
SteelSeries 5L 
CPUGraphicsRAMHard Drive
Pentium 4 Dual Core 2.8 GHz GTX 480 3GB DDR2 533 2x 80 GB WD 
CoolingCoolingOSPower
Cooler Master Hyper 212+ Cooler Master Hyper 212+ Windows BVista 64-bit Corsair HX 850 
Case
Antec 1200 
  hide details  
Reply
post #2 of 3
Does you AV have a firewall system?

if So add the game's executable to its exceptions and allow any parent to it too.I had A similar experience with battlefield.
Dorianime
(15 items)
 
School Rig
(5 items)
 
 
MotherboardGraphicsRAMHard Drive
Clevo W120HNM/w170HN GT540M Samsung Seagate Momentus 
OS
Windows 7 ultimate 
  hide details  
Reply
Dorianime
(15 items)
 
School Rig
(5 items)
 
 
MotherboardGraphicsRAMHard Drive
Clevo W120HNM/w170HN GT540M Samsung Seagate Momentus 
OS
Windows 7 ultimate 
  hide details  
Reply
post #3 of 3
Run the games executable directly from the place that it has been installed.

An error should pop up if nothing else.
BlueRaven
(13 items)
 
Dead BIOS
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 G74Sx NVIDIA GeForce GTX 560M  Samsung  
RAMRAMHard DriveHard Drive
Samsung  Samsung  Momentus 7200.4 Scorpio Blue 
Mouse
Logitech G700 
  hide details  
Reply
BlueRaven
(13 items)
 
Dead BIOS
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 G74Sx NVIDIA GeForce GTX 560M  Samsung  
RAMRAMHard DriveHard Drive
Samsung  Samsung  Momentus 7200.4 Scorpio Blue 
Mouse
Logitech G700 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Mirror's Edge not running after "Preparing to Launch" window