Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5670 Not performing well enough
New Posts  All Forums:Forum Nav:

HD5670 Not performing well enough - Page 4

post #31 of 34
A dual core at 3.2GHz won't run BC2 very well at all. That's part of your problem honestly. The same chip as a quad core would have no issues at all with BC2.

But that's just one game.
Junkyard
(18 items)
 
NAStradamous
(12 items)
 
HTPC01
(16 items)
 
CPUMotherboardGraphicsRAM
Intel i5 2320 @ 3.1GHz MSI B75MA-E33 HIS HD7970 3GB @ 1050 / 1700, 1.17v Patriot 2x4GB DDR3-1066 
Hard DriveHard DriveOptical DriveCooling
Crucial MX100 256GB WD Green 2TB DVDRW Corsair H50 Push / Pull 
CoolingOSMonitorMonitor
NZXT 120mm fans strapped to stock 7970 cooler Windows 10 Pro Dell 3007WFP Dell 2007FP 
MonitorKeyboardPowerCase
Dell 2007FP Cheap Toshiba (R.I.P. Ducky) PC Power & Cooling Silencer MKIII 950w Cheap Garbage (free) 
MouseAudio
Logitech G602 Yardsale Special 
CPUMotherboardGraphicsRAM
Intel Core i5 3330 Asus H61 MSI GTX 750Ti Low Profile 2x4GB Hynix DDR3-1333 
Hard DriveHard DriveOptical DriveCooling
60GB Kingston SSD 1TB Seagate Samsung DVDRW CoolerMaster Gemin II 
OSMonitorKeyboardPower
Windows 8.1 + Steam Big Picture / Plex HT 50" Insignia LED 1080p Logitech Rosewill Green 530w 
CaseMouseAudioOther
Silverstone HTPC Logitech Pioneer 2.0 tower speakers + 135w RMS Rosewill MCE Remote 
  hide details  
Reply
Junkyard
(18 items)
 
NAStradamous
(12 items)
 
HTPC01
(16 items)
 
CPUMotherboardGraphicsRAM
Intel i5 2320 @ 3.1GHz MSI B75MA-E33 HIS HD7970 3GB @ 1050 / 1700, 1.17v Patriot 2x4GB DDR3-1066 
Hard DriveHard DriveOptical DriveCooling
Crucial MX100 256GB WD Green 2TB DVDRW Corsair H50 Push / Pull 
CoolingOSMonitorMonitor
NZXT 120mm fans strapped to stock 7970 cooler Windows 10 Pro Dell 3007WFP Dell 2007FP 
MonitorKeyboardPowerCase
Dell 2007FP Cheap Toshiba (R.I.P. Ducky) PC Power & Cooling Silencer MKIII 950w Cheap Garbage (free) 
MouseAudio
Logitech G602 Yardsale Special 
CPUMotherboardGraphicsRAM
Intel Core i5 3330 Asus H61 MSI GTX 750Ti Low Profile 2x4GB Hynix DDR3-1333 
Hard DriveHard DriveOptical DriveCooling
60GB Kingston SSD 1TB Seagate Samsung DVDRW CoolerMaster Gemin II 
OSMonitorKeyboardPower
Windows 8.1 + Steam Big Picture / Plex HT 50" Insignia LED 1080p Logitech Rosewill Green 530w 
CaseMouseAudioOther
Silverstone HTPC Logitech Pioneer 2.0 tower speakers + 135w RMS Rosewill MCE Remote 
  hide details  
Reply
post #32 of 34
Quote:
Originally Posted by cel13 View Post
Yes, GPU drivers and BIOS are both up to date.

sLowEnd, Yes, it runs best on quads. But shouldn't it be running fine on dual cores, with low settings ? Because mine is on low and sometimes it's almost unplayable.

I'm just wondering if my CPU is performing as it should, or am I losing something.
Minimum system requirements are just that.
If you are playing in maps with a lot of people, or big maps, then that may explain your low frame rates.
GE60
(13 items)
 
  
CPUGraphicsHard DriveOS
Intel Core i5 4200M Geforce GTX760M 750GB WD Scorpio Black Windows 7 Home Premium 
MonitorKeyboardMouseMouse Pad
15.6" CM Quickfire Rapid CM Xornet Steelseries QcK+ 
  hide details  
Reply
GE60
(13 items)
 
  
CPUGraphicsHard DriveOS
Intel Core i5 4200M Geforce GTX760M 750GB WD Scorpio Black Windows 7 Home Premium 
MonitorKeyboardMouseMouse Pad
15.6" CM Quickfire Rapid CM Xornet Steelseries QcK+ 
  hide details  
Reply
post #33 of 34
Thread Starter 
Well, all I played was single player, just a couple of missions. No epic battles there, so I don't know.

Also, yesterday I tried Crysis. I thought at least that game would run on high settings. But nope, even with high/medium settings, pretty huge lag.

Edit: also lags on all medium settings :/
Edited by cel13 - 10/15/11 at 3:32am
Older Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Pentium Dual Core E6700 3,2 GHz 2MB ASRock G31M-S R2.0 Sapphire Radeon HD5670 3GB DDR2 
OSPower
Windows 7 Ultimate x64 Codegen 400W 
  hide details  
Reply
Older Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Pentium Dual Core E6700 3,2 GHz 2MB ASRock G31M-S R2.0 Sapphire Radeon HD5670 3GB DDR2 
OSPower
Windows 7 Ultimate x64 Codegen 400W 
  hide details  
Reply
post #34 of 34
Thread Starter 
Sorry for doubleposting, but I didn't want to start a new thread just because of this.

When I run CPU-Z, it only shows core speed as ~1595 MHz. So I thought maybe Intel Speedstep is limiting it, but I couldn't find it. I did find C1E, and disabled it.

The value didn't change, and what seems even stranger is that this value hardly changes even under full load using ORTHOS.

Multiplier is x 6.0

That isn't normal, or is it ?

EDIT: So I got a new motherboard, and now the CPU is working fine. The games run well now as well. Thanks for your time
Edited by cel13 - 10/22/11 at 6:13am
Older Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Pentium Dual Core E6700 3,2 GHz 2MB ASRock G31M-S R2.0 Sapphire Radeon HD5670 3GB DDR2 
OSPower
Windows 7 Ultimate x64 Codegen 400W 
  hide details  
Reply
Older Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Pentium Dual Core E6700 3,2 GHz 2MB ASRock G31M-S R2.0 Sapphire Radeon HD5670 3GB DDR2 
OSPower
Windows 7 Ultimate x64 Codegen 400W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5670 Not performing well enough