Overclock.net › Forums › Specialty Builds › HTPC › optical/hdmi DTS aduio problems
New Posts  All Forums:Forum Nav:

optical/hdmi DTS aduio problems

post #1 of 7
Thread Starter 
OK, I have a GIGABYTE GA-P35C-DS3R mobo, Q6600, 4gb of ram, and an ATI Radeon HD5750 in my setup. I have 2 problems:

First, I cant get this setup to play 1080p MKV's smoothly. It will play fine for a bit and then the video will ****ter and become pixalated, then it corrects itself and plays fine. I am using VLC to play the files.

Secondly, I cant get it to recognize DTS sound. I have tried hooking it up to the optical port on the mobo, and just using the HDMI output from the card. No luck so far. The optical port wont give me an option to select the DTS sound, and the video card will play the files but no option for 5.1 or dts, only 2.0.

I have all of this running thru mu Onkyo reciever. Whats funny is that I have a simular setup but with a ASUS mobo and everything plays fine with sound.
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
post #2 of 7
One dump vlc for now, Two get the full klite codec pack. Install with default settings. And every thing should work fine. Also make sure you have the latest driver for ATI/AMD catalyst drivers. I know this because I have been through what you are going through and this is the most simplest thing to get everything working okay.

Don't worry about DTS until you can verify that sound is just being outputted across hdmi. Then you edit the settings to passthru dts to your receiver. I have a onkyo receiver (search google for onkyo ghettosupersta forum repair)
Edited by ghettosuperstar - 10/9/11 at 2:31pm
Darkness
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 965 ASUS M4A89GTD PRO/USB3 6950 Corsair 4gb 1600 
Hard DriveOSMonitorPower
12TB plus 64gb Adata(Microcenter) Windows 7 Ultimate x64 3 24" Displays (Eyefinity) CM 1000W 
Case
HAF 932 
  hide details  
Reply
Darkness
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 965 ASUS M4A89GTD PRO/USB3 6950 Corsair 4gb 1600 
Hard DriveOSMonitorPower
12TB plus 64gb Adata(Microcenter) Windows 7 Ultimate x64 3 24" Displays (Eyefinity) CM 1000W 
Case
HAF 932 
  hide details  
Reply
post #3 of 7
Thread Starter 
ok, I have already uninstalled all of the drivers & software and reistalled everything again. I can get sound from both of them. On the hdmi port, i cant set up realtek audio to anything other than 2.0. And on the optical, it can only see 2 channel audio as well. Im not even given an option to select 5.1 or 7.1 audio.

Does this board have the Dolby Digital Live option availible? I know my ASUS board does.
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
post #4 of 7
yes if you don't see those options, you definitely have to install the drivers from asus website. I know, I have two asus motherboards.

Note:fill out the system in your profile so i can see what you have.
Edited by ghettosuperstar - 10/9/11 at 5:23pm
Darkness
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 965 ASUS M4A89GTD PRO/USB3 6950 Corsair 4gb 1600 
Hard DriveOSMonitorPower
12TB plus 64gb Adata(Microcenter) Windows 7 Ultimate x64 3 24" Displays (Eyefinity) CM 1000W 
Case
HAF 932 
  hide details  
Reply
Darkness
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II 965 ASUS M4A89GTD PRO/USB3 6950 Corsair 4gb 1600 
Hard DriveOSMonitorPower
12TB plus 64gb Adata(Microcenter) Windows 7 Ultimate x64 3 24" Displays (Eyefinity) CM 1000W 
Case
HAF 932 
  hide details  
Reply
post #5 of 7
Thread Starter 
Quote:
Originally Posted by ghettosuperstar View Post
yes if you don't see those options, you definitely have to install the drivers from asus website. I know, I have two asus motherboards.
lol...no its the gigabyte board that is giving me problems. I wonder if I do a fresh install of win7 would it correct the problems. Or should I just look for a good sound card.
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
post #6 of 7
Thread Starter 
Ok, i did a fresh install of the drivers but I still cant it to recognize AC3/dolby digital files. It can read DTS fine. I however found a guy on craigslist that has one of these for $15 http://www.newegg.com/Product/Produc...82E16829102017

hopefully it will solve my problems
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
post #7 of 7
Thread Starter 
Well I just installed Zoom Player and it plays smooth like butter. I think its the codecs that it uses especially the haail media splitter. I just checked my "Saving Private Ryan" 20gig 1080p file and it played smooth where I noticed the stuttering
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
Daveo Schmavo
(5 items)
 
  
CPUMotherboardGraphicsOS
i7 3770k Asrock Z77 Extreme4 Galaxy GTX 670 Windows 7 x64 
Monitor
W2753VC 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC
Overclock.net › Forums › Specialty Builds › HTPC › optical/hdmi DTS aduio problems