Overclock.net › Forums › Mobile Computing Forum › Phones › iPod Video died after messing with internals :(
New Posts  All Forums:Forum Nav:

iPod Video died after messing with internals :(

post #1 of 5
Thread Starter 
I bought a OEM click wheel from eBay to use in my iPod Video (which is like 6 years old, just recently found it) and I installed it and everything, but now my iPod will not start up. I also tried the old one again, and it refuses to work. I watched a guide on how to dismantle it, and I removed all the cables carefully, but for some reason the iPod refuses to start up .

Any ideas?
post #2 of 5
make sure all the connectors are fully seated, make sure nothing is shorting out on the casing

Also make sure the external hold switch is properly seated on the internal pcb mounted switch
post #3 of 5
Thread Starter 
Quote:
Originally Posted by The_ocho View Post
make sure all the connectors are fully seated, make sure nothing is shorting out on the casing

Also make sure the external hold switch is properly seated on the internal pcb mounted switch
Already checked. I am currently in the process of completely dismantling and reassembling.
post #4 of 5
and try plugging charger in too
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9650 Asus P5E Sapphire 4850 2GB And 4870 1GB SilentEfficiency CF 8GB Kingston 1066Mhz 
Hard DriveOptical DriveOSPower
Western Digital 1TB 2x Liteon DVD-RW Windows 7 Ultimate 64bit OCZ Z Series 1000W 
Case
Antec 1200 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9650 Asus P5E Sapphire 4850 2GB And 4870 1GB SilentEfficiency CF 8GB Kingston 1066Mhz 
Hard DriveOptical DriveOSPower
Western Digital 1TB 2x Liteon DVD-RW Windows 7 Ultimate 64bit OCZ Z Series 1000W 
Case
Antec 1200 
  hide details  
Reply
post #5 of 5
Thread Starter 
Got it working last night. Complete reassemble seemed to fix it.

Sent from my GT-I9100
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Phones
Overclock.net › Forums › Mobile Computing Forum › Phones › iPod Video died after messing with internals :(