Overclock.net › Forums › Intel › Intel Motherboards › ASRock Z68 Discussion/Owners Club
New Posts  All Forums:Forum Nav:

ASRock Z68 Discussion/Owners Club - Page 195

post #1941 of 2941
frown.gif mine seems to be posting about 30 seconds slower than before but then again I probably missed even more settings. has anyone been able to get higher overclocks on the bios than they could before? Intel smart connect turns on your computer intermittently while sleeping to gather data for things like dropbox, email etc. and rapid start doesn't seem all that useful for desktops at the moment.
DeadHost
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500k 4.7 Ghz ASRock Z68 Extreme4 MSI GTX 670 PE 8 GB Crucial Ballistix 
Hard DriveHard DriveCoolingOS
1 TB WD Green Crucial M4 Antec Kuhler H20 620 Windows 7 Ultimate x86_64 SP1 
MonitorMonitorKeyboardPower
HPW23something Dell U2312HM CM Storm Quickfire Pro OCZ 600W 
CaseMouseMouse PadAudio
Fractal Design Define R4 Logitech G400 Steelseries Qck Pioneer VSX-821 
  hide details  
Reply
DeadHost
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500k 4.7 Ghz ASRock Z68 Extreme4 MSI GTX 670 PE 8 GB Crucial Ballistix 
Hard DriveHard DriveCoolingOS
1 TB WD Green Crucial M4 Antec Kuhler H20 620 Windows 7 Ultimate x86_64 SP1 
MonitorMonitorKeyboardPower
HPW23something Dell U2312HM CM Storm Quickfire Pro OCZ 600W 
CaseMouseMouse PadAudio
Fractal Design Define R4 Logitech G400 Steelseries Qck Pioneer VSX-821 
  hide details  
Reply
post #1942 of 2941
just wondering if anyone can help me choose a decent air cooler.

i have the Z68 Extreme4 (non Gen3) board and my case it a Raven RV03 which is optimized for air cooling. I have an Antec Kuhler 620 water cooler, which is quite noisy to my liking. the biggest restriction is my Corsair Vengeance RAM. I have 4 of them, so I need a cooler that
1) doesn't reach the RAM slots (because seems to be nothing that has enough clearance above the RAM)
2) doesn't obstruct my PCI-E X-FI titanium sound card installed in the top most PCI-E x1 slot
3) does fit inside a Raven RV03 (says max height is 163mm in the case's spec sheet.)

Since Kuhler 620 is quiet compared to other water coolers, and since I cannot tolerate even that, I guess water coolers are out of the question. H100 with custom fans would have been cool , but the case doesn't fit one normally and the way it has to be fixed would disrupt the airflow.)

Or and btw on the new bios. I got to play with it a bit. Got mine stable for 3.5hrs in Prime blend @ 4.5GHz. 4.6GHz at same Vcore gave stop 124 error. Now i am trying to drop the Vcore at 4.5GHz. currently +0.005 offset yielding 1.320V~1.336V at load. also playing with the power saving features.

One note on core level turbo boost overclocking. It doesn't work at all. It just stays fixed at 45. i tried 45,46,47,48 for different loads. no go. POST screen showed 25GHz or some weird CPU speed. (I wish!) didn't get to play with Smart Connect or Rapid Start yet. eventually i will. still trying to get the OC stable. only today i learned how to stop the idle BSOD 124 bug. doh.gif

Quote:
Originally Posted by thelamacmdr View Post

frown.gif mine seems to be posting about 30 seconds slower than before but then again I probably missed even more settings. has anyone been able to get higher overclocks on the bios than they could before? Intel smart connect turns on your computer intermittently while sleeping to gather data for things like dropbox, email etc. and rapid start doesn't seem all that useful for desktops at the moment.
i measured the POST. it's pretty much the same. about 1-2s between the two. Oh well...
Edited by Anusha - 4/19/12 at 7:39am
post #1943 of 2941
yeah maybe I'm just an unfortunate soul or I forgot something down the line but everyones experience tends to vary but so far I haven't seen any reasonable gains that warrant the new BIOS upgrade unlesss you were to upgrade to Ivy Bridge soon. Also I've been having an issue when trying to boot the computer will shutdown twice while trying to post and finally manage to on the 3rd try anyone else have this issue or is it just my motherboard that really really disagrees with this new bios?
DeadHost
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500k 4.7 Ghz ASRock Z68 Extreme4 MSI GTX 670 PE 8 GB Crucial Ballistix 
Hard DriveHard DriveCoolingOS
1 TB WD Green Crucial M4 Antec Kuhler H20 620 Windows 7 Ultimate x86_64 SP1 
MonitorMonitorKeyboardPower
HPW23something Dell U2312HM CM Storm Quickfire Pro OCZ 600W 
CaseMouseMouse PadAudio
Fractal Design Define R4 Logitech G400 Steelseries Qck Pioneer VSX-821 
  hide details  
Reply
DeadHost
(16 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500k 4.7 Ghz ASRock Z68 Extreme4 MSI GTX 670 PE 8 GB Crucial Ballistix 
Hard DriveHard DriveCoolingOS
1 TB WD Green Crucial M4 Antec Kuhler H20 620 Windows 7 Ultimate x86_64 SP1 
MonitorMonitorKeyboardPower
HPW23something Dell U2312HM CM Storm Quickfire Pro OCZ 600W 
CaseMouseMouse PadAudio
Fractal Design Define R4 Logitech G400 Steelseries Qck Pioneer VSX-821 
  hide details  
Reply
post #1944 of 2941
Quote:
Originally Posted by blaze0079 View Post

[URL=http://www.overclock.net/image/id/2199805/width/600/height/375i wasnt able to set my ram to run at 1n .

I am having a similar problem on my Z77/E6 bios, which I assume is very similar to the update bios for the Z68/E4/G3 ... Not only can I not set 1N (1T) But NONE of my ram timings/settings are changeable frown.gif ... anyone else having this problem???

I have the newer G.SKILL Ripjaws X 16GB (2 x 8GB)DDR3 1600 F3-1600C9D-16GXM, maybe it's because of the strain the single 8GB sticks put on the board ... I'll try a 2x4GB set later today? I WANT MY RAM SETTINGS BACK!
Quote:
Originally Posted by thelamacmdr View Post

But so far I haven't seen any reasonable gains that warrant the new BIOS upgrade unlesss you were to upgrade to Ivy Bridge soon.

I agree ... unless you want the Support for intel rapid start and Support for intel smart connect (presently I have no experience w/these) ... ONE thing some new to OC'ing may appreciate as ASRock seems to have backed off the higher voltage settings for the "Turbo" overclock pre-sets ... this is probably due to Z77 and IB lower voltage needed architecture? So if you have a Z68 and SB chip and DON'T manually set your OC's I'd stay away from the new IB bios; :O
Edited by TomcatV - 4/19/12 at 10:31am
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
post #1945 of 2941
The problem with setting t1 was i was expecting a drop down menu but all i had to do with type 1 in the command rate box.


Anyone who having a problem cold booting at 43-46 multiplier should give this new bios a try.
Edited by blaze0079 - 4/19/12 at 11:23am
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2700k Extreme4 gen3 Evga Gtx 780 SC 16GB DDR3 1866 
Hard DriveHard DriveOptical DriveCooling
samsung Samsung Spinpoint F3 SAMSUNG HD103UJ DVD-RAM GH22NS30 NH-D14 
OSMonitorKeyboardPower
Windows 8 Qnix qx 2700 CM Trigger SilverStone Strider Plus 850w 
CaseMouseAudio
Haf X SteelSeries Sensei Creative Sound Blaster Z 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2700k Extreme4 gen3 Evga Gtx 780 SC 16GB DDR3 1866 
Hard DriveHard DriveOptical DriveCooling
samsung Samsung Spinpoint F3 SAMSUNG HD103UJ DVD-RAM GH22NS30 NH-D14 
OSMonitorKeyboardPower
Windows 8 Qnix qx 2700 CM Trigger SilverStone Strider Plus 850w 
CaseMouseAudio
Haf X SteelSeries Sensei Creative Sound Blaster Z 
  hide details  
Reply
post #1946 of 2941
PCI-e #1 quit working on my ext4g3.

I began having boot issues where I stated it seemed like it would go through the boot sequence but the screen would read no input.

The other day it wouldn't boot at all & when it finaly did it was on for a matter of seconds & the tv started screatching. Remembering a post, I believe to have b een in this thread, about a similar occurrence. I then decided to swap the card, computer booted & I loaded the card drivers & it booting up. I had to uninstal the on-board gpu to get catalyst to show up.

Going to return this board in the very near future.
i7 HAF-922
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570 ASUS P8Z77-M PRO AMD Radeon Sapphire HD 6950 11188-05-50G Kingston KHX1600C9D3K2/8GX 
Hard DriveHard DriveOptical DriveOS
Western Digital WD1001faes Samsung 830 128Gb SSD Pioneer DVR-217 Windows 7 Ultimate 
MonitorPowerCaseMouse
32" LG LCD Antec HCG-900 Cooler Master HAF-922 GS500 I 
AudioOther
Pioneer Theater Component Corsair H100 
  hide details  
Reply
i7 HAF-922
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570 ASUS P8Z77-M PRO AMD Radeon Sapphire HD 6950 11188-05-50G Kingston KHX1600C9D3K2/8GX 
Hard DriveHard DriveOptical DriveOS
Western Digital WD1001faes Samsung 830 128Gb SSD Pioneer DVR-217 Windows 7 Ultimate 
MonitorPowerCaseMouse
32" LG LCD Antec HCG-900 Cooler Master HAF-922 GS500 I 
AudioOther
Pioneer Theater Component Corsair H100 
  hide details  
Reply
post #1947 of 2941
Quote:
Originally Posted by blaze0079 View Post

The problem with setting t1 was i was expecting a drop down menu but all i had to do with type 1 in the command rate box.
.

SAME HERE ... Man old habits Die Hard frown.gif ... never thought to type it in Duhh ... YOU MADE MY DAY ... Now I'm back to being very impressed with this (Z77) board, as for me, it is just as important how well a board overclocks RAM, not just the CPU ... Thanks Again Blaze!
Quote:
Originally Posted by ****xy View Post

PCI-e #1 quit working on my ext4g3.
Remembering a post, I believe to have b een in this thread, about a similar occurrence. I then decided to swap the card, computer booted & I loaded the card drivers & it booting up. I had to uninstal the on-board gpu to get catalyst to show up.
Going to return this board in the very near future.

That's 2 now, earlier I believe "Wickedout" had the same problem ... wonder when mine is going to go bad? More important I'm not clear if you got PCI-Ex16#1 working again? ... or are you now using #2 slot? Well if you have to RMA, it seems to be a 100% positive experience around here! Except were still waiting for "Wicked" to tell us how his RMA'd Z68/E4/G3 performed once he got it back :O
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
post #1948 of 2941
Besides keying in a number, I believe you can also use the + and - keys to change the value.

This was one of the UEFI changes I lobbied for when I wrote my feedback to Asrock when testing their earlier mobos, imo the old drop down menu over 2 options just to change one value was so unproductive and redundant.
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
post #1949 of 2941
btw, the new beta UEFI for the Z68 Fatal1ty mobo looks freshly updated like the Z77 model. Let me quote the user who posted in my VR Zone thread cos the effort was all his.

Quote:
Originally Posted by ceut2004 
So....My first review of new beta L2.03 bios!
First thing I have said to my LCD screen is "Wow" eek.gif, here is the new screen:
L2.03_1.jpg

L2.03_2.jpg

Great graphics ! Asrock has done a great job on this ! No more face here (but during the boot the face is here...) !!!
There are some news options as Intel Smart Response/Connect for example.
We can tell now if a hard drive is a SSD or not, etc..

For instance, no problem with my little Celeron G530 (as I'm waiting for the 3770k and have sold my previous 2600k since many months...).

But it seems that keyboard management is as buggy as previous bios version, for example if I try to press F11 to have the boot menu, the bios menu appears...I've found that I must press it very very shortly and only once to have this boot menu.

Previous bug of IDE controller is still there, so warning:
disabling the IEE1394 under "Advanced>SouthBridge Configuration" disables IDE controller.

It seems that the boot Bios time is a little faster too cool.gif (this M/B really boot fast!!!).

Notice that the update is done in 2 steps: first is the main bios block reprogramming, then reboot then the Intel ME Firmware reprogramming (all is automatically done).
I think that's why Asrock do not recommand to downgrade Bios after this one
.

I will update later after doing some more tests with new options.


HTH
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
Tick Tac Tock!
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD | Intel Asrock | Asus AMD 32GB Vengeance Pro DDR3-2666 
Hard DriveOptical DriveCoolingOS
IntelSSD Pioneer | Samsung NiCu Heatkiller 3.0 | 655 | MicroRes | GTX360 Win7 x64 
MonitorKeyboardPowerCase
1920x1200 Logitech Corsair-Enermax Open air MoBoX | MSI Bench 3G 
  hide details  
Reply
post #1950 of 2941
Quote:
Originally Posted by MacClipper View Post

btw, the new beta UEFI for the Z68 Fatal1ty mobo looks freshly updated like the Z77 model. Let me quote the user who posted in my VR Zone thread cos the effort was all his.

OK, call me stupid. But where would one find this beta UEFI? There is nothing in beta on the Asrock site.
My Desktop PC
(15 items)
 
My recent build
(10 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7-2600K ASRock Z77 Formula OC GeForce 470GTX Mushkin Blackline Ridgeback 2x4GB DDR3 2000 
Hard DriveHard DriveCoolingOS
Crucial M4 256GB WD Caviar Black 1.5TB 7200 RPM 6.0Gb/s Corsair H50 Windows 8.1 Pro 
MonitorPowerCaseMouse
SAMSUNG XL2370-1 23" LED Corsair HX 750W NZXT Phantom Logitech Performance MX 
CPUMotherboardGraphicsRAM
Intel 4670K MSI Z87-GD65 EVAG 660 GTX Superclocked Mushkin 2X4 
Hard DriveOptical DriveCoolingOS
Samsung EVO 840 Asus DVD H100i 8.1 
PowerCase
Corsair 650 Gold Rosewill R5 
  hide details  
Reply
My Desktop PC
(15 items)
 
My recent build
(10 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7-2600K ASRock Z77 Formula OC GeForce 470GTX Mushkin Blackline Ridgeback 2x4GB DDR3 2000 
Hard DriveHard DriveCoolingOS
Crucial M4 256GB WD Caviar Black 1.5TB 7200 RPM 6.0Gb/s Corsair H50 Windows 8.1 Pro 
MonitorPowerCaseMouse
SAMSUNG XL2370-1 23" LED Corsair HX 750W NZXT Phantom Logitech Performance MX 
CPUMotherboardGraphicsRAM
Intel 4670K MSI Z87-GD65 EVAG 660 GTX Superclocked Mushkin 2X4 
Hard DriveOptical DriveCoolingOS
Samsung EVO 840 Asus DVD H100i 8.1 
PowerCase
Corsair 650 Gold Rosewill R5 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › ASRock Z68 Discussion/Owners Club