Overclock.net › Forums › Intel › Intel Motherboards › ASRock Z68 Discussion/Owners Club
New Posts  All Forums:Forum Nav:

ASRock Z68 Discussion/Owners Club - Page 260

post #2591 of 2941
Quote:
Originally Posted by TomcatV View Post

Welcome to OCN ... wish it was under better circumstances redface.gif ... Yours is an all to common problem of which you can read some of my earlier post(s) with more information [HERE] Page 251 / post #2501/2507
And more "ranting"? info [HERE] PAGE 200 / POST#1997 AND [HERE]
In a nutshell, I'd contact ASRock Customer Service and I would specifically list my problems/conflicts/hardware specs and ask them for a new bios chip with the 1.xx bios that was optimized for Sandy Bridge so you can get back to where you started, as ASRock clearly states you can't flash backwards from the Ivy Bridge 2.xx bios'
ASRock America, Inc.
13848 Magnolia Ave, Chino, CA91710 / U.S.A.
http://www.asrock.com/support/tsd.asp
Phone: +1-909-590-8308
Fax: +1-909-590-1026
EDIT: If you'd like to fill in all your system specs and give more details to your exact problem(s) we can all offer more help and suggestions biggrin.gif

Thanks for the reply, I've got the Fatal1ty pro gen3 MB, i7-2700k, 16gb gskill sniper series 1866, corsair force series 3 90gb ssd, PNY GTX 560ti. Everything is running stock. While using 1.3 for the past 9-10 months or so, I was dual booting between win 7(the install disk was pre-SP1, but has since been kept up-to-date) and xubuntu linux (it was installed on a separate hdd). Everything worked great, then I got the _great_ idea to update my bios the other day. Now the computer will boot into linux just fine but when I try to boot into windows, the screen just shows a blinking cursor for 2 seconds and then reboots. After reading this thread i've tried adjusting the sata3 settings back and forth between IDE and AHCI. I also tried resetting the CMOS.

Thankfully I was able to use clonezilla to make a backup of the SSD. I tried re-installing windows and it installed fine but then would not reboot back into windows. I submitted a support request to ASRock on Sunday but so far I've only gotten the auto-reply saying they received the request.

I was curious if you could "downgrade" to 1.30 as FAUguy suggests [Here] post #2547 If so, that would be great because then I would just re-flash the BIOS and put the backup image back on the ssd and let this be a lesson to me biggrin.gif
post #2592 of 2941
Quote:
Originally Posted by esgant View Post

Thanks for the reply, I've got the Fatal1ty pro gen3 MB, i7-2700k, 16gb gskill sniper series 1866, corsair force series 3 90gb ssd, PNY GTX 560ti.
I was curious if you could "downgrade" to 1.30 as FAUguy suggests [Here] post #2547 If so, that would be great because then I would just re-flash the BIOS and put the backup image back on the ssd and let this be a lesson to me biggrin.gif

No problem, your welcome smile.gif Looks like you've done a pretty thorough job of troubleshooting but as previously stated/linked ... ASRock specifically says you cannot (or shouldn't) "flashback", but I can say in "Rare" instances some guys [like FAUguy?] have somehow successfully flashed back to a Sandy Bridge 1.xx bios from an Ivy Bridge 2.xx bios without replacing the bios chip! ... It certainly wouldn't hurt to try? ... Additionally if your in N America I'd use the phone # above to speed things along ... ASRock NAmerica has proven to be quite helpful in the CS dept.!
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
post #2593 of 2941
Quote:
Originally Posted by TomcatV View Post

No problem, your welcome smile.gif Looks like you've done a pretty thorough job of troubleshooting but as previously stated/linked ... ASRock specifically says you cannot (or shouldn't) "flashback", but I can say in "Rare" instances some guys [like FAUguy?] have somehow successfully flashed back to a Sandy Bridge 1.xx bios from an Ivy Bridge 2.xx bios without replacing the bios chip! ... It certainly wouldn't hurt to try? ... Additionally if your in N America I'd use the phone # above to speed things along ... ASRock NAmerica has proven to be quite helpful in the CS dept.!
When the Beta BIOS L2.03 and L.2.04 were posted, I tried them for a while, but had issues and was able yo flash back to 1.30. But in doing so, each time the system would POST it would show an error about an incompatible version of Intel Management Engine. Then when the 2.10 BIOS was released I flashed to it, then later to the new 2.20, which I've been using for over a month without problem. Currently have my 2600k at 4.6GHz, and can quad boot just fine to XP, Vista, Win 7, and Win 8. I have all of them using the most current Intel AHCI driverd and have AHCI enabled in the BIOS.

To me, it sounds like your issue is most likely driver related. When you had 1.30, was IDE or AHCI being used in the BIOS?
FAUguy PC
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770K ASRock Z68 Fatal1ty Pro Gen 3 NVidia 560 ti Mushkin Enhanced Redline 16GB 2133MHz 
Hard DriveOptical DriveOptical DriveOS
Hitachi 2TB 7K3000 Pioneer BDR-2208 Plextor PX-716 Windows 7 x64 
MonitorPowerCaseAudio
NEC FE2111SB Enermax 600W CoolerMaster CM Stacker Soundblaster Audigy 2 
  hide details  
Reply
FAUguy PC
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770K ASRock Z68 Fatal1ty Pro Gen 3 NVidia 560 ti Mushkin Enhanced Redline 16GB 2133MHz 
Hard DriveOptical DriveOptical DriveOS
Hitachi 2TB 7K3000 Pioneer BDR-2208 Plextor PX-716 Windows 7 x64 
MonitorPowerCaseAudio
NEC FE2111SB Enermax 600W CoolerMaster CM Stacker Soundblaster Audigy 2 
  hide details  
Reply
post #2594 of 2941
I was using AHCI with 1.30
post #2595 of 2941
Did someone already updated BIOS to 2.30?

I want your feedback abou that 'dehumidifier' option...... what's it for? Noted any benefits?

Regards,
post #2596 of 2941
Quote:
Originally Posted by Gaucho View Post

Did someone already updated BIOS to 2.30?
I want your feedback abou that 'dehumidifier' option...... what's it for? Noted any benefits?
Regards,

Pretty sure the dehumidifier just turns the fan on and off occasionally, im most cases if you have your rig inside your house you wouldn't really need to worry about it.
Eternity-VIII
(15 items)
 
Eternity-IX
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770K (delid) ASUS Maximus VI Gene MSI GTX 970 Gaming 8GB Samsung MV-3V4G3 
Hard DriveHard DriveCoolingOS
Samsung 840 Pro 256GB (OS) Samsung 840 EVO 250GB (Steam) Corsair H80i, 4x NF-A14 PWM Windows 8.1 Pro  
MonitorKeyboardPowerCase
BenQ XL2720T CM Quickfire TK Red Corsair AX850 Corsair 350D 
MouseMouse PadAudio
Logitech G400/G502/G602 Steel Series 4HD SupremeFX 
CPUMotherboardGraphicsRAM
i7 6820HK Intel CM236 MSI GTX 1070 16GB Kingston 2400 
Hard DriveHard DriveHard DriveOS
Toshiba XG3 128GB NVME (OS) Samsung 850 EVO 250GB (Steam) Toshiba TR150 960GB (Steam) Windows 10 Pro 
MonitorKeyboardPowerCase
17.3" 120Hz CM Quickfire TK Red 230W GT73VR TITAN 
MouseMouse Pad
Logitech G502 SteelSeries 4HD 
  hide details  
Reply
Eternity-VIII
(15 items)
 
Eternity-IX
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770K (delid) ASUS Maximus VI Gene MSI GTX 970 Gaming 8GB Samsung MV-3V4G3 
Hard DriveHard DriveCoolingOS
Samsung 840 Pro 256GB (OS) Samsung 840 EVO 250GB (Steam) Corsair H80i, 4x NF-A14 PWM Windows 8.1 Pro  
MonitorKeyboardPowerCase
BenQ XL2720T CM Quickfire TK Red Corsair AX850 Corsair 350D 
MouseMouse PadAudio
Logitech G400/G502/G602 Steel Series 4HD SupremeFX 
CPUMotherboardGraphicsRAM
i7 6820HK Intel CM236 MSI GTX 1070 16GB Kingston 2400 
Hard DriveHard DriveHard DriveOS
Toshiba XG3 128GB NVME (OS) Samsung 850 EVO 250GB (Steam) Toshiba TR150 960GB (Steam) Windows 10 Pro 
MonitorKeyboardPowerCase
17.3" 120Hz CM Quickfire TK Red 230W GT73VR TITAN 
MouseMouse Pad
Logitech G502 SteelSeries 4HD 
  hide details  
Reply
post #2597 of 2941
Quote:
Originally Posted by UZ7 View Post

Pretty sure the dehumidifier just turns the fan on and off occasionally, im most cases if you have your rig inside your house you wouldn't really need to worry about it.

Yes, I can't believe that someone spent time and actually got paid to make this dehumidifier option. Talk about a waste of time.
FAUguy PC
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770K ASRock Z68 Fatal1ty Pro Gen 3 NVidia 560 ti Mushkin Enhanced Redline 16GB 2133MHz 
Hard DriveOptical DriveOptical DriveOS
Hitachi 2TB 7K3000 Pioneer BDR-2208 Plextor PX-716 Windows 7 x64 
MonitorPowerCaseAudio
NEC FE2111SB Enermax 600W CoolerMaster CM Stacker Soundblaster Audigy 2 
  hide details  
Reply
FAUguy PC
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770K ASRock Z68 Fatal1ty Pro Gen 3 NVidia 560 ti Mushkin Enhanced Redline 16GB 2133MHz 
Hard DriveOptical DriveOptical DriveOS
Hitachi 2TB 7K3000 Pioneer BDR-2208 Plextor PX-716 Windows 7 x64 
MonitorPowerCaseAudio
NEC FE2111SB Enermax 600W CoolerMaster CM Stacker Soundblaster Audigy 2 
  hide details  
Reply
post #2598 of 2941
So after flashing from 1.30 to 2.30 my i5 2500K isn't stable anymore at 4.5 Ghz 1.312v

Did anyone done some stable clock withs this bios and i5 at 4.5 ghz something I could refer too I know every processor has different capabilities as far as oc goes but some standing point

For now I run pre programmed 4.6 ghz of that bios and seams fine just the voltage in CPU z
Is ~ 1.370v a bit high for that clock.

I'm using intel burn test as a fast oc indicator set up to 10 loops and very high memory
And prime95 for 12 + h runs as a time consuming indicator thumb.gif

I,ll just stick with pre programmed 4.6 for now it passed my intel burn test and running 3h prime so far temps aren't bad bellow 70 c and it all happens while watching move and doing some photoshop editing and typing this

Maybe that put some work in those pre programmed profiles after all....

What do you guys think

I have limited time
Edited by K2mil - 8/16/12 at 3:00pm
K2mil-PC
(21 items)
 
  
CPUMotherboardGraphicsRAM
INTEL CORE I5 2500K @ 4.5 Ghz ASRock Extreme 7 (G3) Asus 1070 Strix OC 16GB @ 1600 |CORSAIR CMZ8GX3M2A1600C9B 
Hard DriveHard DriveHard DriveCooling
Intel 730 SSD 240 GB SATA III Samsung SSD  WD Blue 1TB Zalman CNPS9900 MAX 
OSMonitorKeyboardPower
Windows 10 x64 ASUS ROG Swift PG278Q Logitech K800 Corsair 850i Modular 
CaseMouseMouse PadAudio
Corsair Obsidian 650d Corsair M60 Saitek Cyborg Astro A30 
OtherOtherOtherOther
Saitek X65F HOTAS Saitek Pro Ruder Pedals Saitek Pro Flight Instrument Panel  Trackir 5 
Other
Sound Blaster Z 
  hide details  
Reply
K2mil-PC
(21 items)
 
  
CPUMotherboardGraphicsRAM
INTEL CORE I5 2500K @ 4.5 Ghz ASRock Extreme 7 (G3) Asus 1070 Strix OC 16GB @ 1600 |CORSAIR CMZ8GX3M2A1600C9B 
Hard DriveHard DriveHard DriveCooling
Intel 730 SSD 240 GB SATA III Samsung SSD  WD Blue 1TB Zalman CNPS9900 MAX 
OSMonitorKeyboardPower
Windows 10 x64 ASUS ROG Swift PG278Q Logitech K800 Corsair 850i Modular 
CaseMouseMouse PadAudio
Corsair Obsidian 650d Corsair M60 Saitek Cyborg Astro A30 
OtherOtherOtherOther
Saitek X65F HOTAS Saitek Pro Ruder Pedals Saitek Pro Flight Instrument Panel  Trackir 5 
Other
Sound Blaster Z 
  hide details  
Reply
post #2599 of 2941
Quote:
Originally Posted by K2mil View Post

So after flashing from 1.30 to 2.30 my i5 2500K isn't stable anymore at 4.5 Ghz 1.312v
Did anyone done some stable clock withs this bios and i5 at 4.5 ghz something I could refer too I know every processor has different capabilities as far as oc goes but some standing point
For now I run pre programmed 4.6 ghz of that bios and seams fine just the voltage in CPU z
Is ~ 1.370v a bit high for that clock.
I'm using intel burn test as a fast oc indicator set up to 10 loops and very high memory
And prime95 for 12 + h runs as a time consuming indicator thumb.gif
I,ll just stick with pre programmed 4.6 for now it passed my intel burn test and running 3h prime so far temps aren't bad bellow 70 c and it all happens while watching move and doing some photoshop editing and typing this
Maybe that put some work in those pre programmed profiles after all....
What do you guys think
I have limited time

Giving your limited amount of time ... I think your fine, especially with those temps using IBT! That voltage 1.37 isn't too bad, however I doubt you will ever get it back down to 1.312v without going into all the detail of why a bios optimized for IB can present "minor"? OC problems w/SB. I'm curious what cooling method your using and at what ambients cause your right on point with a well tuned setup biggrin.gif

DE-HUMAN-FIRE ... that cracked me up the 1st time it was posted ... sounded like some Alien Invasion prevention program from Mars biggrin.gif ... but I can certainly see it's usefullness in high humidity area's like the deep south ... not here in the desert though.
Edited by TomcatV - 8/16/12 at 3:51pm
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
 
Too Easy
(17 items)
 
 
CPUMotherboardGraphicsGraphics
6700K 47/44GHz@1.296v or 48/45@1.360v Adaptive ... Z170 ASUS HERO VIII LGA 1151 (Bios 2202) Evga GTX 1080 SC "SOLD $525" no bios editor! Gigabyte G1 GTX 980Ti 1519/8002 24/7 Bios modded! 
RAMHard DriveHard DriveCooling
TridentZ 3600 15-15-15-36-1T [F4-3600C16D-16GTZ ] Samsung Evo SSD 500GB (boot) Crucial MX300 SSD 1TB (storage) Kraken X61  
OSMonitorMonitorKeyboard
Win10 64bit (sucks) Overlord 27" "Glossy" 1440p@120Hz QNIX QX2710 "Glossy" 1440p@120Hz+  Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
EVGA SuperNOVA 1200 P2 Platinum NZXT H440 (Hate it!) Logitech G502 / Razer Deathader Rocketfish "Speed" 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
CPUMotherboardGraphicsRAM
2500K@4.6 24/7 ASRock Z68 Ext4 Gen3 (bios 1.10) Gigabyte G1 GTX 980Ti 1532/8002 24/7 Bios modded GSkill F3-17000CL11D-8GBXL 1.54v 
Hard DriveHard DriveOptical DriveCooling
Samsung 850 Evo 500GB 1T Samsung F3-storage Asus 24x H100 top exhaust (push/pull kinda?) 
OSMonitorMonitorKeyboard
Win7-64bit SP1  QNIX QX2710 "Glossy" 1440p@120Hz++ (1st gen L02... Overlord 27" Glossy 1440p@120Hz Corsair K65 RGB Cherry Red 
PowerCaseMouseMouse Pad
Corsair HX850w Haf 922 (modded) Logitech G502 Rocketfish Speed 
Audio
Sound Blaster Z w/ Logitech Z680 5.1 Speakers  
  hide details  
Reply
post #2600 of 2941
Quote:
Originally Posted by K2mil View Post

So after flashing from 1.30 to 2.30 my i5 2500K isn't stable anymore at 4.5 Ghz 1.312v
Did anyone done some stable clock withs this bios and i5 at 4.5 ghz something I could refer too I know every processor has different capabilities as far as oc goes but some standing point
For now I run pre programmed 4.6 ghz of that bios and seams fine just the voltage in CPU z
Is ~ 1.370v a bit high for that clock.
I'm using intel burn test as a fast oc indicator set up to 10 loops and very high memory
And prime95 for 12 + h runs as a time consuming indicator thumb.gif
I,ll just stick with pre programmed 4.6 for now it passed my intel burn test and running 3h prime so far temps aren't bad bellow 70 c and it all happens while watching move and doing some photoshop editing and typing this
Maybe that put some work in those pre programmed profiles after all....
What do you guys think
I have limited time
With my 2600K and Fatal1ty Z68 Pro Gen 3 with BIOS 2.20, I have it clocked at 4.6GHz and the voltage offset of +0.050 and LLC 5. That give me a max voltage of 1.312v and temps about 70c, when running IBT for a few hours. If I chose the auto 4.6 overclock in the BIOS, I think it uses a +0.750v offset and produces higher temps. That is why I tested the offsets myself, and found that lowering it to +0.050v was stable, but any lower would cause IBT to crash or BSOD when booting Win 7.
Edited by FAUguy - 8/16/12 at 10:56pm
FAUguy PC
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770K ASRock Z68 Fatal1ty Pro Gen 3 NVidia 560 ti Mushkin Enhanced Redline 16GB 2133MHz 
Hard DriveOptical DriveOptical DriveOS
Hitachi 2TB 7K3000 Pioneer BDR-2208 Plextor PX-716 Windows 7 x64 
MonitorPowerCaseAudio
NEC FE2111SB Enermax 600W CoolerMaster CM Stacker Soundblaster Audigy 2 
  hide details  
Reply
FAUguy PC
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3770K ASRock Z68 Fatal1ty Pro Gen 3 NVidia 560 ti Mushkin Enhanced Redline 16GB 2133MHz 
Hard DriveOptical DriveOptical DriveOS
Hitachi 2TB 7K3000 Pioneer BDR-2208 Plextor PX-716 Windows 7 x64 
MonitorPowerCaseAudio
NEC FE2111SB Enermax 600W CoolerMaster CM Stacker Soundblaster Audigy 2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › ASRock Z68 Discussion/Owners Club