Overclock.net › Forums › AMD › AMD Motherboards › Coolit ECO + GA=990XA Need Help ASAP
New Posts  All Forums:Forum Nav:

Coolit ECO + GA=990XA Need Help ASAP

post #1 of 9
Thread Starter 
I am trying to install the Coolit ECO to my Gigabyte 990XA UD3 board but am confused about these backplate things and where to mount the bracket for the cooler. Help
Edited by NuclearSlurpee - 10/13/11 at 7:24pm
post #2 of 9
There should be instructions that guide you through the process.

Basically, you attach the backplate to the back of the motherboard, and then screw it into the motherboard with the screws provided.

At this point, you will be able to take the cooler and attach it to the processor with the new holes in the front of the mobo.
2500k
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k @ 4.6 1.27V Asus p67 Pro SLI 560 TI Ripjaws X 1600 2x4GB 
Hard DriveCoolingOSMonitor
Crucial C300 + Spinpoint F3 Noctua N-D14 Win 7 x64 LG 1920x1080 
KeyboardPowerCaseMouse
Das Professional NZXT 750w Hale90 Antec 600 M60 
Audio
ATH AD700 
  hide details  
Reply
2500k
(15 items)
 
  
CPUMotherboardGraphicsRAM
2500k @ 4.6 1.27V Asus p67 Pro SLI 560 TI Ripjaws X 1600 2x4GB 
Hard DriveCoolingOSMonitor
Crucial C300 + Spinpoint F3 Noctua N-D14 Win 7 x64 LG 1920x1080 
KeyboardPowerCaseMouse
Das Professional NZXT 750w Hale90 Antec 600 M60 
Audio
ATH AD700 
  hide details  
Reply
post #3 of 9
Thread Starter 
There is this one backplate that has nothing on it, no 1333 or 1156 or 1155 for Intel. Is that the one? Or do I keep the stock backplate on?
post #4 of 9
Thread Starter 
It doesnt appear that the blank bracket can since it is square and the one on there is a rectangle I guess for AMD.
post #5 of 9
Thread Starter 
Need some help. The screws on the bracket of the mobo are really tightened
post #6 of 9
Thread Starter 
When I try to tighten the screws on the ECO to the backplate, they dont screw in,,,
post #7 of 9
Thread Starter 
Anybody?
post #8 of 9
Thread Starter 
Seriously AMD people. I am trying to screw the cooler in to the backplate but for some reason the screws aren't going in.... Is this unit screwed up or something?
post #9 of 9
Thread Starter 
Wow I feel stupid. Close this thread
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › Coolit ECO + GA=990XA Need Help ASAP