Overclock.net › Forums › Video Games › PC Gaming › [Fixed] Problems connecting to server - BC2
New Posts  All Forums:Forum Nav:

[Fixed] Problems connecting to server - BC2

post #1 of 11
Thread Starter 
Hi all.

Really getting annoyed with this. Going into the bad company 2 server screen, I can search and find hundreds of servers. I can not connect to a single one, unless I choose 'play now' and hope that I get sent to a server with at least one other person on it ¬.¬

Nothing has changed since 3 hours ago, not router resets (EVERYTHING else that uses a connection to the internet is fine, including other games), no hardware change, no steam settings changed...

I don't use a firewall yet because... well I haven't got around to installing one yet

Anyone able to think of a reason that BC2 might decide I shouldn't play multiplayer anymore?
Edited by SgtMunky - 10/14/11 at 2:07pm
post #2 of 11
I had this SAME exact problem last night. (I was jonzing for some BF3 action, so I settled for this). I had to log in, then log out of BC2 3 or 4 times completely. I also closed and reopened the game a couple of time between doing that. Once I did that I was able to connect to all the servers I browsed. Weird problem.
Liquid Blue
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600k @ 4.7ghz Gigabyte P67A-UD4_B5 Msi 1080 ti Founder's Edition 16gb Corsair Vengence 1600 
Hard DriveCoolingCoolingOS
Crucial M5 512 GB CPU: XSPC Raystorm h2o GPU: XSPC Razor 1080 ti Full block Windows 10 x64 
MonitorPowerCase
LG 34UC98 Mushkin Enhanced Joule 1000 NZXT Switch 810 Full Tower 
  hide details  
Reply
Liquid Blue
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600k @ 4.7ghz Gigabyte P67A-UD4_B5 Msi 1080 ti Founder's Edition 16gb Corsair Vengence 1600 
Hard DriveCoolingCoolingOS
Crucial M5 512 GB CPU: XSPC Raystorm h2o GPU: XSPC Razor 1080 ti Full block Windows 10 x64 
MonitorPowerCase
LG 34UC98 Mushkin Enhanced Joule 1000 NZXT Switch 810 Full Tower 
  hide details  
Reply
post #3 of 11
Thread Starter 
Really annoying, especially as nothing has changed and its only one game
post #4 of 11
I had this problem but after doing a run of CCleaner, it worked fine!

(Probably a problem with cache or somethin)
post #5 of 11
Thread Starter 
Ok I signed in and out 3 times, I'm in
post #6 of 11
ive been having the same issue for a few days now, ive had to logout and in multiple times before it let me on servers
Patawic's Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Thuban 1055T Gigabyte 880GMA-UD2H GIGABYTE GeForce GTX 460 1GB OC Corsair 4gb 1333mhz DDR3 
Hard DriveOptical DriveCoolingOS
Samsung F4 LG CH10LS20 Bluray CoolerMaster Hyper Z600 Windows 7 
MonitorKeyboardPowerCase
Dell P4211H x 2 Logitech G110 OCZ 750W Fatal1ty HAF 912 
  hide details  
Reply
Patawic's Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Thuban 1055T Gigabyte 880GMA-UD2H GIGABYTE GeForce GTX 460 1GB OC Corsair 4gb 1333mhz DDR3 
Hard DriveOptical DriveCoolingOS
Samsung F4 LG CH10LS20 Bluray CoolerMaster Hyper Z600 Windows 7 
MonitorKeyboardPowerCase
Dell P4211H x 2 Logitech G110 OCZ 750W Fatal1ty HAF 912 
  hide details  
Reply
post #7 of 11
Quote:
Originally Posted by SgtMunky View Post
Ok I signed in and out 3 times, I'm in
Great! Now prepare to be disappointed.
Liquid Blue
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600k @ 4.7ghz Gigabyte P67A-UD4_B5 Msi 1080 ti Founder's Edition 16gb Corsair Vengence 1600 
Hard DriveCoolingCoolingOS
Crucial M5 512 GB CPU: XSPC Raystorm h2o GPU: XSPC Razor 1080 ti Full block Windows 10 x64 
MonitorPowerCase
LG 34UC98 Mushkin Enhanced Joule 1000 NZXT Switch 810 Full Tower 
  hide details  
Reply
Liquid Blue
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel 2600k @ 4.7ghz Gigabyte P67A-UD4_B5 Msi 1080 ti Founder's Edition 16gb Corsair Vengence 1600 
Hard DriveCoolingCoolingOS
Crucial M5 512 GB CPU: XSPC Raystorm h2o GPU: XSPC Razor 1080 ti Full block Windows 10 x64 
MonitorPowerCase
LG 34UC98 Mushkin Enhanced Joule 1000 NZXT Switch 810 Full Tower 
  hide details  
Reply
post #8 of 11
Thread Starter 
lol I'm so awful at it, but first game I got into unlocked the GOL so all is well
post #9 of 11
Close the game and open it again.
Randomness
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 980x @ 4.4 / Upgrade - Ivy Bridge X58A-UD3R [EVGA] 2x EVGA GTX 580 3GB 12GB Corsair DDR3-1600  
Hard DriveOSMonitorKeyboard
Seagate Barracuda XT ST32000641AS 2TB HDD Windows 7 64 bit nVidia Surround - 3x U2410 IPS 6048x1200 G15 
PowerCaseMouse
Thermaltake Toughpower 1200 Thermaltake SwordM Razer Naga, G400 
  hide details  
Reply
Randomness
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 980x @ 4.4 / Upgrade - Ivy Bridge X58A-UD3R [EVGA] 2x EVGA GTX 580 3GB 12GB Corsair DDR3-1600  
Hard DriveOSMonitorKeyboard
Seagate Barracuda XT ST32000641AS 2TB HDD Windows 7 64 bit nVidia Surround - 3x U2410 IPS 6048x1200 G15 
PowerCaseMouse
Thermaltake Toughpower 1200 Thermaltake SwordM Razer Naga, G400 
  hide details  
Reply
post #10 of 11
Quote:
Originally Posted by SgtMunky View Post
Hi all.

Really getting annoyed with this. Going into the bad company 2 server screen, I can search and find hundreds of servers. I can not connect to a single one, unless I choose 'play now' and hope that I get sent to a server with at least one other person on it ¬.¬

Nothing has changed since 3 hours ago, not router resets (EVERYTHING else that uses a connection to the internet is fine, including other games), no hardware change, no steam settings changed...

I don't use a firewall yet because... well I haven't got around to installing one yet

Anyone able to think of a reason that BC2 might decide I shouldn't play multiplayer anymore?
same here, 1st time I tried sonce it was working yesterday

was like it last week sometime for a while
purifying flames
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k @ 4.6 GHz Gigabyte Z68XP-UD4 rev 1.0 sapphire 6950 2GB 4GB 1600 CL6 
Hard DriveMonitorPower
Crucial M4 128GB sata3 24" 1080p XFX 750W XXX 80+silver 
  hide details  
Reply
purifying flames
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500k @ 4.6 GHz Gigabyte Z68XP-UD4 rev 1.0 sapphire 6950 2GB 4GB 1600 CL6 
Hard DriveMonitorPower
Crucial M4 128GB sata3 24" 1080p XFX 750W XXX 80+silver 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › [Fixed] Problems connecting to server - BC2