Overclock.net › Forums › Video Games › PC Gaming › GTA IV lag spikes with new parts
New Posts  All Forums:Forum Nav:

GTA IV lag spikes with new parts

post #1 of 12
Thread Starter 
So I just updated my CPU, Mobo and RAMs (sig rig) from Q8200, msi p43 neo-f and 4gb g.skill 800mhz RAM.

GTA IV were running fine with older parts but now i get constantly lag spikes and see how objects come there when I move on, on the map (like drive a car and see when theres pop ups fire escape ladder on buildings).

I remember that I had this problem once with old parts too but dunno how it solved.

I tried to defragg my HDDs, SMART check, error check them with HD Tune. Reinstalling gpu drives. Update all updates from windows update.

It's on steam so I guess it haves latest patches too.

Haven't tried to reinstall the game or steam because it takes too long to download that :/


So anyone have suggestions to fix this slow objects loading problem which causes lag spikes?
Edited by MooMoo - 10/18/11 at 4:39am
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
post #2 of 12
Thread Starter 
I just saw this http://i.imgur.com/YJ2q4.jpg and went to dxdiag too, it show me same ammount, what to do?
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
post #3 of 12
use gpu-z to see if that's true. If it is, your gpu's memory possibly died? I'm not 100% certain if it can happen but it seems like it did
Budget Rig V2
(10 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen R7 1700 @ 3900 Asus AB350M Pro4 EVGA GTX 1080 TI SC2 Hybrid Corsair Vengeance LPx 
Hard DriveCoolingOSMonitor
MyDigitalSSD BPX EVGA CLC 280mm Windows 10 Pro Benq PD3200U 
PowerCase
Seasonic Platinum 660 Fractal Design Mini C 
  hide details  
Reply
Budget Rig V2
(10 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen R7 1700 @ 3900 Asus AB350M Pro4 EVGA GTX 1080 TI SC2 Hybrid Corsair Vengeance LPx 
Hard DriveCoolingOSMonitor
MyDigitalSSD BPX EVGA CLC 280mm Windows 10 Pro Benq PD3200U 
PowerCase
Seasonic Platinum 660 Fractal Design Mini C 
  hide details  
Reply
post #4 of 12
Thread Starter 
Quote:
Originally Posted by Ubernoobie;15352581 
use gpu-z to see if that's true. If it is, your gpu's memory possibly died? I'm not 100% certain if it can happen but it seems like it did

http://i.imgur.com/vbkXV.jpg So it's not true?
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
post #5 of 12
GTAIV is a very poor console port. You got to play around with the graphic settings to make it not lag, well as much. For your card, Your best bet is to have graphic settings on medium with 512MB card. Since your CPU couldn't really be the problem. The game uses alot of video memory. So, The sliders is basically is what's going to kill you and cause lag. Make sure you're updated to 1.0.7.0 and at the bottom where it shows the amount of VRAM used, Make sure to keep it in the green. Although, I would really recommend that you upgrade the graphics card if you wish to play this game without lag. 1GB VRAM helps but it still kind of lags when all the settings are kind of maxed out.
    
CPUMotherboardGraphicsRAM
[ Q6600 2.4GHz ] [ ASUS P5K ] [ Radeon HD5830 ] [ 4GB 800MHz ] 
Hard DriveOptical DriveOSMonitor
[ WD 500GB SATA ] [ DVD Burner/Reader 16x ] [ W7 Ultimate x64 ] [ Viewsonic 19" ] 
KeyboardPowerCaseMouse
Microsoft [ 600W ] [ Antec 900 ] Microsoft 
Mouse Pad
Desk 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[ Q6600 2.4GHz ] [ ASUS P5K ] [ Radeon HD5830 ] [ 4GB 800MHz ] 
Hard DriveOptical DriveOSMonitor
[ WD 500GB SATA ] [ DVD Burner/Reader 16x ] [ W7 Ultimate x64 ] [ Viewsonic 19" ] 
KeyboardPowerCaseMouse
Microsoft [ 600W ] [ Antec 900 ] Microsoft 
Mouse Pad
Desk 
  hide details  
Reply
post #6 of 12
Thread Starter 
I've messed with the settings without results. I didn't have problems with this graphic card before upgrading my cpu, mobo and ram. I ran it nicely with medium settings and didnt have lagg unless it didnt have patches (like year ago or something), but now it should have newest patch because I downloaded it from steam.
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
post #7 of 12
this will most definitely fix it.

-refreshrate 39
-framelimit 1

write that on a .txt and name it commandline.txt, place it in your game directory (where launchgta.exe is), give it a try, im almost certain this will solve your issue. (I know it removed all my lag and stuttering by 99.99%)

Also, recent ATI drivers made gta performance worse, rolling back to 11.2 made it much better; Give those a try, specially the commandline. Good luck!
Little Beast
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @4.5ghz Asus P8P67 Pro Asus GTX 970 Corsair Dominator 8gb 1600mhz 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black 1TB Western Digital Caviar Black 1TB Cooler Master Hyper 212+ Windows 7 64bit 
PowerCase
Antec HCP-850W Cooler Master HAF 922 
  hide details  
Reply
Little Beast
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @4.5ghz Asus P8P67 Pro Asus GTX 970 Corsair Dominator 8gb 1600mhz 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black 1TB Western Digital Caviar Black 1TB Cooler Master Hyper 212+ Windows 7 64bit 
PowerCase
Antec HCP-850W Cooler Master HAF 922 
  hide details  
Reply
post #8 of 12
Thread Starter 
Thx for reply.
But hmm, didn't work.
It seems like its not about the graphics, its about loading objects which causes lag spikes, maybe my hdd is messed up or something :/
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
It's alive!
(25 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-7700k Asus ROG MAXIMUS IX HERO Z270 bios: 0906 Gigabyte 7950 3GB @1050/1550MHz G.Skill "Trident Z RGB" F4-3866C18D-16GTZR 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 EVO 250GB OS 830 256GB  2xWD Caviar Black 640GB 64MB WD Caviar Green 1TB 64MB 
Hard DriveOptical DriveCoolingCooling
Intel 600p 256GB LG DVD drive CPU: Noctua NH-D15 GPU: Accelero Xtreme 7970 
OSMonitorMonitorKeyboard
Windows 10 64bit ASUS 27" LED VE278Q  BenQ 22" Logitech 710+ MX Brown 
PowerCaseMouseMouse Pad
Corsair HX850W NZXT Switch 810 White Logitech G500 Steelseries 9HD 
AudioAudioAudioAudio
Asus ROG Xonar Phoebus Logitech Z523 2.1 Beyerdynamic DT 990 Pro 250Ω Samson C01U mic 
Other
Asus RT-N66U 'Dark Knight' Router 
  hide details  
Reply
post #9 of 12
Quote:
Originally Posted by MooMoo;15365015 
Thx for reply.
But hmm, didn't work.
It seems like its not about the graphics, its about loading objects which causes lag spikes, maybe my hdd is messed up or something :/

You could use Steam Mover to move the game to another HDD to test and see cool.gif
Link to Steam Mover thread
I Like Smileys :)
(16 items)
 
Sony Vaio 1512
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 4.6GHz Asus P8P67 Pro Bios 3207 MSI GTX 970 GAMING 4G Ripjaws-X 16GB 1600MHz 
Hard DriveHard DriveOptical DriveCooling
80GB Intel & 128GB 830  2 x WD640 Caviar Black LG DVD-RW Noctua NH-D14  
OSMonitorKeyboardPower
Windows 7 HP 64bit Acer 5906x1080 3D Logitech G15 Corsair TX850W 
CaseMouseMouse PadAudio
Antec Dark Fleet DF-85 Logitec G700 Razer Goliathus Sharkoon X-Tatic 5.1 Headset 
CPUMotherboardGraphicsRAM
Intel® Core™ i5-3210M Laptop  HD 4000 Corsair Vengeance 8GB  
Hard DriveOptical DriveOSMonitor
Samsung 840 250GB DVD Multi Windows 8 15.5 inch display (1366 x 768) 
Keyboard
LED Back lit 
  hide details  
Reply
I Like Smileys :)
(16 items)
 
Sony Vaio 1512
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 4.6GHz Asus P8P67 Pro Bios 3207 MSI GTX 970 GAMING 4G Ripjaws-X 16GB 1600MHz 
Hard DriveHard DriveOptical DriveCooling
80GB Intel & 128GB 830  2 x WD640 Caviar Black LG DVD-RW Noctua NH-D14  
OSMonitorKeyboardPower
Windows 7 HP 64bit Acer 5906x1080 3D Logitech G15 Corsair TX850W 
CaseMouseMouse PadAudio
Antec Dark Fleet DF-85 Logitec G700 Razer Goliathus Sharkoon X-Tatic 5.1 Headset 
CPUMotherboardGraphicsRAM
Intel® Core™ i5-3210M Laptop  HD 4000 Corsair Vengeance 8GB  
Hard DriveOptical DriveOSMonitor
Samsung 840 250GB DVD Multi Windows 8 15.5 inch display (1366 x 768) 
Keyboard
LED Back lit 
  hide details  
Reply
post #10 of 12
I know low detail distance can cause stuttering cause the objects will just like... pop out of nothing and will make the game freak out for some dumb reason.

Strange the above tip didn't work for you though, it works in most cases; for the record, you need to have vsync activated in game for it to work properly, did you at least notice the cap on the framerate when tryng it? If not, you didn't do it right, I mean, it's cool just saying. (also, if it works you can't change your graphic settings on the graphics menu or it will override the framerate cap)

I suggested the above thing cause I had the exact same problem, in very specific parts of the map too, I, as well thought it was a hard drive issue, but it turns out it's a leak on the memory buffer, last time rockstar was 'looking into it', I guess they completely gave up by now; but I guess this is not your issue then so...

Also, one more thing, steam automatically updates you to the latest patch which to be fair, is far from being the best patch fps wise (almost no system can play the game with very high shadows without stuttering), patch 4 and 5 gives you the best results, if you have the money and you're willing to buy the retail version, go for it, and try those patches, the game is very cheap nowadays anyway. good luck.
Edited by Brainsick - 10/19/11 at 1:15am
Little Beast
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @4.5ghz Asus P8P67 Pro Asus GTX 970 Corsair Dominator 8gb 1600mhz 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black 1TB Western Digital Caviar Black 1TB Cooler Master Hyper 212+ Windows 7 64bit 
PowerCase
Antec HCP-850W Cooler Master HAF 922 
  hide details  
Reply
Little Beast
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k @4.5ghz Asus P8P67 Pro Asus GTX 970 Corsair Dominator 8gb 1600mhz 
Hard DriveHard DriveCoolingOS
Western Digital Caviar Black 1TB Western Digital Caviar Black 1TB Cooler Master Hyper 212+ Windows 7 64bit 
PowerCase
Antec HCP-850W Cooler Master HAF 922 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › GTA IV lag spikes with new parts