Overclock.net › Forums › Components › Monitors and Displays › DVI input dead?
New Posts  All Forums:Forum Nav:

DVI input dead?

post #1 of 7
Thread Starter 
I was recently plagued by a no display issue (Westinghouse lcm-22w3) after attempting to go back to my winter time OC. I was testing an OC when my computer booted at 640x480 res. I rebooted thinking that my video driver failed to load or something but was greeted with the black screen of death. The computer booted in the background but I got no image. After messing around with CMOS resets and such I finally decided to try the VGA input on the monitor and the picture, while somewhat blurry, showed up running at the native 1680x1050 res.

I've uninstalled all recent updated to the system, set default clocks, reinstalled video drivers, even tried a different monitor (which worked) and am still getting the same results. All fingers point to the DVI input being dead right?

If so then I will need a new monitor, what do you guys suggest? I would like a 22-24" LED backlit 1920x1080 monitor that is good for gaming + movies and preferably an IPS panel.

Edit: I'm somewhat of a monitor noob, so any and all suggestions are appreciated.
Edited by rusky1 - 10/18/11 at 11:30pm
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
post #2 of 7
If it doesnt work on another monitor, shouldnt it be that the video card dvi is dead and not the monitor? Do you have another video card to test your dvi input with?
kaoru
(19 items)
 
kirino
(10 items)
 
 
CPUMotherboardGraphicsRAM
Zosma 960T SABERTOOTH 990FX Radeon HD 6850 SAMSUNG 
Hard DriveHard DriveHard DriveHard Drive
Seagate Barracuda 250GB Western Digital WD Green WD20EARX 2TB ST2000DM001 Western Digital Scorpio Black WD1600BEKT  
Optical DriveCoolingOSOS
LITE-ON 24X DVD Writer GentleTyphoon 2150 x3 Windows 8.1 Professional Windows 7 Professional 
MonitorPowerCaseOther
SyncMaster P2370HD CORSAIR CMPSU-550VX  Fractal Design R4 HighPointTech Raid Controller 4320 
CPUMotherboardGraphicsRAM
AMD A8-3850 Llano BIOSTAR A75MH AMD Radeon HD 6550D G.SKILL Ripjaws 
Hard DriveCoolingCoolingOS
Western Digital Black Scythe SCKBT-1000 Kabuto BitFenix Spectre Pro 120mm Fan - White LED Windows 7 Professional 
PowerCase
Corsair CMPSU-430CXV2 Dell Dimension 2300 Case 
  hide details  
Reply
kaoru
(19 items)
 
kirino
(10 items)
 
 
CPUMotherboardGraphicsRAM
Zosma 960T SABERTOOTH 990FX Radeon HD 6850 SAMSUNG 
Hard DriveHard DriveHard DriveHard Drive
Seagate Barracuda 250GB Western Digital WD Green WD20EARX 2TB ST2000DM001 Western Digital Scorpio Black WD1600BEKT  
Optical DriveCoolingOSOS
LITE-ON 24X DVD Writer GentleTyphoon 2150 x3 Windows 8.1 Professional Windows 7 Professional 
MonitorPowerCaseOther
SyncMaster P2370HD CORSAIR CMPSU-550VX  Fractal Design R4 HighPointTech Raid Controller 4320 
CPUMotherboardGraphicsRAM
AMD A8-3850 Llano BIOSTAR A75MH AMD Radeon HD 6550D G.SKILL Ripjaws 
Hard DriveCoolingCoolingOS
Western Digital Black Scythe SCKBT-1000 Kabuto BitFenix Spectre Pro 120mm Fan - White LED Windows 7 Professional 
PowerCase
Corsair CMPSU-430CXV2 Dell Dimension 2300 Case 
  hide details  
Reply
post #3 of 7
Thread Starter 
Quote:
Originally Posted by caffeinescandal;15364536 
If it doesnt work on another monitor, shouldnt it be that the video card dvi is dead and not the monitor? Do you have another video card to test your dvi input with?

My bad, I just noticed that I didn't phrase that correctly. When I plugged in another monitor via the DVI connection, it worked fine.
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
post #4 of 7
Thread Starter 
I checked the driver that windows is attempting to use for this monitor when connected via DVI, it is a Generic Non-PNP monitor driver dated all the way back to 2006. This looks odd since I definitely know that this monitor is PNP and shows up as LCM-22W3 when plugged in via vga.

Anybody know of an updated PNP monitor driver that I can download and force windows to use?
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
post #5 of 7
Thread Starter 
Bump.
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
post #6 of 7
Thread Starter 
After a bit of research I have been left with 4 options.

1. Continue running the monitor in VGA mode.
2. Get a new monitor.
3. Attempt to fix current monitor by replacing possible bad capacitors. I don't even know if this would do anything since the monitor still displays everything just fine in VGA mode.
4. Attempt to delete dvi input of current monitor from registry thus forcing windows to reinstall it when plugged in again. Problem with this solution though is I am unsure which registry key to delete since I have 8 keys displayed when looking under the "HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Video" directory.

If anybody is able to help me out with the registry edit, it would be greatly appreciated.
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
post #7 of 7
Thread Starter 
Just thought that I should say that I have solved the problem. It seems that AMD's 11.9 drivers somehow made my dvi port unusable. Everything displays as before with the 11.11 drivers that I just installed. So if anybody ever has similar issues, ROLLBACK OR UPDATE your drivers!
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
T3k
(13 items)
 
The Tibaldi
(9 items)
 
WooJoo
(13 items)
 
CPUMotherboardGraphicsGraphics
Intel i5 3210 h77 HD4000 GeForce 640 LE 
RAMHard DriveOSOS
4gb of something 5400rpm slowness 13.04 Ubuntu x64  Windows 8 Pro 
Monitor
1920x1080 
CPUMotherboardGraphicsRAM
965 BE 4.0GHZ (250 x 15.5) @1.5V m2n32 sli deluxe - 2000mhz @ 1.3V Asus TOP 5850 1GB 950/1200 Kingston HyperX 5-5-5-15 
Hard DriveOptical DriveOSMonitor
WD Velociraptor 150GB, WD raptor 74gb TDK 880N DVDRW Windows 7 x64 Ultimate Westinghouse 22" lcd 
KeyboardPowerCaseMouse
saitek eclipse II Corsair 620W modular Cooler Master ATCS 840 black emprex 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Monitors and Displays
Overclock.net › Forums › Components › Monitors and Displays › DVI input dead?