Overclock.net › Forums › AMD › AMD - General › My new msi 6950 isnt working!
New Posts  All Forums:Forum Nav:

My new msi 6950 isnt working!

post #1 of 9
Thread Starter 
Hello everyone, yesterday i bought an msi 6950 twin frozr III and it has highly disappointed me.
I was so happy to buy one but then its not working.
What happens:

I remove all my previous amd drivers or whatever i have so i that i make a clean install for it.
I install the latest driver from amd and once catalyst is installed along with the driver, it prompts to restart,so i do. Now, when i restart the welcome screen processes and after that its all black screen. Nothing comes after it. I waited for quite long but nothing happened. I tried everything,reinstalled windows(i'm using windows 7 64bit ultimate),check wiring and everything.
Also,i noticed that when i boot with the monitor connected to the 6950, i see irregularities in the letters that come up when we boot our systems(you know when it shows 8gb ram and all during boot). i also checked out bios settings,even there the letters are all wrong. Like a particular word would be like "advanced -se~tn" instead of "advanced settings" and this is for a lot of options that i see in the bios settings.
Now,when i take the 6950 out and connect it to the integrated graphic unit on my board,all the irregularities i mentioned in the bootup are gone and the system boots properly.
Is it possible that my graphic card is broken?

My specs:
Coolermaster 550gx
phenom IIx4 945
8gigs of ram
Gigabyte GA-880GM-UD2H

And i'm not sure if the psu should create any problems? What do you think?
post #2 of 9
While I didn't get the 6950, I did buy the GTX 560 Ti, and had numerous problems after three months. Long story short (and after two RMAs to the Manufacturer), I just requested a new replacement of the card.

Your best bet - write down as much info as you can (driver versions, hardware numbers, even the OS service park version). From there, the Support department will request that you update your BIOS (among other things).

Hopefully this will help you out.
2011 Workstation
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 860 MSI P55-GDR Sapphire HD 6970 2GB G-Skill 8GB 
Hard DriveOptical DriveOSMonitor
4x WD 750GB (Raid 0+1) LG lightscribe Windows 7 Home Premium 64bit Acer AL2216W x2 
KeyboardPowerCaseMouse
Microsoft ergonomics Corsair 750w Antec 902 Logitech MX815 
Mouse Pad
none 
  hide details  
Reply
2011 Workstation
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 860 MSI P55-GDR Sapphire HD 6970 2GB G-Skill 8GB 
Hard DriveOptical DriveOSMonitor
4x WD 750GB (Raid 0+1) LG lightscribe Windows 7 Home Premium 64bit Acer AL2216W x2 
KeyboardPowerCaseMouse
Microsoft ergonomics Corsair 750w Antec 902 Logitech MX815 
Mouse Pad
none 
  hide details  
Reply
post #3 of 9
It may be your psu, did you try and flash the bios?
post #4 of 9
Sounds very much like DOA or broken PCIe x16-slot
Main rig
(21 items)
 
Alienware M14x
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600k P8Z68-V PRO 2x HD 7970 16GB 1600 MHz 
Hard DriveHard DriveHard DriveCooling
180GB SSD 2TB Green spinpoint F3 1TB EK Supreme HF 
CoolingCoolingCoolingCooling
MCP355 2x Coolgate 240mm XSPC Dual-bay res Scythe Gentle Typhoon 
CoolingOSMonitorKeyboard
2x EK-FC7970 Windows 7 XL2410T Qpad MK-80 
PowerCaseMouseAudio
Corsair AX850 Corsair C70 Arctic White Steelseries Xai ASUS Xonar DX 
CPUMotherboardGraphicsGraphics
i7-3720QM Alienware M14x motherboard Nvidia Geforce GT 650M Intel HD Graphics 4000 
RAMHard DriveOptical DriveCooling
6GB 1600MHz CL11 Seagate momentus 500GB 7200RPM DVD Alienwarer M14x leafblower 
OSMonitorKeyboard
Windows 7 Home Premium 1600x900 Alienware bling 
  hide details  
Reply
Main rig
(21 items)
 
Alienware M14x
(11 items)
 
 
CPUMotherboardGraphicsRAM
i7-2600k P8Z68-V PRO 2x HD 7970 16GB 1600 MHz 
Hard DriveHard DriveHard DriveCooling
180GB SSD 2TB Green spinpoint F3 1TB EK Supreme HF 
CoolingCoolingCoolingCooling
MCP355 2x Coolgate 240mm XSPC Dual-bay res Scythe Gentle Typhoon 
CoolingOSMonitorKeyboard
2x EK-FC7970 Windows 7 XL2410T Qpad MK-80 
PowerCaseMouseAudio
Corsair AX850 Corsair C70 Arctic White Steelseries Xai ASUS Xonar DX 
CPUMotherboardGraphicsGraphics
i7-3720QM Alienware M14x motherboard Nvidia Geforce GT 650M Intel HD Graphics 4000 
RAMHard DriveOptical DriveCooling
6GB 1600MHz CL11 Seagate momentus 500GB 7200RPM DVD Alienwarer M14x leafblower 
OSMonitorKeyboard
Windows 7 Home Premium 1600x900 Alienware bling 
  hide details  
Reply
post #5 of 9
^ this or the guy above...what's your psu?
Hexacore Whore
(14 items)
 
  
CPUMotherboardGraphicsGraphics
1055t 125w @ 3.5 Gigabyte GA-890GPA UD3-H rev 1.0 F7c MSI R6950 PE OC Unlocked shaders MSI R6950 PE OC Locked shaders :( 
RAMOSMonitorKeyboard
G.Skill Ripjaw Blue 1.6v Win7 Ultimate 64bit LG 37LH3000 37" 1080P Havit Magic Eagle 
PowerCaseMouseMouse Pad
XFX XXX 650W Cooler Master Storm Scout Havit Magic Eagle Havit 
  hide details  
Reply
Hexacore Whore
(14 items)
 
  
CPUMotherboardGraphicsGraphics
1055t 125w @ 3.5 Gigabyte GA-890GPA UD3-H rev 1.0 F7c MSI R6950 PE OC Unlocked shaders MSI R6950 PE OC Locked shaders :( 
RAMOSMonitorKeyboard
G.Skill Ripjaw Blue 1.6v Win7 Ultimate 64bit LG 37LH3000 37" 1080P Havit Magic Eagle 
PowerCaseMouseMouse Pad
XFX XXX 650W Cooler Master Storm Scout Havit Magic Eagle Havit 
  hide details  
Reply
post #6 of 9
The MSI twin frozrs have had a list of issues in the past couple months, you likely just got yet another bad egg from the msi twin frozr lineup. There's been alot of RMA's done on them in recent months, it seems they let the popularity of the card get ahead of them and let the quality degrade to keep up with demand. Honestly, I'd return it if at all possible and go with another manufacturer for the time being.

Could also be your PSU like others have said though.
    
CPUMotherboardGraphicsRAM
i5-2500k Asrock Extreme 3 Gen 3 Z68 MSI R9 390 8GB Gskill Ripsaw 2x4GB 1600 Mhz 
Hard DriveHard DriveHard DriveOS
500GB 7200RPM 500GB 7200RPM Crucial M500 240GB SSD Windows 7 x64 
MonitorKeyboardPowerCase
22" 1680x1050 Razer Blackwidow Corsair TX650 V2 NZXT Phantom (Black) 
MouseMouse PadAudio
Logitech G9 Icemat V2 Eagle Tech ET-AR504LR-BK 2.1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k Asrock Extreme 3 Gen 3 Z68 MSI R9 390 8GB Gskill Ripsaw 2x4GB 1600 Mhz 
Hard DriveHard DriveHard DriveOS
500GB 7200RPM 500GB 7200RPM Crucial M500 240GB SSD Windows 7 x64 
MonitorKeyboardPowerCase
22" 1680x1050 Razer Blackwidow Corsair TX650 V2 NZXT Phantom (Black) 
MouseMouse PadAudio
Logitech G9 Icemat V2 Eagle Tech ET-AR504LR-BK 2.1 
  hide details  
Reply
post #7 of 9
don't say that i'm just about to buy one cos it fits!
Hexacore Whore
(14 items)
 
  
CPUMotherboardGraphicsGraphics
1055t 125w @ 3.5 Gigabyte GA-890GPA UD3-H rev 1.0 F7c MSI R6950 PE OC Unlocked shaders MSI R6950 PE OC Locked shaders :( 
RAMOSMonitorKeyboard
G.Skill Ripjaw Blue 1.6v Win7 Ultimate 64bit LG 37LH3000 37" 1080P Havit Magic Eagle 
PowerCaseMouseMouse Pad
XFX XXX 650W Cooler Master Storm Scout Havit Magic Eagle Havit 
  hide details  
Reply
Hexacore Whore
(14 items)
 
  
CPUMotherboardGraphicsGraphics
1055t 125w @ 3.5 Gigabyte GA-890GPA UD3-H rev 1.0 F7c MSI R6950 PE OC Unlocked shaders MSI R6950 PE OC Locked shaders :( 
RAMOSMonitorKeyboard
G.Skill Ripjaw Blue 1.6v Win7 Ultimate 64bit LG 37LH3000 37" 1080P Havit Magic Eagle 
PowerCaseMouseMouse Pad
XFX XXX 650W Cooler Master Storm Scout Havit Magic Eagle Havit 
  hide details  
Reply
post #8 of 9
Quote:
Originally Posted by Spacedinvader View Post
don't say that i'm just about to buy one cos it fits!
Well, feel free to do your own research haha. The earlier cards didn't have as many if really any issues, they just started having issues I'd say about 3 months ago. I'm not saying its a 100% chance to get a bad card, but there's definitely been a higher than normal failure rate lately and seems to be a coin toss whether you'll get one that's 100% or not.
    
CPUMotherboardGraphicsRAM
i5-2500k Asrock Extreme 3 Gen 3 Z68 MSI R9 390 8GB Gskill Ripsaw 2x4GB 1600 Mhz 
Hard DriveHard DriveHard DriveOS
500GB 7200RPM 500GB 7200RPM Crucial M500 240GB SSD Windows 7 x64 
MonitorKeyboardPowerCase
22" 1680x1050 Razer Blackwidow Corsair TX650 V2 NZXT Phantom (Black) 
MouseMouse PadAudio
Logitech G9 Icemat V2 Eagle Tech ET-AR504LR-BK 2.1 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k Asrock Extreme 3 Gen 3 Z68 MSI R9 390 8GB Gskill Ripsaw 2x4GB 1600 Mhz 
Hard DriveHard DriveHard DriveOS
500GB 7200RPM 500GB 7200RPM Crucial M500 240GB SSD Windows 7 x64 
MonitorKeyboardPowerCase
22" 1680x1050 Razer Blackwidow Corsair TX650 V2 NZXT Phantom (Black) 
MouseMouse PadAudio
Logitech G9 Icemat V2 Eagle Tech ET-AR504LR-BK 2.1 
  hide details  
Reply
post #9 of 9
that's the thing, i have researched...they were supposed to be the better ones with 2 phase power japanese caps two fanz twin frozrzrzr can unlox blahblahblah and it's 270mm long (plastic overhang on the card that can be chibbed off instead of doing the case)

don't care about the unlock (nice tho) just want the **** to fit!

edit: soz thread hijack
Hexacore Whore
(14 items)
 
  
CPUMotherboardGraphicsGraphics
1055t 125w @ 3.5 Gigabyte GA-890GPA UD3-H rev 1.0 F7c MSI R6950 PE OC Unlocked shaders MSI R6950 PE OC Locked shaders :( 
RAMOSMonitorKeyboard
G.Skill Ripjaw Blue 1.6v Win7 Ultimate 64bit LG 37LH3000 37" 1080P Havit Magic Eagle 
PowerCaseMouseMouse Pad
XFX XXX 650W Cooler Master Storm Scout Havit Magic Eagle Havit 
  hide details  
Reply
Hexacore Whore
(14 items)
 
  
CPUMotherboardGraphicsGraphics
1055t 125w @ 3.5 Gigabyte GA-890GPA UD3-H rev 1.0 F7c MSI R6950 PE OC Unlocked shaders MSI R6950 PE OC Locked shaders :( 
RAMOSMonitorKeyboard
G.Skill Ripjaw Blue 1.6v Win7 Ultimate 64bit LG 37LH3000 37" 1080P Havit Magic Eagle 
PowerCaseMouseMouse Pad
XFX XXX 650W Cooler Master Storm Scout Havit Magic Eagle Havit 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD - General
Overclock.net › Forums › AMD › AMD - General › My new msi 6950 isnt working!