Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire TOXIC HD-6950/70 Owners Club & Informational Thread
New Posts  All Forums:Forum Nav:

Sapphire TOXIC HD-6950/70 Owners Club & Informational Thread - Page 41

post #401 of 1649
Thank you.I just thought it wouldn't come back anymore. I am planning to buy it along with an 2500k, HAF 912, and an Asrock extreme 3 around cybermonday. Would there be a better sale during christmas? I am in no hurry due to my 4890 still running good with BF3 on medium settings.

Also, I dont think newegg allows you to be alerted while its deactivated. I dont see the option anymore whereas when out of stock, there was a option.
    
CPUMotherboardGraphicsRAM
i5 2500k Asrock Z68 extreme3 Gen3 ASUS 7970 DCII 2x4 G.Skill Sniper 
Hard DriveOSMonitorPower
m4 Windows 7 extreme VH23 OCZ ZT series 750w 
CaseAudio
Corsair White 500r HD 555 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 2500k Asrock Z68 extreme3 Gen3 ASUS 7970 DCII 2x4 G.Skill Sniper 
Hard DriveOSMonitorPower
m4 Windows 7 extreme VH23 OCZ ZT series 750w 
CaseAudio
Corsair White 500r HD 555 
  hide details  
Reply
post #402 of 1649
In my personal experience using the Newegg auto-notify function for the TOXIC HD6950, it didn't notify me before they were sold out... they go too fast. I have used auto-notify for many other products before, so this was a first... and it happened many times for this SKU, so I don't think that it was an annomoly.

Some others that are far more knowledgeable than me say that that they may not be making many more of these either, so get one now if you want one (...or another one for a cross-fire set-up...'-). Cheers! cheers.gif
Quote:
Originally Posted by mgrman View Post

If you set up your autonotify you should get one in time. They were in stock for about 4 or 5 hours today before they sold out. You could also check out the Dirt 3 Sapphire card. It supposedly has a great unlock rate also.
Trainwreck
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K (4.6G) ASUS ROG M4GZ Sapphire Toxic HD6950 2G Corsair Vengeance 16GB, Red/Black 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 3 VTX3 120G, WD 640G 7200RPM ASUS DVD Burner (SATA) Win7 Pro, 64bit (Bios 0902) Dell 2001FP 
KeyboardPowerCaseMouse
MX5500 Revolution (cordless, bluetooth) Corsair AX850 Fractal Arc Mini MX Revolution Laser 
  hide details  
Reply
Trainwreck
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K (4.6G) ASUS ROG M4GZ Sapphire Toxic HD6950 2G Corsair Vengeance 16GB, Red/Black 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 3 VTX3 120G, WD 640G 7200RPM ASUS DVD Burner (SATA) Win7 Pro, 64bit (Bios 0902) Dell 2001FP 
KeyboardPowerCaseMouse
MX5500 Revolution (cordless, bluetooth) Corsair AX850 Fractal Arc Mini MX Revolution Laser 
  hide details  
Reply
post #403 of 1649
So i just found out that you CAN'T RMA through newegg once you cut the UPC label for the Mail in rebate. I have to go through sapphire's rma process which will probably take freaking 2 weeks or even more. This will be the last time I'll buy an AMD/Sapphire product, should have just went with the GTX 570 EVGA without the rebate on newegg. The nvidia series is better with BF3, the game in which I mostly play. I guess you get what you pay for mad.gifmadsmiley.png
Edited by chrisys93 - 11/11/11 at 12:52pm
My PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x4 955 C3 Gigabyte GA-970-A-UD3 AM3+ Sapphire Toxic HD 6950 2GB  Kingston HyperX 8GB 
Hard DriveHard DriveOptical DriveCooling
Intel 520 120GB SSD  WD 500GB Caviar Black LiteOn DVD Burner Cooler Master 212 Evo Push/Pull 
OSMonitorKeyboardPower
Win 7 Home Premium x64 Asus VS238H LED 23" Microsoft Sidewinder X4 Corsair AX750W 
CaseMouseMouse Pad
Cooler Master HAF 932 Advanced Logitech G400 Razor Scarab 
  hide details  
Reply
My PC
(15 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x4 955 C3 Gigabyte GA-970-A-UD3 AM3+ Sapphire Toxic HD 6950 2GB  Kingston HyperX 8GB 
Hard DriveHard DriveOptical DriveCooling
Intel 520 120GB SSD  WD 500GB Caviar Black LiteOn DVD Burner Cooler Master 212 Evo Push/Pull 
OSMonitorKeyboardPower
Win 7 Home Premium x64 Asus VS238H LED 23" Microsoft Sidewinder X4 Corsair AX750W 
CaseMouseMouse Pad
Cooler Master HAF 932 Advanced Logitech G400 Razor Scarab 
  hide details  
Reply
post #404 of 1649
Thread Starter 
Quote:
Originally Posted by chrisys93 View Post

I guess you get what you pay for mad.gifmadsmiley.png

Yeah ... a great graphics card for the money ??? Why were you RMA'ing your card again ? for some screen flicker ?
Have you tried turning down your OC a little ? and/or are you running the CCC Overdrive to kick the PowerTune up +20% ?

Also I know it might sound basic but be sure the ends of your cable connections are clean and secure, I read one person had green dots on his screen because he had dirt/dust build up inside the end of his cable from it sitting around unplugged to anything for so long before he used it.

Anyways if something is seriously wrong with your card and you do RMA it, try talking Sapphire into an ADVANCE RMA, meaning they send you a replacement while you're sending them your old card, they might have to give you the 6970 if they are low stocked on TOXIC's like they claim. It might not work ... but worth asking them about it.


Edited by LA_Kings_Fan - 11/11/11 at 5:02pm
   
LG/Google NEXUS 5
(10 items)
 
CPUMotherboardGraphicsRAM
Q9650 Yorkfield Quad-Core Asus IPIBL-LB (HP Benicia-GL8E) Sapphire TOXIC HD6950 {UnLocked 1536 shaders} 8 GB G. Skill Pi Black DDR2 
Hard DriveOptical DriveCoolingOS
SeaGate Barracuda 1TB 32MB Cache HP - DVD/CD combo Drive Cooler Master  MS Vista Home Premium 64 bit 
MonitorKeyboardPowerCase
HP w2207h Widescreen HP Stock BFG Tech LS-680 HP Pavilion 
Mouse
HP stock 
CPUMotherboardGraphicsRAM
Quad Core Krait 400 @ 2.30GHz  Qualcomm MSM8974(Snapdragon 800) Adreno 330 2GB LPDDR3-1600 
Hard DriveOSMonitorKeyboard
32GB NAND Android 4.4 Kitkat 4.95" 1080X1920 IPS Display Swiftkey 
PowerAudio
2300 mAh Battery Stereo Speakers 
  hide details  
Reply
   
LG/Google NEXUS 5
(10 items)
 
CPUMotherboardGraphicsRAM
Q9650 Yorkfield Quad-Core Asus IPIBL-LB (HP Benicia-GL8E) Sapphire TOXIC HD6950 {UnLocked 1536 shaders} 8 GB G. Skill Pi Black DDR2 
Hard DriveOptical DriveCoolingOS
SeaGate Barracuda 1TB 32MB Cache HP - DVD/CD combo Drive Cooler Master  MS Vista Home Premium 64 bit 
MonitorKeyboardPowerCase
HP w2207h Widescreen HP Stock BFG Tech LS-680 HP Pavilion 
Mouse
HP stock 
CPUMotherboardGraphicsRAM
Quad Core Krait 400 @ 2.30GHz  Qualcomm MSM8974(Snapdragon 800) Adreno 330 2GB LPDDR3-1600 
Hard DriveOSMonitorKeyboard
32GB NAND Android 4.4 Kitkat 4.95" 1080X1920 IPS Display Swiftkey 
PowerAudio
2300 mAh Battery Stereo Speakers 
  hide details  
Reply
post #405 of 1649
So I just installed my new PSU and the second GPU and I am having problems with Trixx's custom fan profile not being applied to both cards. Also, one of the cards' Power Tune setting keeps getting reset from +50 to 0 in CCC. Anyone know how to remedy these issues? IMG00658.jpg 470k .jpg file
Bottleneck
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 (3.4GHz) Gigabyte GA-EP45-UD3P Sapphire 6950 Toxic CrossFireX (Unlocked 925/1400) OCZ Reaper HPC Edition 4GB 
Hard DriveOptical DriveOSMonitor
WD Caviar Black WD6401AALS Samsung Windows 7 Professional 64bit HP w2207 
KeyboardPowerCaseMouse
Logitech Cordless Corsair AX850 Antec Logitech G7 
Mouse Pad
Func Industries Surface 1030 
  hide details  
Reply
Bottleneck
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 (3.4GHz) Gigabyte GA-EP45-UD3P Sapphire 6950 Toxic CrossFireX (Unlocked 925/1400) OCZ Reaper HPC Edition 4GB 
Hard DriveOptical DriveOSMonitor
WD Caviar Black WD6401AALS Samsung Windows 7 Professional 64bit HP w2207 
KeyboardPowerCaseMouse
Logitech Cordless Corsair AX850 Antec Logitech G7 
Mouse Pad
Func Industries Surface 1030 
  hide details  
Reply
post #406 of 1649
After doing some research, I decided to continue using Trixx for controlling the clock speeds and MSI Afterburner for the fan profile.

Everything works great, both cards are synchronized on the same custom fan profile and the overclocks are applied to both cards as well.
Bottleneck
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 (3.4GHz) Gigabyte GA-EP45-UD3P Sapphire 6950 Toxic CrossFireX (Unlocked 925/1400) OCZ Reaper HPC Edition 4GB 
Hard DriveOptical DriveOSMonitor
WD Caviar Black WD6401AALS Samsung Windows 7 Professional 64bit HP w2207 
KeyboardPowerCaseMouse
Logitech Cordless Corsair AX850 Antec Logitech G7 
Mouse Pad
Func Industries Surface 1030 
  hide details  
Reply
Bottleneck
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q6600 (3.4GHz) Gigabyte GA-EP45-UD3P Sapphire 6950 Toxic CrossFireX (Unlocked 925/1400) OCZ Reaper HPC Edition 4GB 
Hard DriveOptical DriveOSMonitor
WD Caviar Black WD6401AALS Samsung Windows 7 Professional 64bit HP w2207 
KeyboardPowerCaseMouse
Logitech Cordless Corsair AX850 Antec Logitech G7 
Mouse Pad
Func Industries Surface 1030 
  hide details  
Reply
post #407 of 1649
Finally decided to create an account here and ask you 6950 experts a question of my own. I just built a computer last week and i chose Toxic 6950 as my video card. But i've been having one problem after another.
My card is flashed and i have set the power control to 50% and i have the 11.10 preview driver installed (for Rage). After setting the power control to 20% for the first time, my card was idling at core clock 250 and loading at 880. But for some reason i noticed today while playing Skyrim my card was at 725. I just set the power control to 50% and it seems like the core clock is fluctuating. sometimes at 250 then 880 then 500 etc etc. (this is during normal usage). At this moment, while i'm typing this, i have furmark running and the clock is running at 880 steady.
what is happening?? is this normal??
Thanks for everyone's time and hopefully you guys can help me solve my card problem once and for all.

note: please excuse my bad grammar. it is 3am in the morning and i've had a long day...

Cheers!
post #408 of 1649
Quote:
Originally Posted by to505 View Post

Finally decided to create an account here and ask you 6950 experts a question of my own. I just built a computer last week and i chose Toxic 6950 as my video card. But i've been having one problem after another.
My card is flashed and i have set the power control to 50% and i have the 11.10 preview driver installed (for Rage). After setting the power control to 20% for the first time, my card was idling at core clock 250 and loading at 880. But for some reason i noticed today while playing Skyrim my card was at 725. I just set the power control to 50% and it seems like the core clock is fluctuating. sometimes at 250 then 880 then 500 etc etc. (this is during normal usage). At this moment, while i'm typing this, i have furmark running and the clock is running at 880 steady.
what is happening?? is this normal??
Thanks for everyone's time and hopefully you guys can help me solve my card problem once and for all.
note: please excuse my bad grammar. it is 3am in the morning and i've had a long day...
Cheers!

you have 11.10 preview drivers installed? you know the final drivers are out now right? i had a terrible experience with those preview drivers...

if your clocks are running at full speed throughout furmark then i would assume things are ok because that pushes the graphics card hard all the way through. +20% appeared to be enough for mine to run at full clock speeds all the way through furmark as before it was barely hitting 700Mhz on the gpu clock.

I haven't monitored my clock speeds while gaming but they may underclock at points in the game if the graphics card isn't having to work hard, like when you're in the menu screens or something. Do you know at which points it underclocks?
post #409 of 1649
Thanks for the response!!
But after a few uninstall> driver sweep> install routine, when i finally got Rage to play without those horrible screen tearings i kept it at that version. Mayybe i should try uninstalling again and install the new version... would using the AMD's update utility be fine? or should i go and dl from amd's site?
i used GPUz to log the sensors and throughout my whole Skyrim gameplay (about 2-3 hours) it was at 725 the whole time..I am running it at everything maxed out and a few tweaks in the .ini even.... so i'm pretty sure the game will use up 100% of my card most of the time. Although everything still runs fine (a few hiccups here and there, but that could just be the game is a little buggy), i'm still bothered at the fact that my card is only at 725 core clock...

But aside from my card clocking in at 725 (fluctuates), this card is a monster! I haven't even overclock it myself and it runs Skyrim at everything maxed smoothly. i know it's overclocked already but the fact that i am reading the success rate of pushing it even higher is just remarkable. Although i'm not planning to overclock it anytime soon... with my luck i think i should just go with "if it works, don't break it" motto....

Again, thanks for everyone's time. Really appreciate it!
post #410 of 1649
Quote:
Originally Posted by to505 View Post

Thanks for the response!!
But after a few uninstall> driver sweep> install routine, when i finally got Rage to play without those horrible screen tearings i kept it at that version. Mayybe i should try uninstalling again and install the new version... would using the AMD's update utility be fine? or should i go and dl from amd's site?
i used GPUz to log the sensors and throughout my whole Skyrim gameplay (about 2-3 hours) it was at 725 the whole time..I am running it at everything maxed out and a few tweaks in the .ini even.... so i'm pretty sure the game will use up 100% of my card most of the time. Although everything still runs fine (a few hiccups here and there, but that could just be the game is a little buggy), i'm still bothered at the fact that my card is only at 725 core clock...
But aside from my card clocking in at 725 (fluctuates), this card is a monster! I haven't even overclock it myself and it runs Skyrim at everything maxed smoothly. i know it's overclocked already but the fact that i am reading the success rate of pushing it even higher is just remarkable. Although i'm not planning to overclock it anytime soon... with my luck i think i should just go with "if it works, don't break it" motto....
Again, thanks for everyone's time. Really appreciate it!

well maybe you are better with that driver then. i dont tend to use the amd update utility personally because it doesn't do anything you cant do with a few clicks and i often find it doesn't even get the latest drivers.

if upping power control isn't doing it for you then im not sure why the gpu is underclocking... could be lack of power from your psu. what psu do you have? actually if you wouldn't mind posting your whole setup so i can see how you're running skyrim at max settings? biggrin.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire TOXIC HD-6950/70 Owners Club & Informational Thread