Overclock.net › Forums › Graphics Cards › NVIDIA › Triple Buffering not working BF3??
New Posts  All Forums:Forum Nav:

Triple Buffering not working BF3??

post #1 of 4
Thread Starter 
I have vsync and triple buffer both forced to be on through nvidia control panel.

When I am playing my GPU usage is only about 80% and I get frame drops from 60 down to around 53 and its driving me insane. If I turn off triple buffer i dont notice any increase in performance.. it pretty much stays the same. If i turn Vsync off I get about 75-80 fps.

Why is this happening?
Game Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-2700k @ 5Ghz  ASUS P8Z68-v Gen 3 GTX 1070 X 16GB Corsair Vengeance  
Hard DriveHard DriveOptical DriveCooling
3x Samsung Spinpoint F3 1TB Crucial M4 128GB Asus DVD drive H100 
OSMonitorKeyboardPower
Windows 7 professional Samsung 27" LCD 1080p Ducky Shine (MX brown) AX850 
CaseMouseMouse PadAudio
Corsair 600T SE White Logitech mx518 Steelseries QCK+ ASUS Xonar DX 
Audio
BeyerDynamics DT770 Pro 80 ohm 
  hide details  
Reply
Game Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-2700k @ 5Ghz  ASUS P8Z68-v Gen 3 GTX 1070 X 16GB Corsair Vengeance  
Hard DriveHard DriveOptical DriveCooling
3x Samsung Spinpoint F3 1TB Crucial M4 128GB Asus DVD drive H100 
OSMonitorKeyboardPower
Windows 7 professional Samsung 27" LCD 1080p Ducky Shine (MX brown) AX850 
CaseMouseMouse PadAudio
Corsair 600T SE White Logitech mx518 Steelseries QCK+ ASUS Xonar DX 
Audio
BeyerDynamics DT770 Pro 80 ohm 
  hide details  
Reply
post #2 of 4
Perfectly normal, Vsync capping at 60FPS to prevent screen tearing. Disable forced settings through display drivers, and leave to in-game/app prefs.
 
Alienware 13
(10 items)
 
Alienware Alpha
(6 items)
 
CPUMotherboardGraphicsRAM
Intel i7 4770k @4.0Ghz MSI Z87 G65 EVGA 980Ti Classified+EVGA 660SC PhysX G.Skill Trident X 16GB @2400Mhz 
Hard DriveCoolingOSMonitor
Corsair 480GB+1TB WD Black Corsair H100 W10 Pro|Start10 U2713HM+U22 LED+ACz1 Mount 
KeyboardPowerCaseMouse
RealForce 87U 55g  Corsair HX1050 Corsair 650D Razer DeathAdder+Firefly 
Audio
STX+SP2500, Asgard 2+HD650 
CPUGraphicsRAMHard Drive
Intel i7 6500U nVidia GTX 960m OC Samsung 16GB 1.35v M.2 850 EVO 500GB+1TB WD 
OSMonitorKeyboard
W10|Start 10 IPS 4k, Touch Alienware FX 
CPUGraphicsRAMHard Drive
Intel i7 4785T @3.2Ghz 8MB nVidia 860m OC vBIOS mod HyperX Impact 16GB DDR3 256GB Samsung SSD+1TB HDD 
OSAudio
W10|Start 10 DragonFly v1.2 
  hide details  
Reply
 
Alienware 13
(10 items)
 
Alienware Alpha
(6 items)
 
CPUMotherboardGraphicsRAM
Intel i7 4770k @4.0Ghz MSI Z87 G65 EVGA 980Ti Classified+EVGA 660SC PhysX G.Skill Trident X 16GB @2400Mhz 
Hard DriveCoolingOSMonitor
Corsair 480GB+1TB WD Black Corsair H100 W10 Pro|Start10 U2713HM+U22 LED+ACz1 Mount 
KeyboardPowerCaseMouse
RealForce 87U 55g  Corsair HX1050 Corsair 650D Razer DeathAdder+Firefly 
Audio
STX+SP2500, Asgard 2+HD650 
CPUGraphicsRAMHard Drive
Intel i7 6500U nVidia GTX 960m OC Samsung 16GB 1.35v M.2 850 EVO 500GB+1TB WD 
OSMonitorKeyboard
W10|Start 10 IPS 4k, Touch Alienware FX 
CPUGraphicsRAMHard Drive
Intel i7 4785T @3.2Ghz 8MB nVidia 860m OC vBIOS mod HyperX Impact 16GB DDR3 256GB Samsung SSD+1TB HDD 
OSAudio
W10|Start 10 DragonFly v1.2 
  hide details  
Reply
post #3 of 4
Thread Starter 
so its normal to drop down to 53 fps when only using 80 percent of GPU? .. ... for some reason i thought triple buffer would make it use 99 percent to keep me at 60 constantly.
Edited by Ratjack - 10/26/11 at 12:05am
Game Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-2700k @ 5Ghz  ASUS P8Z68-v Gen 3 GTX 1070 X 16GB Corsair Vengeance  
Hard DriveHard DriveOptical DriveCooling
3x Samsung Spinpoint F3 1TB Crucial M4 128GB Asus DVD drive H100 
OSMonitorKeyboardPower
Windows 7 professional Samsung 27" LCD 1080p Ducky Shine (MX brown) AX850 
CaseMouseMouse PadAudio
Corsair 600T SE White Logitech mx518 Steelseries QCK+ ASUS Xonar DX 
Audio
BeyerDynamics DT770 Pro 80 ohm 
  hide details  
Reply
Game Rig
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-2700k @ 5Ghz  ASUS P8Z68-v Gen 3 GTX 1070 X 16GB Corsair Vengeance  
Hard DriveHard DriveOptical DriveCooling
3x Samsung Spinpoint F3 1TB Crucial M4 128GB Asus DVD drive H100 
OSMonitorKeyboardPower
Windows 7 professional Samsung 27" LCD 1080p Ducky Shine (MX brown) AX850 
CaseMouseMouse PadAudio
Corsair 600T SE White Logitech mx518 Steelseries QCK+ ASUS Xonar DX 
Audio
BeyerDynamics DT770 Pro 80 ohm 
  hide details  
Reply
post #4 of 4
Quote:
Originally Posted by Ratjack View Post
so its normal to drop down to 53 fps when only using 80 percent of GPU? .. ... for some reason i though triple buffer would make it use 99 percent to keep me at 60 constantly.
Nope, (triple buffering)doesn't work that way. Forcing to render X frames ahead of output often leads to issues because different engines have different/specific command queues/rendering methods. Even at 80%, with an alt-tab method of checking GPU usage can lead to skewed measurements..(OS caching of background programs) A more accurate method if determining GPU activity would be to log to a txt file, and check results thereafter.
Edited by Blindrage606 - 10/26/11 at 12:12am
 
Alienware 13
(10 items)
 
Alienware Alpha
(6 items)
 
CPUMotherboardGraphicsRAM
Intel i7 4770k @4.0Ghz MSI Z87 G65 EVGA 980Ti Classified+EVGA 660SC PhysX G.Skill Trident X 16GB @2400Mhz 
Hard DriveCoolingOSMonitor
Corsair 480GB+1TB WD Black Corsair H100 W10 Pro|Start10 U2713HM+U22 LED+ACz1 Mount 
KeyboardPowerCaseMouse
RealForce 87U 55g  Corsair HX1050 Corsair 650D Razer DeathAdder+Firefly 
Audio
STX+SP2500, Asgard 2+HD650 
CPUGraphicsRAMHard Drive
Intel i7 6500U nVidia GTX 960m OC Samsung 16GB 1.35v M.2 850 EVO 500GB+1TB WD 
OSMonitorKeyboard
W10|Start 10 IPS 4k, Touch Alienware FX 
CPUGraphicsRAMHard Drive
Intel i7 4785T @3.2Ghz 8MB nVidia 860m OC vBIOS mod HyperX Impact 16GB DDR3 256GB Samsung SSD+1TB HDD 
OSAudio
W10|Start 10 DragonFly v1.2 
  hide details  
Reply
 
Alienware 13
(10 items)
 
Alienware Alpha
(6 items)
 
CPUMotherboardGraphicsRAM
Intel i7 4770k @4.0Ghz MSI Z87 G65 EVGA 980Ti Classified+EVGA 660SC PhysX G.Skill Trident X 16GB @2400Mhz 
Hard DriveCoolingOSMonitor
Corsair 480GB+1TB WD Black Corsair H100 W10 Pro|Start10 U2713HM+U22 LED+ACz1 Mount 
KeyboardPowerCaseMouse
RealForce 87U 55g  Corsair HX1050 Corsair 650D Razer DeathAdder+Firefly 
Audio
STX+SP2500, Asgard 2+HD650 
CPUGraphicsRAMHard Drive
Intel i7 6500U nVidia GTX 960m OC Samsung 16GB 1.35v M.2 850 EVO 500GB+1TB WD 
OSMonitorKeyboard
W10|Start 10 IPS 4k, Touch Alienware FX 
CPUGraphicsRAMHard Drive
Intel i7 4785T @3.2Ghz 8MB nVidia 860m OC vBIOS mod HyperX Impact 16GB DDR3 256GB Samsung SSD+1TB HDD 
OSAudio
W10|Start 10 DragonFly v1.2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Triple Buffering not working BF3??