Overclock.net › Forums › Components › Sound Cards and Computer Audio › SB X-Fi series Support Pack 2.5 (10/25/2011)
New Posts  All Forums:Forum Nav:

SB X-Fi series Support Pack 2.5 (10/25/2011) - Page 3

post #21 of 31
they wouldn't install for me, kept saying the hardware wasn't detected. :*(
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
post #22 of 31
Quote:
Originally Posted by mtbiker033 View Post

they wouldn't install for me, kept saying the hardware wasn't detected. :*(

Let Windows install it's driver for it from Windows Update. Then it will work. I had the same problem with my Titanium.
Hephaestus
(22 items)
 
  
CPUMotherboardGraphicsGraphics
Core i5 2500K [4.5Ghz][100x45][1.29v] MSi P67A-GD65 [1.9 BIOS] MSi GTX670 PE OC MSi GTX670 PE OC 
RAMHard DriveHard DriveHard Drive
16GB Corsair Vengeance 1600Mhz [9-9-9-24] Crucial M4 256GB [CORE] WD Caviar Black 1TB [FILEZ] WD Caviar Black 2TB [GAMEZ] 
Optical DriveCoolingOSMonitor
LG Blu-Ray Combo Corsair H50 [Push/Pull][UltraKaze 3Ks] Windows 7 Ultimate x64 Retail SP1 Yamakasi Catleap Q270 27" S-IPS 
KeyboardPowerCaseMouse
Logitech G110 Antec TP-750 Blue Lian Li Lancool PC-K62 Razer Naga Epic 
Mouse PadAudioAudioAudio
Razer Goliathus Fragger Speed  X-Fi Titanium Logitech z5300 5.1 Logitech G930 
OtherOther
MS LifeCam Studio 1080p Belkin n52te 
  hide details  
Reply
Hephaestus
(22 items)
 
  
CPUMotherboardGraphicsGraphics
Core i5 2500K [4.5Ghz][100x45][1.29v] MSi P67A-GD65 [1.9 BIOS] MSi GTX670 PE OC MSi GTX670 PE OC 
RAMHard DriveHard DriveHard Drive
16GB Corsair Vengeance 1600Mhz [9-9-9-24] Crucial M4 256GB [CORE] WD Caviar Black 1TB [FILEZ] WD Caviar Black 2TB [GAMEZ] 
Optical DriveCoolingOSMonitor
LG Blu-Ray Combo Corsair H50 [Push/Pull][UltraKaze 3Ks] Windows 7 Ultimate x64 Retail SP1 Yamakasi Catleap Q270 27" S-IPS 
KeyboardPowerCaseMouse
Logitech G110 Antec TP-750 Blue Lian Li Lancool PC-K62 Razer Naga Epic 
Mouse PadAudioAudioAudio
Razer Goliathus Fragger Speed  X-Fi Titanium Logitech z5300 5.1 Logitech G930 
OtherOther
MS LifeCam Studio 1080p Belkin n52te 
  hide details  
Reply
post #23 of 31
Quote:
Originally Posted by Demented View Post

Let Windows install it's driver for it from Windows Update. Then it will work. I had the same problem with my Titanium.

oh ok so uninstall driver, reboot, let windows do its thing then install daniel k's pack, will try! thanks!
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
post #24 of 31
Quote:
Originally Posted by mtbiker033 View Post

oh ok so uninstall driver, reboot, let windows do its thing then install daniel k's pack, will try! thanks!

The titanium HD isn't supported in this pack. Just go to creative's site and install the latest beta.
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77X-UD5H MSI TF3 7950 Tri-fire Samsung 30nm 4x4GB 
Hard DriveOSMonitorKeyboard
Intel 320 160GB and a few samsung platters Windows7 x64 Catleap Q270 Rosewill mechanical 
PowerCaseMouseMouse Pad
Corsair AX850 Xigmatek Elysium Razer Deathadder Puretrak talent 
Audio
Xonar Essence STX 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77X-UD5H MSI TF3 7950 Tri-fire Samsung 30nm 4x4GB 
Hard DriveOSMonitorKeyboard
Intel 320 160GB and a few samsung platters Windows7 x64 Catleap Q270 Rosewill mechanical 
PowerCaseMouseMouse Pad
Corsair AX850 Xigmatek Elysium Razer Deathadder Puretrak talent 
Audio
Xonar Essence STX 
  hide details  
Reply
post #25 of 31
Quote:
Originally Posted by BababooeyHTJ View Post

The titanium HD isn't supported in this pack. Just go to creative's site and install the latest beta.

I did just that and am listening to music right now, sounds pretty good to me! thanks!thumb.gif
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
post #26 of 31
Quote:
Originally Posted by mtbiker033 View Post

I did just that and am listening to music right now, sounds pretty good to me! thanks!thumb.gif

Can you get away with setting Windows to 5.1 without losing any audio quality with your card? For some reason my card was giving me crap at 44.1 and 48khz at 5.1 but was fine at 96khz., I'm assuming that it was a software issue.
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77X-UD5H MSI TF3 7950 Tri-fire Samsung 30nm 4x4GB 
Hard DriveOSMonitorKeyboard
Intel 320 160GB and a few samsung platters Windows7 x64 Catleap Q270 Rosewill mechanical 
PowerCaseMouseMouse Pad
Corsair AX850 Xigmatek Elysium Razer Deathadder Puretrak talent 
Audio
Xonar Essence STX 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77X-UD5H MSI TF3 7950 Tri-fire Samsung 30nm 4x4GB 
Hard DriveOSMonitorKeyboard
Intel 320 160GB and a few samsung platters Windows7 x64 Catleap Q270 Rosewill mechanical 
PowerCaseMouseMouse Pad
Corsair AX850 Xigmatek Elysium Razer Deathadder Puretrak talent 
Audio
Xonar Essence STX 
  hide details  
Reply
post #27 of 31
Out of curiosity does this ever get updated regularly? I've been poking around to try an official website for these drivers/pack and I can't seem to find anything that is up to date really. I believe the link in the OP has a really old set of drivers/pack.
post #28 of 31
No, he just updates it whenever he feels like it. The latest official X-fi drivers are over a year old.
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77X-UD5H MSI TF3 7950 Tri-fire Samsung 30nm 4x4GB 
Hard DriveOSMonitorKeyboard
Intel 320 160GB and a few samsung platters Windows7 x64 Catleap Q270 Rosewill mechanical 
PowerCaseMouseMouse Pad
Corsair AX850 Xigmatek Elysium Razer Deathadder Puretrak talent 
Audio
Xonar Essence STX 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k Gigabyte Z77X-UD5H MSI TF3 7950 Tri-fire Samsung 30nm 4x4GB 
Hard DriveOSMonitorKeyboard
Intel 320 160GB and a few samsung platters Windows7 x64 Catleap Q270 Rosewill mechanical 
PowerCaseMouseMouse Pad
Corsair AX850 Xigmatek Elysium Razer Deathadder Puretrak talent 
Audio
Xonar Essence STX 
  hide details  
Reply
post #29 of 31
Hello everyone.

I have X-fi Titanium about 2 weeks and have a problem with sound on 5.1 creative speakers. I've tried many drivers including pack 2.5 and newer what I found. I was trying everything I guess. Uninstall all drivers and then install new one, install under save mode, update with creative web page updater - still the same problem.
The test is fine, speakers are good, cables are good - nothing is broken.
The test is working but to play any music with players or web - only front speakers working.

what is the solution ? before i was using Audigy SB so I think i know how to set up everything smile.gif

Thanks for any help !
post #30 of 31
Quote:
Originally Posted by sacrum View Post

Hello everyone.
I have X-fi Titanium about 2 weeks and have a problem with sound on 5.1 creative speakers. I've tried many drivers including pack 2.5 and newer what I found. I was trying everything I guess. Uninstall all drivers and then install new one, install under save mode, update with creative web page updater - still the same problem.
The test is fine, speakers are good, cables are good - nothing is broken.
The test is working but to play any music with players or web - only front speakers working.
what is the solution ? before i was using Audigy SB so I think i know how to set up everything smile.gif
Thanks for any help !

Sounds like it is a setting in your Operating system sound setup. Open Control panel and click on sound and make sure your speakers are set to the default sound device.
The HedgeHog
(15 items)
 
  
CPUMotherboardGraphicsRAM
3770K Z77-UP7 MSI GTX 680 Twin 4 Gig G.Skill Trident X 2600's and some Dom's Hypers 
Hard DriveCoolingOSMonitor
Yes, lots of them. LN2  The smallest one I can get! Samsung 2333 HD 23" 
PowerCaseMouseMouse Pad
Corisar 1200 AX=1.21 jigawatts Fractal Design/Dimastech G5 Rocketfish 
  hide details  
Reply
The HedgeHog
(15 items)
 
  
CPUMotherboardGraphicsRAM
3770K Z77-UP7 MSI GTX 680 Twin 4 Gig G.Skill Trident X 2600's and some Dom's Hypers 
Hard DriveCoolingOSMonitor
Yes, lots of them. LN2  The smallest one I can get! Samsung 2333 HD 23" 
PowerCaseMouseMouse Pad
Corisar 1200 AX=1.21 jigawatts Fractal Design/Dimastech G5 Rocketfish 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › SB X-Fi series Support Pack 2.5 (10/25/2011)