Overclock.net › Forums › Video Games › PC Gaming › Source games: No "High Shadows" Setting
New Posts  All Forums:Forum Nav:

Source games: No "High Shadows" Setting

post #1 of 11
Thread Starter 
Only on my laptop does it give me this problem. CSS, and all the HL2 series, I can max everything out fine without a hiccup. But when I go to the video settings, under Shadows, there is only Low and Medium. High doesn't show up. All my drivers as well as DirectX are up to date. What could be the problem? I have never found a fix online and was hoping someone here might know.

Laptop:

i5 2410M (2.3-2.9GHz)
6GB RAM
750GB
Nvidia GeForce GT 540M (1GB OC'd 730 core)
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
post #2 of 11
Throw these in an autoexec:
Code:
mat_shadowstate"2"
r_shadows "1"
r_shadowmaxrendered "999"
r_shadowrendertotexture "1"

If you don't have an autoexec, put this file in \Steam\steamapps\username\counter-strike source\cstrike\cfg\
Code:
http://www.mediafire.com/file/jlloic9xw5etu3d/autoexec.cfg
2600k
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.7 1.38V and climbing ASrock Extreme4 Gen3 GTX 580 DCII 8gb g.skil ripjaws x @1600 
Hard DriveOptical DriveOSMonitor
crucial m4 120 ssd + WD 500 gb Lite-On DVDR-DL Windows 7 x64 Viewsonic vx2268wm 
KeyboardPowerCaseMouse
Microsoft Comfort Curve Seasonic X-750 HAF X Logitech g400 
Mouse Pad
Steelseries QCK+ 
  hide details  
Reply
2600k
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.7 1.38V and climbing ASrock Extreme4 Gen3 GTX 580 DCII 8gb g.skil ripjaws x @1600 
Hard DriveOptical DriveOSMonitor
crucial m4 120 ssd + WD 500 gb Lite-On DVDR-DL Windows 7 x64 Viewsonic vx2268wm 
KeyboardPowerCaseMouse
Microsoft Comfort Curve Seasonic X-750 HAF X Logitech g400 
Mouse Pad
Steelseries QCK+ 
  hide details  
Reply
post #3 of 11
Thread Starter 
Alright thanks! I'll give it a try in a bit!
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
post #4 of 11
Are you running DX95 in game? mat_dxlevel to check your DirectX in game. Sounds to me like you're running DirectX8 in game which is why the option is not showing up.

If that turns out to be that case, type in console mat_dxlevel 95. Should be able to set your shadows to high now.
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
post #5 of 11
Hardly any difference between the Shadow Quality tbh. Yep, you might be running on DX8, check if it is in DirectX 9 mode.
    
CPUMotherboardGraphicsRAM
i5 6500 @ stock MSI H110i Pro AC Asus GTX 1070 Gaming Strix OC 16Gb DDR4 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
1Tb Hitachi 5400RPM 2.5" HDD Intel 540s 240Gb SSD Noctua L9i Windows 10 Home Premium 
MonitorKeyboardPowerCase
PX2370 Filco Ninja Brown Switches Silverstone 500W SFX-L Gold Silverstone RVZ02 (Non-Windowed) 
MouseAudio
Razer DeathAdder Chroma Bose Companion II 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 6500 @ stock MSI H110i Pro AC Asus GTX 1070 Gaming Strix OC 16Gb DDR4 Corsair Vengeance 
Hard DriveHard DriveCoolingOS
1Tb Hitachi 5400RPM 2.5" HDD Intel 540s 240Gb SSD Noctua L9i Windows 10 Home Premium 
MonitorKeyboardPowerCase
PX2370 Filco Ninja Brown Switches Silverstone 500W SFX-L Gold Silverstone RVZ02 (Non-Windowed) 
MouseAudio
Razer DeathAdder Chroma Bose Companion II 
  hide details  
Reply
post #6 of 11
Thread Starter 
Quote:
Originally Posted by dmasteR;15494459 
Are you running DX95 in game? mat_dxlevel to check your DirectX in game. Sounds to me like you're running DirectX8 in game which is why the option is not showing up.

If that turns out to be that case, type in console mat_dxlevel 95. Should be able to set your shadows to high now.
Quote:
Originally Posted by sloppyjoe123;15494477 
Hardly any difference between the Shadow Quality tbh. Yep, you might be running on DX8, check if it is in DirectX 9 mode.

It says in the video options DX9 but I'll run the command to see.
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
post #7 of 11
Thread Starter 
Ran the mat_dxlevel code. Said it was 90 so I changed it to 95, screen flashed, went to video options, still medium. Restarted to the game to check and still medium. I'll try out that config a couple posts above tho.
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
post #8 of 11
Quote:
Originally Posted by XanderDylan;15498696 
Ran the mat_dxlevel code. Said it was 90 so I changed it to 95, screen flashed, went to video options, still medium. Restarted to the game to check and still medium. I'll try out that config a couple posts above tho.


After it restarted, when you type mat_dxlevel does it still say 95 or 90? You might need to put it into your launch command. -dxlevel 95 in launch commands, launch game and check. If all is good then when you exit the game make sure you take it out of your launch commands.
Quote:
r_flashlightdepthtexture 1
r_shadowrendertotexture 1


Works as well to get the High options for Shadows.
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
^_^
(13 items)
 
   
CPUMotherboardGraphicsRAM
Intel 2600K ASRock Z68 EXTREME4 GEN3 Gigabyte Windforce 7970 OC Mushkin Enhanced Blackline 8GB (2 x 4GB) 
CoolingMonitorPowerCase
Noctua D14 Asus VG248QE Corsair TX 750 V2 Corsair 650D 
MouseMouse PadAudioAudio
G400, MX518, G500, G5, IMO 1.1, IME 3.0, Deatha... fUnC 1030, QCK+, QCK Heavy, PureTrak Talent Whi... X-Fi Titanium HD Sennheiser HD555 
CPUGraphicsRAMHard Drive
Intel i7 2.4GHz Intel HD 4000 8GB 256GB SSD 
Monitor
2880 x 1800 Retina 
  hide details  
Reply
post #9 of 11
Quote:
Originally Posted by XanderDylan;15498696 
Ran the mat_dxlevel code. Said it was 90 so I changed it to 95, screen flashed, went to video options, still medium. Restarted to the game to check and still medium. I'll try out that config a couple posts above tho.

Since you have a dx10 capable card, you should use the new dxlevel 98 switch. Flashbangs are even shorter with this setting...

Just add the line mat_dxlevel 98 to the autoexec I posted above, or right click css from within steam, go to properties and set launch options then put
Code:
-dxlevel 98
2600k
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.7 1.38V and climbing ASrock Extreme4 Gen3 GTX 580 DCII 8gb g.skil ripjaws x @1600 
Hard DriveOptical DriveOSMonitor
crucial m4 120 ssd + WD 500 gb Lite-On DVDR-DL Windows 7 x64 Viewsonic vx2268wm 
KeyboardPowerCaseMouse
Microsoft Comfort Curve Seasonic X-750 HAF X Logitech g400 
Mouse Pad
Steelseries QCK+ 
  hide details  
Reply
2600k
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.7 1.38V and climbing ASrock Extreme4 Gen3 GTX 580 DCII 8gb g.skil ripjaws x @1600 
Hard DriveOptical DriveOSMonitor
crucial m4 120 ssd + WD 500 gb Lite-On DVDR-DL Windows 7 x64 Viewsonic vx2268wm 
KeyboardPowerCaseMouse
Microsoft Comfort Curve Seasonic X-750 HAF X Logitech g400 
Mouse Pad
Steelseries QCK+ 
  hide details  
Reply
post #10 of 11
Thread Starter 
Quote:
Originally Posted by dmasteR;15500995 
After it restarted, when you type mat_dxlevel does it still say 95 or 90? You might need to put it into your launch command. -dxlevel 95 in launch commands, launch game and check. If all is good then when you exit the game make sure you take it out of your launch commands.

Okay I'll give it a shot.


Works as well to get the High options for Shadows.
Yeah I think that one will work too. I'll try that one first.
Quote:
Originally Posted by SEVINN;15504239 
Since you have a dx10 capable card, you should use the new dxlevel 98 switch. Flashbangs are even shorter with this setting...

Just add the line mat_dxlevel 98 to the autoexec I posted above, or right click css from within steam, go to properties and set launch options then put
Code:
-dxlevel 98

Technically, it's DX11 capable but Source games are 9-10 anyways. Alright if the first two ideas dont work I'll try that one as well.

Thank you all for the help so far.
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
Main Rig (ITX)
(11 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-4790k ASUS H97I-PLUS EVGA GeForce GTX 980 Ti FTW Corsair Vengeance DDR3 1600 2 x 4GB 
Hard DriveHard DriveHard DriveOS
Sandisk Z400s Seagate Barracuda 1TB 7200RPM 64MB Cache Seagate Barracuda 2TB 7200 RPM 64MB Cache Windows 10 Pro 
PowerCaseAudio
EVGA 600B Corsair Obsidian 250D M-Audio Mobile Pre 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Source games: No "High Shadows" Setting