Overclock.net › Forums › Video Games › PC Gaming › BF3 crashes on startup.
New Posts  All Forums:Forum Nav:

BF3 crashes on startup.

post #1 of 10
Thread Starter 
When I start the game, bf3.exe crashes and displays the message "The procedure entry point CreateDXGIFactory1 could not be located in the dynamic link library dxgi.dll". Anyone else have this problem, and anyone know how to fix it?
15" rMPB
(7 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-2820QM Intel Iris Pro DDR3-1600 PCIe Solid State Drive 
OSMonitorAudio
Mac OS X 10.9.4 Mavericks 2880x1800 15" Retina Display Focusrite 2i2 -> Beyerdynamic T50p 
  hide details  
Reply
15" rMPB
(7 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-2820QM Intel Iris Pro DDR3-1600 PCIe Solid State Drive 
OSMonitorAudio
Mac OS X 10.9.4 Mavericks 2880x1800 15" Retina Display Focusrite 2i2 -> Beyerdynamic T50p 
  hide details  
Reply
post #2 of 10
Have you tried uninstalling, restarting comp, and re-installing? Just have to be sure tongue.gif
Verktøy Cu
(20 items)
 
XForma MBX MKII
(18 items)
 
 
CPUCPUMotherboardGraphics
Intel Xeon E5-2670 V4 Intel Xeon E5-2670 V4 Asus Z10PE-D8 WS Nvidia Titan X 
GraphicsGraphicsGraphicsRAM
Nvidia Titan X Nvidia Titan X Nvidia Titan X 128GB of Kingston DDR4 ECC 2133Mhz 
Hard DriveHard DriveHard DriveHard Drive
Intel 750 NVME 1.2TB U.2 Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC 
CoolingOSMonitorKeyboard
EK Water Blocks Windows 10 Pro Dell UP2715K Cherry MX 6.0 
PowerCaseMouseAudio
Corsair AX1500i Case Labs S8 Logitech MX Master Pioneer SE-L40 
CPUMotherboardGraphicsGraphics
Intel 5960X Asus Rampage V Extreme Nvidia Titan X Nvidia Titan X 
GraphicsRAMHard DriveHard Drive
Nvidia Titan X Corsair Dominator Platinum 4x8GB 2400Mhz (2) Intel 530 180GB (2) HGST 4TB 
Optical DriveCoolingOSMonitor
Blu-Ray Slot Load EK Water Blocks Liquid Cooling Windows 8.1 Dell UP2715K 
KeyboardPowerCaseMouse
Ducky OCN Blues Seasonic 1200W Platinum XForma MBX MKII TBD 
AudioAudio
Asus Xonar Essence One (2) Mackie MR5MK2 
  hide details  
Reply
Verktøy Cu
(20 items)
 
XForma MBX MKII
(18 items)
 
 
CPUCPUMotherboardGraphics
Intel Xeon E5-2670 V4 Intel Xeon E5-2670 V4 Asus Z10PE-D8 WS Nvidia Titan X 
GraphicsGraphicsGraphicsRAM
Nvidia Titan X Nvidia Titan X Nvidia Titan X 128GB of Kingston DDR4 ECC 2133Mhz 
Hard DriveHard DriveHard DriveHard Drive
Intel 750 NVME 1.2TB U.2 Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC Intel 750 NVME 1.2TB AIC 
CoolingOSMonitorKeyboard
EK Water Blocks Windows 10 Pro Dell UP2715K Cherry MX 6.0 
PowerCaseMouseAudio
Corsair AX1500i Case Labs S8 Logitech MX Master Pioneer SE-L40 
CPUMotherboardGraphicsGraphics
Intel 5960X Asus Rampage V Extreme Nvidia Titan X Nvidia Titan X 
GraphicsRAMHard DriveHard Drive
Nvidia Titan X Corsair Dominator Platinum 4x8GB 2400Mhz (2) Intel 530 180GB (2) HGST 4TB 
Optical DriveCoolingOSMonitor
Blu-Ray Slot Load EK Water Blocks Liquid Cooling Windows 8.1 Dell UP2715K 
KeyboardPowerCaseMouse
Ducky OCN Blues Seasonic 1200W Platinum XForma MBX MKII TBD 
AudioAudio
Asus Xonar Essence One (2) Mackie MR5MK2 
  hide details  
Reply
post #3 of 10
Thread Starter 
Quote:
Originally Posted by derickwm;15498905 
Have you tried uninstalling, restarting comp, and re-installing? Just have to be sure tongue.gif

I'll give that a shot.
15" rMPB
(7 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-2820QM Intel Iris Pro DDR3-1600 PCIe Solid State Drive 
OSMonitorAudio
Mac OS X 10.9.4 Mavericks 2880x1800 15" Retina Display Focusrite 2i2 -> Beyerdynamic T50p 
  hide details  
Reply
15" rMPB
(7 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-2820QM Intel Iris Pro DDR3-1600 PCIe Solid State Drive 
OSMonitorAudio
Mac OS X 10.9.4 Mavericks 2880x1800 15" Retina Display Focusrite 2i2 -> Beyerdynamic T50p 
  hide details  
Reply
post #4 of 10
I'd right click the game icon in Origin, and try doing a repair smile.gif
I Like Smileys :)
(16 items)
 
Sony Vaio 1512
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 4.6GHz Asus P8P67 Pro Bios 3207 MSI GTX 970 GAMING 4G Ripjaws-X 16GB 1600MHz 
Hard DriveHard DriveOptical DriveCooling
80GB Intel & 128GB 830  2 x WD640 Caviar Black LG DVD-RW Noctua NH-D14  
OSMonitorKeyboardPower
Windows 7 HP 64bit Acer 5906x1080 3D Logitech G15 Corsair TX850W 
CaseMouseMouse PadAudio
Antec Dark Fleet DF-85 Logitec G700 Razer Goliathus Sharkoon X-Tatic 5.1 Headset 
CPUMotherboardGraphicsRAM
Intel® Core™ i5-3210M Laptop  HD 4000 Corsair Vengeance 8GB  
Hard DriveOptical DriveOSMonitor
Samsung 840 250GB DVD Multi Windows 8 15.5 inch display (1366 x 768) 
Keyboard
LED Back lit 
  hide details  
Reply
I Like Smileys :)
(16 items)
 
Sony Vaio 1512
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 4.6GHz Asus P8P67 Pro Bios 3207 MSI GTX 970 GAMING 4G Ripjaws-X 16GB 1600MHz 
Hard DriveHard DriveOptical DriveCooling
80GB Intel & 128GB 830  2 x WD640 Caviar Black LG DVD-RW Noctua NH-D14  
OSMonitorKeyboardPower
Windows 7 HP 64bit Acer 5906x1080 3D Logitech G15 Corsair TX850W 
CaseMouseMouse PadAudio
Antec Dark Fleet DF-85 Logitec G700 Razer Goliathus Sharkoon X-Tatic 5.1 Headset 
CPUMotherboardGraphicsRAM
Intel® Core™ i5-3210M Laptop  HD 4000 Corsair Vengeance 8GB  
Hard DriveOptical DriveOSMonitor
Samsung 840 250GB DVD Multi Windows 8 15.5 inch display (1366 x 768) 
Keyboard
LED Back lit 
  hide details  
Reply
post #5 of 10
Are you running any OSD programs, like Afterburner's or ATI tray tools OSD features? Any overlay I have tried to use crashes the game before I can get past the first loading animation screen. Any program that shows FPS/GPU usage/temps, etc. Only one that I have gotten to work and not crash is Fraps and that is just for frames per second. I miss not having all my other info up in the corner. Hopefully they can fix this soon.
post #6 of 10
●๑۩۩๑●
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.4GHz (1.34v) Gigabyte P67A-UD4-B3 Gigabyte GTX 470 SOC @ 825MHz 4GB Corsair Vengeance DDR3 1600MHz (CL8) 
Hard DriveCoolingOSMonitor
Samsung Spinpoint F3 1TB Cooler Master Hyper N520 Windows 7 Ultimate x64 SP1 ASUS VH236H 23" 1080p | 2ms 
PowerCaseAudio
Corsair TX650w (V1) Xigmatek Utgard X-Fi Titanium Fatal1ty 
  hide details  
Reply
●๑۩۩๑●
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.4GHz (1.34v) Gigabyte P67A-UD4-B3 Gigabyte GTX 470 SOC @ 825MHz 4GB Corsair Vengeance DDR3 1600MHz (CL8) 
Hard DriveCoolingOSMonitor
Samsung Spinpoint F3 1TB Cooler Master Hyper N520 Windows 7 Ultimate x64 SP1 ASUS VH236H 23" 1080p | 2ms 
PowerCaseAudio
Corsair TX650w (V1) Xigmatek Utgard X-Fi Titanium Fatal1ty 
  hide details  
Reply
post #7 of 10
Sounds like a DirectX problem. Try updating to the latest DirectX Runtime.
    
CPUMotherboardGraphicsRAM
[ Q6600 2.4GHz ] [ ASUS P5K ] [ Radeon HD5830 ] [ 4GB 800MHz ] 
Hard DriveOptical DriveOSMonitor
[ WD 500GB SATA ] [ DVD Burner/Reader 16x ] [ W7 Ultimate x64 ] [ Viewsonic 19" ] 
KeyboardPowerCaseMouse
Microsoft [ 600W ] [ Antec 900 ] Microsoft 
Mouse Pad
Desk 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[ Q6600 2.4GHz ] [ ASUS P5K ] [ Radeon HD5830 ] [ 4GB 800MHz ] 
Hard DriveOptical DriveOSMonitor
[ WD 500GB SATA ] [ DVD Burner/Reader 16x ] [ W7 Ultimate x64 ] [ Viewsonic 19" ] 
KeyboardPowerCaseMouse
Microsoft [ 600W ] [ Antec 900 ] Microsoft 
Mouse Pad
Desk 
  hide details  
Reply
post #8 of 10
I have the digital DL copy installed and have no issue with Afterburner.

Stock clocks are 800/1600/2048 V1.025. OC to 850/1700/2100 with V1.050.
My First Build
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7-860 2.8/OC'ed 3.60 FPO/batch # L935B730 Asus P7P55d Evo MSI 580 TF II OC 8 Gig Corsiar DDR3 1600 XMP 
Hard DriveOptical DriveCoolingOS
WD Black 750 Samsung H50, pull/push Win7 Pro 64 
MonitorKeyboardPowerCase
HP 2509B 25" 1920x1080 Steelseries backlit Merc Corsiar TX650 Thermatake V9 Black 
MouseAudio
Rat 7 Asus Xonar DG 
  hide details  
Reply
My First Build
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7-860 2.8/OC'ed 3.60 FPO/batch # L935B730 Asus P7P55d Evo MSI 580 TF II OC 8 Gig Corsiar DDR3 1600 XMP 
Hard DriveOptical DriveCoolingOS
WD Black 750 Samsung H50, pull/push Win7 Pro 64 
MonitorKeyboardPowerCase
HP 2509B 25" 1920x1080 Steelseries backlit Merc Corsiar TX650 Thermatake V9 Black 
MouseAudio
Rat 7 Asus Xonar DG 
  hide details  
Reply
post #9 of 10
Thread Starter 
Reinstalled BF3, updated DirectX, still nothing.
15" rMPB
(7 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-2820QM Intel Iris Pro DDR3-1600 PCIe Solid State Drive 
OSMonitorAudio
Mac OS X 10.9.4 Mavericks 2880x1800 15" Retina Display Focusrite 2i2 -> Beyerdynamic T50p 
  hide details  
Reply
15" rMPB
(7 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7-2820QM Intel Iris Pro DDR3-1600 PCIe Solid State Drive 
OSMonitorAudio
Mac OS X 10.9.4 Mavericks 2880x1800 15" Retina Display Focusrite 2i2 -> Beyerdynamic T50p 
  hide details  
Reply
post #10 of 10
ive had no p[rob using afterburning running in the background
Gaming Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 975 GA-990FXA-UD5 Radeon HD 7950 Corsair Vengence Blue 
Hard DriveOptical DriveCoolingOS
Seagate 500GB 3.5" SATA-III 6Gb/s DVD RW Corsair H100 Win 7 Home Premium 64Bit 
MonitorKeyboardPowerCase
Dell U2312HM Cheap XFX 750w black edition Coolermaster CM II Advanced 
MouseMouse PadAudioAudio
Cyborg RAT 7 None Tritton PC510 HDa Asus Xonar DX 
  hide details  
Reply
Gaming Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 975 GA-990FXA-UD5 Radeon HD 7950 Corsair Vengence Blue 
Hard DriveOptical DriveCoolingOS
Seagate 500GB 3.5" SATA-III 6Gb/s DVD RW Corsair H100 Win 7 Home Premium 64Bit 
MonitorKeyboardPowerCase
Dell U2312HM Cheap XFX 750w black edition Coolermaster CM II Advanced 
MouseMouse PadAudioAudio
Cyborg RAT 7 None Tritton PC510 HDa Asus Xonar DX 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › BF3 crashes on startup.