Overclock.net › Forums › Components › Hard Drives & Storage › HDD Smart Warning Conflict - Dying Drive or Software Glitch?
New Posts  All Forums:Forum Nav:

HDD Smart Warning Conflict - Dying Drive or Software Glitch?

post #1 of 6
Thread Starter 
I think my program/OS drive (WD 1002FAEX 1TB SATA 6GB/s) is starting to go bad, but I'm getting conflicting results.

HDTune gives me a Reallaocated Sector Count warning (05 & C4), and even worse, a Current Pending Sector count (C5) warning



Crystal DiskInfo gives me the same warnings, though there's NO C4 warning and the data value for Current Sector Pending count is 11 vs. 17 for HDTune.



The drive passes the WD Data Life Guard Diagnostics Quick Test (SMART Test) even though it does show the one Reallocated Sector. There's no warning for Current Pending Sector count (value = 0).



I ran a sector scan check with HDTune...twice The first time it showed 3 or 4 bad sectors right at the end of the scan before my OS locked up at 99% done. That could have been my fault since I tied to hotswap a back up HDD for cloning once I saw those "bad sectors." I re-ran the test and this time no bad sectors were found. I then ran ran WD Data LifeGuard's "Long Test" (sector scan) and the drive passed as well. No bad sectors

Overall the drive runs okay though it does seem a bit slower recently. I do have the occasional software glitches, but that's mostly either IE or one game which could easily be cause by overtaxing my very soon to be replaced video card.

What's going on??? Could the fact I have the drive connected to a SATA 6GB/s port somehow cause bad readings from HDTune & Crystal DiskInfo, or is WD Data LG software not that good/accurate?

Normally I would RMA the drive since it's still under warranty. However, I've already RMA'd it once before (severe vibrations) and with the HDD shortage, I'm not sure how willing WD will be to RMA when the drive passes both Data LifeGuard Tests.

Any advice?
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2700k @ 4.5Ghz (HT on) MSI Z77A-GD65 EVGA GTX 580 Classified 3GB @ 920Mhz G.Skill Ripjaws 16GB DDR3 @ 2133Mhz 
Hard DriveHard DriveHard DriveCooling
Crucial M4 SSD 256GB (OS) WD Caviar Black 2TB (Data) 2x Samsung F4EG 2TB (Data) Thermalright Archon 2x140mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit Dell U3011 Logitech G710+ mechanical keyboard Corsair HX850 
CaseAudio
Silverstone Fortress FT02 Asus Xonar Essence STX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2700k @ 4.5Ghz (HT on) MSI Z77A-GD65 EVGA GTX 580 Classified 3GB @ 920Mhz G.Skill Ripjaws 16GB DDR3 @ 2133Mhz 
Hard DriveHard DriveHard DriveCooling
Crucial M4 SSD 256GB (OS) WD Caviar Black 2TB (Data) 2x Samsung F4EG 2TB (Data) Thermalright Archon 2x140mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit Dell U3011 Logitech G710+ mechanical keyboard Corsair HX850 
CaseAudio
Silverstone Fortress FT02 Asus Xonar Essence STX 
  hide details  
Reply
post #2 of 6
you could try running the long test (WD Data Life Guard Diagnostics). and see if it comes up with anything the quick test didn't.
but that takes a long time, not to mention it puts more stress on your already failing drive.
make sure to backup all data ASAP if you haven't already.
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
Daily Workhorse
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670K MSI Z87-GD65 Asus GTX 660 DC2-OC  G.Skill RipjawsX 4x4GB 1600 
Hard DriveOptical DriveCoolingOS
OCZ Agility 60GB none Noctua NH-U12P Windows 8 
MonitorKeyboardPowerCase
Dell U2312HM CoolerMaster Quick Fire CMStorm Red Corsair 650HX Lian Li PC-K9WX 
MouseAudio
Logitech G400 Creative X-Fi HD USB 
  hide details  
Reply
post #3 of 6
If your drive is still under warantee back up your data elsewhere and run the WD diagnostics (long test). Yes, it may take up to 3/4 hours with that 1tb drive but it will pick up on any bad sectors opposed to the quick test.

Once you start getting bad sector's it could go quickly downhill or, it may never. Rma it while you can.
My CM sniper
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8ghz @ 1.4v. ASRock Z68 EXTREME4 GEN3 EVGA gtx470 SC GSKILL SNIPER DDR3 1600 2X4 9.9.9.24 
Hard DriveOptical DriveOSMonitor
CRUCIAL 64GB SSD 1-VR300 4X F3 1TB SAMSUNG 22X SATA DVD BURNER WINDOWZ 7 64BIT 23'' ACER P235H WS 
KeyboardPowerCaseMouse
LOGITECH G15 V 2007 CORSAIR TX750 CM STORM SNIPER/ MODDED OCZ DOMINATRIX 
Mouse PadAudio
ALL OVER THE TABLE ON BOARD 
  hide details  
Reply
My CM sniper
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8ghz @ 1.4v. ASRock Z68 EXTREME4 GEN3 EVGA gtx470 SC GSKILL SNIPER DDR3 1600 2X4 9.9.9.24 
Hard DriveOptical DriveOSMonitor
CRUCIAL 64GB SSD 1-VR300 4X F3 1TB SAMSUNG 22X SATA DVD BURNER WINDOWZ 7 64BIT 23'' ACER P235H WS 
KeyboardPowerCaseMouse
LOGITECH G15 V 2007 CORSAIR TX750 CM STORM SNIPER/ MODDED OCZ DOMINATRIX 
Mouse PadAudio
ALL OVER THE TABLE ON BOARD 
  hide details  
Reply
post #4 of 6
Thread Starter 
Thanks for the replies. FWIW I did run the WD long test after I re-ran the HDTune sector test and the drive passed. I know it takes a long time - I spent 9 hours alone yesterday running HDTune's sector test twice plus the WD Data LG long test.

Summary:

- Warnings from HDTune and Crystal DiskInfo per above
- WD short test = pass/no warnings though it did show one reallocated sector if I'm readling it right.
- 1st run HDTune sector scan (crash at 99% done) had 3 or 4 bad blocks right before my PC locked up
- 2nd run HDTune sector scan = pass (no bad blocks)
- WD long test = pass (no bad sectors).

I'll re-run the WD long test again I guess, but I just don't understand why HDTune and Crystal DiskInfo give off warnings when WD Data LifeGaurd diagnostics show nothing wrong.

I guess I'll clone the drive as well. I've been moving data off, but even if I dont lose any data, it takes me...gah 15-20 hours to clean install Win 7 64 along with all my software and adjust settings.
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2700k @ 4.5Ghz (HT on) MSI Z77A-GD65 EVGA GTX 580 Classified 3GB @ 920Mhz G.Skill Ripjaws 16GB DDR3 @ 2133Mhz 
Hard DriveHard DriveHard DriveCooling
Crucial M4 SSD 256GB (OS) WD Caviar Black 2TB (Data) 2x Samsung F4EG 2TB (Data) Thermalright Archon 2x140mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit Dell U3011 Logitech G710+ mechanical keyboard Corsair HX850 
CaseAudio
Silverstone Fortress FT02 Asus Xonar Essence STX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2700k @ 4.5Ghz (HT on) MSI Z77A-GD65 EVGA GTX 580 Classified 3GB @ 920Mhz G.Skill Ripjaws 16GB DDR3 @ 2133Mhz 
Hard DriveHard DriveHard DriveCooling
Crucial M4 SSD 256GB (OS) WD Caviar Black 2TB (Data) 2x Samsung F4EG 2TB (Data) Thermalright Archon 2x140mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit Dell U3011 Logitech G710+ mechanical keyboard Corsair HX850 
CaseAudio
Silverstone Fortress FT02 Asus Xonar Essence STX 
  hide details  
Reply
post #5 of 6
WD drives die slowly, so you don't have to panic yet. But you should trust HDTune's results.

I'm guessing the drive detected the bad sectors and remapped them internally, which is why they are no longer showing up. Keep an eye on that SMART info - if any of those warnings start going up (Data column) then you have to act on it.
     
CPUMotherboardGraphicsRAM
FX-8350 @ 4.6ghz 1.425v Sabertooth 990FX Zotac GTX 1070 Amp! 32GB (4x8GB) Kingston Fury 1866mhz CL10 1T 1.5v 
Hard DriveHard DriveHard DriveHard Drive
Hitachi 2TB - HDS723020BLA64 Crucial M500 960GB - CT960M500SSD1 WD 4TB Black - WD4001FAEX WD 4TB Black - WD4001FAEX 
Hard DriveHard DriveHard DriveHard Drive
Seagate 2TB - ST2000DM001 WD 640GB Black - WD6401AALS Seagate 6TB - ST6000DM001 Micron M500 - MTFDDAK480MAV 
Optical DriveOptical DriveOptical DriveOptical Drive
Pioneer DVR-115DBK Samsung SH-S243D/BEBE LG GH22NS90 Lite-On EBAU108 External DVD 
CoolingCoolingCoolingOS
Noctua NH-D15 Fractal Design 140mm Fan - FD-FAN-140 Fractal Design 120mm Fan - FD-FAN-120 Windows 7 
OSMonitorMonitorKeyboard
Ubuntu 14.04 LTS Samsung 2343BWX 23" (2048x1152) BenQ GW2765HT 27" IPS LCD Monitor (2560x1440) Genius Keyboard KB-G235 PA 
PowerCaseMouseMouse Pad
Seasonic Platinum 1000w PSU - SS-1000XP Fractal Design Define R5 Steelseries Rival 6500 dcpi Mousepad + Desk 
AudioAudioOtherOther
Onboard Realtek® ALC 892 Cyber Acoustics CA-2992 2.0 Speakers Razer Krait 1600 DPI nGear G-C1601 Card Reader 
OtherOther
Pisen Card Reader Gigabyte M7 Thor 
CPUMotherboardGraphicsRAM
VIA Eden C7 1200mhz Jetway J7F4K1G2ES-LF VIA Onboard 512MB PC2-4200 
Hard DriveOptical DriveCoolingOS
A-Data FlashDrive None Fanless Linux 
MonitorKeyboardPowerCase
Headless None 65w Power Brick Antec ISK300-65 
MouseAudio
None Onboard VIA 
CPUMotherboardGraphicsRAM
Barton XP-M 2400+ FJQ4C Asus A7N8X-E Deluxe 256MB BFG 7800GS OC 2x512MB Samsung PC3200 
Hard DriveOSMonitorKeyboard
Raptor 74GB/Seagate 120GB Windows 2000 Pro 60hz 17" CRT Brandless PS2 Keyboard 
PowerMouse
Antec Neo HE 550w Logitech G5 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
FX-8350 @ 4.6ghz 1.425v Sabertooth 990FX Zotac GTX 1070 Amp! 32GB (4x8GB) Kingston Fury 1866mhz CL10 1T 1.5v 
Hard DriveHard DriveHard DriveHard Drive
Hitachi 2TB - HDS723020BLA64 Crucial M500 960GB - CT960M500SSD1 WD 4TB Black - WD4001FAEX WD 4TB Black - WD4001FAEX 
Hard DriveHard DriveHard DriveHard Drive
Seagate 2TB - ST2000DM001 WD 640GB Black - WD6401AALS Seagate 6TB - ST6000DM001 Micron M500 - MTFDDAK480MAV 
Optical DriveOptical DriveOptical DriveOptical Drive
Pioneer DVR-115DBK Samsung SH-S243D/BEBE LG GH22NS90 Lite-On EBAU108 External DVD 
CoolingCoolingCoolingOS
Noctua NH-D15 Fractal Design 140mm Fan - FD-FAN-140 Fractal Design 120mm Fan - FD-FAN-120 Windows 7 
OSMonitorMonitorKeyboard
Ubuntu 14.04 LTS Samsung 2343BWX 23" (2048x1152) BenQ GW2765HT 27" IPS LCD Monitor (2560x1440) Genius Keyboard KB-G235 PA 
PowerCaseMouseMouse Pad
Seasonic Platinum 1000w PSU - SS-1000XP Fractal Design Define R5 Steelseries Rival 6500 dcpi Mousepad + Desk 
AudioAudioOtherOther
Onboard Realtek® ALC 892 Cyber Acoustics CA-2992 2.0 Speakers Razer Krait 1600 DPI nGear G-C1601 Card Reader 
OtherOther
Pisen Card Reader Gigabyte M7 Thor 
CPUMotherboardGraphicsRAM
VIA Eden C7 1200mhz Jetway J7F4K1G2ES-LF VIA Onboard 512MB PC2-4200 
Hard DriveOptical DriveCoolingOS
A-Data FlashDrive None Fanless Linux 
MonitorKeyboardPowerCase
Headless None 65w Power Brick Antec ISK300-65 
MouseAudio
None Onboard VIA 
CPUMotherboardGraphicsRAM
Barton XP-M 2400+ FJQ4C Asus A7N8X-E Deluxe 256MB BFG 7800GS OC 2x512MB Samsung PC3200 
Hard DriveOSMonitorKeyboard
Raptor 74GB/Seagate 120GB Windows 2000 Pro 60hz 17" CRT Brandless PS2 Keyboard 
PowerMouse
Antec Neo HE 550w Logitech G5 
  hide details  
Reply
post #6 of 6
Thread Starter 
Quote:
Originally Posted by Kramy View Post
WD drives die slowly, so you don't have to panic yet. But you should trust HDTune's results.

I'm guessing the drive detected the bad sectors and remapped them internally, which is why they are no longer showing up. Keep an eye on that SMART info - if any of those warnings start going up (Data column) then you have to act on it.
Thanks for the reply. That's good advice. *sigh* It's such a frustrating situation. I just wish there was some consistancy with all the readings. I did another HDTune sector scan last night & no bad sectors. I kind of wish it would just die (after I've backed up everything of course) rather than this slow quasi death.

I'll run one more WD Long Test (sector scan) tonight and keep working on transfering/back up stuff as clone or work on a clean install bit by bit.
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2700k @ 4.5Ghz (HT on) MSI Z77A-GD65 EVGA GTX 580 Classified 3GB @ 920Mhz G.Skill Ripjaws 16GB DDR3 @ 2133Mhz 
Hard DriveHard DriveHard DriveCooling
Crucial M4 SSD 256GB (OS) WD Caviar Black 2TB (Data) 2x Samsung F4EG 2TB (Data) Thermalright Archon 2x140mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit Dell U3011 Logitech G710+ mechanical keyboard Corsair HX850 
CaseAudio
Silverstone Fortress FT02 Asus Xonar Essence STX 
  hide details  
Reply
My System
(17 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 2700k @ 4.5Ghz (HT on) MSI Z77A-GD65 EVGA GTX 580 Classified 3GB @ 920Mhz G.Skill Ripjaws 16GB DDR3 @ 2133Mhz 
Hard DriveHard DriveHard DriveCooling
Crucial M4 SSD 256GB (OS) WD Caviar Black 2TB (Data) 2x Samsung F4EG 2TB (Data) Thermalright Archon 2x140mm 
OSMonitorKeyboardPower
Windows 7 Ultimate 64bit Dell U3011 Logitech G710+ mechanical keyboard Corsair HX850 
CaseAudio
Silverstone Fortress FT02 Asus Xonar Essence STX 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › HDD Smart Warning Conflict - Dying Drive or Software Glitch?