Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › AMD/ATI site not working properly atm?
New Posts  All Forums:Forum Nav:

AMD/ATI site not working properly atm?

post #1 of 5
Thread Starter 
Hi guys, since last night i have been trying to get past this page but whenever i enter all the details needed and click the "Display Results" button it doesnt do anything? I have tried on Firefox and IE on both my laptop and main computer. Anyone else noticed??
My Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.8 1.256v Asus P6tD Deluxe ATI 5870 12GB Corsair 1600MHz DDR3 
Hard DriveHard DriveOptical DriveCooling
Samsung EVO 500GB 1TB + 500GB HDD LG Bluray Writer + DVD RW Noctua u12p 
OSMonitorKeyboardPower
Windows 10 64Bit Dell u2711 Blackwidow Ultimate EVGA Supernova G2 650w 
CaseMouseAudio
Coolermaster HAF 932 Deathadder 3500dpi KRK Rokit RP6 
  hide details  
Reply
My Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.8 1.256v Asus P6tD Deluxe ATI 5870 12GB Corsair 1600MHz DDR3 
Hard DriveHard DriveOptical DriveCooling
Samsung EVO 500GB 1TB + 500GB HDD LG Bluray Writer + DVD RW Noctua u12p 
OSMonitorKeyboardPower
Windows 10 64Bit Dell u2711 Blackwidow Ultimate EVGA Supernova G2 650w 
CaseMouseAudio
Coolermaster HAF 932 Deathadder 3500dpi KRK Rokit RP6 
  hide details  
Reply
post #2 of 5
Noticed just now. Maybe they are changing something again. Using Chrome, btw.
Oxygène
(15 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen 5 1600 MSI B350 Tomahawk Arctic VTX3D R9 390 8GB G.Skill Ripjaws  
Hard DriveHard DriveHard DriveHard Drive
Kingston Hyper X Kingston HyperX Fury ADATA SP550 ADATA SX8000 
CoolingOSMonitorKeyboard
Noctua NH-D15 SE-AM4 Windows 10 Dell U2711 Microsoft WK 800 
PowerCaseMouse
Chieftec A-135 Series 1000W NZXT. Phantom 410 Microsoft WM 1000 
  hide details  
Reply
Oxygène
(15 items)
 
  
CPUMotherboardGraphicsRAM
Ryzen 5 1600 MSI B350 Tomahawk Arctic VTX3D R9 390 8GB G.Skill Ripjaws  
Hard DriveHard DriveHard DriveHard Drive
Kingston Hyper X Kingston HyperX Fury ADATA SP550 ADATA SX8000 
CoolingOSMonitorKeyboard
Noctua NH-D15 SE-AM4 Windows 10 Dell U2711 Microsoft WK 800 
PowerCaseMouse
Chieftec A-135 Series 1000W NZXT. Phantom 410 Microsoft WM 1000 
  hide details  
Reply
post #3 of 5
Yeah the site is sluggish.
post #4 of 5
Yeah something is up.

This guy is having problems too.

http://www.overclock.net/amd-ati/115...ti-driver.html
    
CPUMotherboardGraphicsRAM
Xeon E5-1680 V2  R4BE  TITAN X (Pascal)   2666 Dominator Platinum CL10 
Hard DriveCoolingCoolingOS
750 NVMe 1.2TB EK HF/rx360/rx120 EK FC/GTs/mcp655 Windows 10 Pro  
MonitorPowerCaseAudio
BL3200PT 1600 T2 800d Pro Audio 2.1 + DragonFly Red 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Xeon E5-1680 V2  R4BE  TITAN X (Pascal)   2666 Dominator Platinum CL10 
Hard DriveCoolingCoolingOS
750 NVMe 1.2TB EK HF/rx360/rx120 EK FC/GTs/mcp655 Windows 10 Pro  
MonitorPowerCaseAudio
BL3200PT 1600 T2 800d Pro Audio 2.1 + DragonFly Red 
  hide details  
Reply
post #5 of 5
Thread Starter 
Ok thought so guys. I didnt see the other thread already made so sorry about creating a new one.
My Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.8 1.256v Asus P6tD Deluxe ATI 5870 12GB Corsair 1600MHz DDR3 
Hard DriveHard DriveOptical DriveCooling
Samsung EVO 500GB 1TB + 500GB HDD LG Bluray Writer + DVD RW Noctua u12p 
OSMonitorKeyboardPower
Windows 10 64Bit Dell u2711 Blackwidow Ultimate EVGA Supernova G2 650w 
CaseMouseAudio
Coolermaster HAF 932 Deathadder 3500dpi KRK Rokit RP6 
  hide details  
Reply
My Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.8 1.256v Asus P6tD Deluxe ATI 5870 12GB Corsair 1600MHz DDR3 
Hard DriveHard DriveOptical DriveCooling
Samsung EVO 500GB 1TB + 500GB HDD LG Bluray Writer + DVD RW Noctua u12p 
OSMonitorKeyboardPower
Windows 10 64Bit Dell u2711 Blackwidow Ultimate EVGA Supernova G2 650w 
CaseMouseAudio
Coolermaster HAF 932 Deathadder 3500dpi KRK Rokit RP6 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI Drivers and Overclocking Software › AMD/ATI site not working properly atm?