Overclock.net › Forums › Graphics Cards › AMD/ATI › BF3 hitting 26 FPS on MEDIUM with a 6970?
New Posts  All Forums:Forum Nav:

BF3 hitting 26 FPS on MEDIUM with a 6970? - Page 6

post #51 of 83
This is NOT a cpu speed problem. BF3 can hit better fps on a dual-core bulldozer: http://www.techspot.com/review/458-battlefield-3-performance/page7.html

BF3 is not a cpu-hog. Whatever is causing these problems, it's not the cpu (assuming that something in the system isn't throttling during play).

OP, have you verified cpu and gpu loads during play? Is one being maxed at 100%? If not, then you have some other issue (whether it be drivers, some other process, etc.).

Is the framerate being hard-limited somehow? Refresh rate of your monitor? I'm grasping, but the speed of the CPU shouldn't be a problem.
    
CPUMotherboardGraphicsRAM
i5-2500K Biostar TP67B+ XFX HD5750 1GB 2x4GB DDR3 Corsair 1600 
Hard DriveOSMonitorPower
60GB OCZ SSD, 2x160GB HDD RAID0, 500GB+500GB+1.5TB Windows 7 Ultimate 64-bit Samsung SyncMaster 930B Antec SmartPower 450w 
Case
Antec 900 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500K Biostar TP67B+ XFX HD5750 1GB 2x4GB DDR3 Corsair 1600 
Hard DriveOSMonitorPower
60GB OCZ SSD, 2x160GB HDD RAID0, 500GB+500GB+1.5TB Windows 7 Ultimate 64-bit Samsung SyncMaster 930B Antec SmartPower 450w 
Case
Antec 900 
  hide details  
Reply
post #52 of 83
Ive got the same exact problem. Even reinstalled windows. newest drivers, everything on medium, and Im not breaking 34 frames. 24 is average. everything high. msaa off. I have to set it to low to be able to get 30+ frames average.
I think its driver related. AMD needs to fix this ASAP. tiered of waiting.
KOMAHDIR
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel I5-2500k  Asus p8z68-v/gen3 Sapphire AMD 290 8GB g-skill snipers @ 1866 9,10,10,28 
Hard DriveCoolingOSMonitor
256 Crucial M4 XSPC,Swiftech,EK windows 8.1 ViewSonic VX2370Smh-LED Black 23" 
PowerCase
Coolermaster 850W Silent Pro Coolermaster CM690 
  hide details  
Reply
KOMAHDIR
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel I5-2500k  Asus p8z68-v/gen3 Sapphire AMD 290 8GB g-skill snipers @ 1866 9,10,10,28 
Hard DriveCoolingOSMonitor
256 Crucial M4 XSPC,Swiftech,EK windows 8.1 ViewSonic VX2370Smh-LED Black 23" 
PowerCase
Coolermaster 850W Silent Pro Coolermaster CM690 
  hide details  
Reply
post #53 of 83
Quote:
Originally Posted by froogle;15570695 
LOL @ this thread. Everyone throwing mud at each-other.

I sense that their is a memory bandwidth problem avec your DDR2 RAM.

nope, i'm running ddr2 ram on an ancient motherboard and i play the game fine.

it's likely amount of ram or driver issue. baaasmiley.gif
Budget Build :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 E0 2.83GHz @ 3.4/3.8GHz ASUS P5B Deluxe XFX 6950 1GB 8GB Crucial Ballistix PC2-6400 4-4-4-12 
Hard DriveOptical DriveOSMonitor
VelociRaptor 150GB + Maxtor 300GB Hitachi 16X DVD-RW Windows 7 Ultimate 64-bit Samsung 24" LCD 
PowerCase
Thermaltake 650W Cooler Master Storm Sniper Black Edition 
  hide details  
Reply
Budget Build :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Q9550 E0 2.83GHz @ 3.4/3.8GHz ASUS P5B Deluxe XFX 6950 1GB 8GB Crucial Ballistix PC2-6400 4-4-4-12 
Hard DriveOptical DriveOSMonitor
VelociRaptor 150GB + Maxtor 300GB Hitachi 16X DVD-RW Windows 7 Ultimate 64-bit Samsung 24" LCD 
PowerCase
Thermaltake 650W Cooler Master Storm Sniper Black Edition 
  hide details  
Reply
post #54 of 83
OP, people who are saying that your CPU is "too old" don't know what they're talking about in the least. My Q9400/GTX560 Ti (a slower card than the 6970) gets 40+ FPS with everything on Ultra (2xAA, HBAO off, motion blur disabled). Something's probably wrong with the driver side.
Limeworks
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9550 ASUS P5E64 WS EVOLUTION MSI GTX560 Ti Twin Frozr II OCZ Reaper HPC Edition 
Hard DriveHard DriveHard DriveHard Drive
Western Digital Caviar Western Digital Caviar Green Western Digital Caviar Green Seagate Barracuda 7200.12 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda 7200.12 HP Lightscribe DVD+RW Burner Thermaltake Frio Windows 7 Ultimate 
MonitorMonitorKeyboardPower
Dell 23" SP2309W Dell 20" 2007FP IBM (Lexmark) Model M Antec NeoPower Blue 650W 
CaseMouseMouse PadAudio
Slightly Modded P180B Logitech G500 Rocketfish SoundMAX Integrated S/PDIF 
AudioAudio
Yamaha RX-V992 Superlux HD681 
  hide details  
Reply
Limeworks
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9550 ASUS P5E64 WS EVOLUTION MSI GTX560 Ti Twin Frozr II OCZ Reaper HPC Edition 
Hard DriveHard DriveHard DriveHard Drive
Western Digital Caviar Western Digital Caviar Green Western Digital Caviar Green Seagate Barracuda 7200.12 
Hard DriveOptical DriveCoolingOS
Seagate Barracuda 7200.12 HP Lightscribe DVD+RW Burner Thermaltake Frio Windows 7 Ultimate 
MonitorMonitorKeyboardPower
Dell 23" SP2309W Dell 20" 2007FP IBM (Lexmark) Model M Antec NeoPower Blue 650W 
CaseMouseMouse PadAudio
Slightly Modded P180B Logitech G500 Rocketfish SoundMAX Integrated S/PDIF 
AudioAudio
Yamaha RX-V992 Superlux HD681 
  hide details  
Reply
post #55 of 83
Quote:
Originally Posted by ChronoBodi;15566716 
yea, BF3 loves MOAR cores and fast, too!

really, it takes an phenom ii x6 or higher-ends i7 quads from both nehalem and sandybridge to feed the GPU fast enough.

^ This, my CPU bottleneck makes me sad, even though I'm sittin on 50-70fps on ultra, 2x msaa.
post #56 of 83
definitely the CPU. i'm having the same problem with my build.
post #57 of 83
Quote:
Originally Posted by guyladouche;15571223 
This is NOT a cpu speed problem. BF3 can hit better fps on a dual-core bulldozer: http://www.techspot.com/review/458-battlefield-3-performance/page7.html

BF3 is not a cpu-hog. Whatever is causing these problems, it's not the cpu (assuming that something in the system isn't throttling during play).

OP, have you verified cpu and gpu loads during play? Is one being maxed at 100%? If not, then you have some other issue (whether it be drivers, some other process, etc.).

Is the framerate being hard-limited somehow? Refresh rate of your monitor? I'm grasping, but the speed of the CPU shouldn't be a problem.

most review sites are basing benchmarks off of single player gameplay, which is pretty much useless. in MP the CPU takes a massive hit, playing with a dual core is literally impossible - max FPS would be 25 or so.
post #58 of 83
Quote:
Originally Posted by naizarak;15571434 
most review sites are basing benchmarks off of single player gameplay, which is pretty much useless. in MP the CPU takes a massive hit, playing with a dual core is literally impossible - max FPS would be 25 or so.

Oh wow, I didn't even think about that. Apologies!

Hmm...I'd def. check cpu usage for sure then.

Also, network lag issues?
    
CPUMotherboardGraphicsRAM
i5-2500K Biostar TP67B+ XFX HD5750 1GB 2x4GB DDR3 Corsair 1600 
Hard DriveOSMonitorPower
60GB OCZ SSD, 2x160GB HDD RAID0, 500GB+500GB+1.5TB Windows 7 Ultimate 64-bit Samsung SyncMaster 930B Antec SmartPower 450w 
Case
Antec 900 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500K Biostar TP67B+ XFX HD5750 1GB 2x4GB DDR3 Corsair 1600 
Hard DriveOSMonitorPower
60GB OCZ SSD, 2x160GB HDD RAID0, 500GB+500GB+1.5TB Windows 7 Ultimate 64-bit Samsung SyncMaster 930B Antec SmartPower 450w 
Case
Antec 900 
  hide details  
Reply
post #59 of 83
Thread Starter 
Quote:
Originally Posted by FlawleZ;15568550 
I ran 1680x1050 mostly high some medium and was hovering in the 40's on a 720 BE 3.5Ghz and overclocked 4850. Your 4870 should have been able to play at moderate settings just fine. Something else is wrong here. I'd say CPU too but even a stock Q9550 shouldn't be THAT bad.

THIS,is what is concerning me most right now. It really, really should've run absolutely fine with my previous setup and while the 6970 did make a huge difference, something is clearly WRONG here, not just insufficient. But I really have no idea what it is, or how to figure it out.

Well, here's an update for you guys.

Today I found my PC powered off, not sure why as I didn't shut it off. Went to turn it on and the 6970 fan instantly hits 100%, and there's no video whatsoever. A little red light on the card lights up. Tried everything, reconnecting everything, swapping back to the 4870 fixed the problem. I called ATI and they say the card's dead, so I'm sending it back to Newegg today. I'm thinking about getting a EVGA 570 after this, perhaps I'll have better luck what with the nvidia chipset in my motherboard. It could be a driver issue, as another user posted he had a similar problem... but again, I can't be sure.
mellowtooth
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2Quad Q9550 @ 2.8 GHz ASUSTeK P5N-E SLI w/ nVidia nForce 650 SLI chip Sapphire Radeon 6970 2GB 4069 MB (DDR2, 4x1024 slots) 
Monitor
1920x1200 
  hide details  
Reply
mellowtooth
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2Quad Q9550 @ 2.8 GHz ASUSTeK P5N-E SLI w/ nVidia nForce 650 SLI chip Sapphire Radeon 6970 2GB 4069 MB (DDR2, 4x1024 slots) 
Monitor
1920x1200 
  hide details  
Reply
post #60 of 83
Quote:
Originally Posted by mellowtooth;15571526 
THIS,is what is concerning me most right now. It really, really should've run absolutely fine with my previous setup and while the 6970 did make a huge difference, something is clearly WRONG here, not just insufficient. But I really have no idea what it is, or how to figure it out.

Well, here's an update for you guys.

Today I found my PC powered off, not sure why as I didn't shut it off. Went to turn it on and the 6970 fan instantly hits 100%, and there's no video whatsoever. A little red light on the card lights up. Tried everything, reconnecting everything, swapping back to the 4870 fixed the problem. I called ATI and they say the card's dead, so I'm sending it back to Newegg today. I'm thinking about getting a EVGA 570 after this, perhaps I'll have better luck what with the nvidia chipset in my motherboard. It could be a driver issue, as another user posted he had a similar problem... but again, I can't be sure.

I'm having the same problem as you. At 1280*1024 on High, FPS will dip down to 40 during Multiplayer. I've pretty much settled on the CPU as the culprit, I'm contemplating switching over to Intel now. I'd imagine you're having the same issue.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › BF3 hitting 26 FPS on MEDIUM with a 6970?