Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire HD 6870 Toxic Edition Droping FPS and lagging while playing ..
New Posts  All Forums:Forum Nav:

Sapphire HD 6870 Toxic Edition Droping FPS and lagging while playing ..

post #1 of 5
Thread Starter 
Hey guys ..
I'm Having a hard time trying to fix my HD 6870 GPU ..
i tried everything is possible .. even i bought a new Power supply , changed the cables .. changed the PC-I Slot .. nothing working .

MY GPU keeps dropping FPS like hell .. i dont feel like games are running smoothly like before , i used to play with GTS 250 with max Settings and everything was fine but now its not good at all with the sapphire HD 6870 Toxic Edition games lagging like hell .

I tested the card with these games :

1. Call of duty Black ops - FPS drops from 60 to 30 or 25 .
2. Call of duty 4 - drops FPS but not that much .
3. Lost Planet 2 - droping FPS
4. Syper Street Fighter 4 -working fine but the average fps when you make a benchmark is something like 190 , i used to have 300 with GTS 250 .
5. Battle Field 3 - the game not stable at all like the screen shaking or something .

so .. there is a problem there and i dont know what to do ..
my PC Spec is ..

# Motherboard : Asus Rampage Extreme III ROG .
# Power Supply : Enermax Revolution 85+ 1250w .
# CPU : Intel I7 960 3.20 GHz 8 Mega Cash .
# Video Card : Sapphire Radeon HD 6870 Toxic Edition .
# Memory : Corsair Vengeance 12GB Triple Channel DDR3 Memory Kit .
# HDD : Western Digital Caviar Black 2 TB SATA III 7200 rpm .
# Chase : Enermax SpineRex .
# Screen : Chimei CMV 938D 19 inch Widescreen LCD .

what should i do .. im so ***** desperate since MW3 is coming and im not able to play games well .
post #2 of 5
Quote:
Originally Posted by itsperfecthit View Post
Hey guys ..
I'm Having a hard time trying to fix my HD 6870 GPU ..
i tried everything is possible .. even i bought a new Power supply , changed the cables .. changed the PC-I Slot .. nothing working .

MY GPU keeps dropping FPS like hell .. i dont feel like games are running smoothly like before , i used to play with GTS 250 with max Settings and everything was fine but now its not good at all with the sapphire HD 6870 Toxic Edition games lagging like hell .

I tested the card with these games :

1. Call of duty Black ops - FPS drops from 60 to 30 or 25 .
2. Call of duty 4 - drops FPS but not that much .
3. Lost Planet 2 - droping FPS
4. Syper Street Fighter 4 -working fine but the average fps when you make a benchmark is something like 190 , i used to have 300 with GTS 250 .
5. Battle Field 3 - the game not stable at all like the screen shaking or something .

so .. there is a problem there and i dont know what to do ..
my PC Spec is ..

# Motherboard : Asus Rampage Extreme III ROG .
# Power Supply : Enermax Revolution 85+ 1250w .
# CPU : Intel I7 960 3.20 GHz 8 Mega Cash .
# Video Card : Sapphire Radeon HD 6870 Toxic Edition .
# Memory : Corsair Vengeance 12GB Triple Channel DDR3 Memory Kit .
# HDD : Western Digital Caviar Black 2 TB SATA III 7200 rpm .
# Chase : Enermax SpineRex .
# Screen : Chimei CMV 938D 19 inch Widescreen LCD .

what should i do .. im so ***** desperate since MW3 is coming and im not able to play games well .

Please fill this, it will be easier to look at the hardware you are working with. http://www.overclock.net/specs.php


Try this:

Shutdown PC. Remove the card to another PCIe slot and make sure the power connector pins are firmly connected.

Does it fix it?


Use GPU-Z check the temperature and core/memory clocks are fluctuating during game play?


Edited by Ken1649 - 11/6/11 at 11:15am
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #3 of 5
Sounds like a heat issue.. The card throttles down when it exceeds 100c...
Could be a bad card or improperly applied thermal compound
Main
(8 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4400  Asrock P67 Extreme Gigabyte GTX 670 Gskill 8GB 8-8-8-24 @ 1.5v 
Hard DriveHard DrivePowerCase
Intel 120GB SSD 520  Dual 1TB Samsung  Coolermaster GX750 Coolermaster CM690 II  
  hide details  
Reply
Main
(8 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4400  Asrock P67 Extreme Gigabyte GTX 670 Gskill 8GB 8-8-8-24 @ 1.5v 
Hard DriveHard DrivePowerCase
Intel 120GB SSD 520  Dual 1TB Samsung  Coolermaster GX750 Coolermaster CM690 II  
  hide details  
Reply
post #4 of 5
Thread Starter 
tomorrow after work ill do what you told me guys ..
wish me luck .
post #5 of 5
Hi guys....I have the same problem and i dont know what to do ..any ideas??
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Sapphire HD 6870 Toxic Edition Droping FPS and lagging while playing ..